After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 273627 - No way to configure mailbox != username
No way to configure mailbox != username
Product: Evolution Exchange
Classification: Deprecated
Component: Connector
Other All
: Normal major
: 2.5
Assigned To: Milan Crha
Ximian Connector QA
: 269942 274168 302255 523605 (view as bug list)
Depends on:
Blocks: 323345 327514
Reported: 2005-03-12 15:10 UTC by Tommi Komulainen
Modified: 2008-07-07 11:04 UTC
See Also:
GNOME target: ---
GNOME version: ---

screenshot (40.00 KB, image/png)
2005-03-28 18:48 UTC, Bryan Christ
logfile (1.88 KB, text/plain)
2005-03-31 19:30 UTC, Bryan Christ
exchangeserver.local/exchange/first.last@domain/ works. my e2debug output - seems to be working at least on the exchange side now (3.32 KB, text/plain)
2005-04-05 11:29 UTC, ximian
logfile with E2KDEBUG=4 (2.90 KB, text/plain)
2005-04-18 18:53 UTC, Bryan christ
evolution log file with E2K_DEBUG=4 (5.63 KB, text/plain)
2005-05-17 10:10 UTC, Ronny Buchmann
Log of exchange connector session, E2K_DEBUG=4 (6.81 KB, application/octet-stream)
2006-03-28 07:37 UTC, Ted Rodriguez-Bell
logfile with E2K_DEBUG=4 (4.33 KB, text/plain)
2007-02-09 22:33 UTC, Bryan christ
proposed eds patch (1.59 KB, patch)
2008-06-03 11:11 UTC, Milan Crha
committed Details | Review
proposed evo patch (4.91 KB, patch)
2008-06-03 11:14 UTC, Milan Crha
committed Details | Review
Updated screen shot . (24.86 KB, image/png)
2008-06-29 20:21 UTC, Chenthill P

Description Tommi Komulainen 2005-03-12 15:10:45 UTC
ximian-connector 2.2.0

Our exchange servers are using DOMAIN\username for authentication, but the
mailbox path is https://server/exchange/firstname.lastname.  There is no
way to configure the mailbox in the account setup.

This is a regression from 2.0.x where there used to be a separate field for
Comment 1 Tommi Komulainen 2005-03-14 09:33:16 UTC
I also tried ximian-connector-setup-2.2 but it failed to authenticate.
 Providing the same values for x-c-s-2.0 proceeds further (but for
probably unrelated reasons the mailbox fails to open still.)
Comment 2 Tommi Komulainen 2005-03-15 18:19:05 UTC
I applied this patch and tried again.

Migration from functional 2.0 setup didn't work, the mailbox failed to
open.  Removed the existing account then.

Running ximian-connector-setup-2.2 and including the mailbox name in
the OWA URL works better, it can now correctly detect all the
information (like 2.0 used to.)

However the mailbox still can not be opened.  Checking the account
information in evolution prefs I see that OWA URL is mysteriously
empty.  The authentication method is also 'secure password'

After (again) entering the OWA URL and changing to 'plaintext
password' I am now able to read my mail again.  Yay!
Comment 3 Sushma Rai 2005-03-16 10:51:46 UTC
Please try re-creating the account using account setup.
Select authentication type as plaintext password, while you 
create the account.
Enter owa url with the mailbox name in it.
Comment 4 Sushma Rai 2005-03-16 11:59:24 UTC
just some modification to my comment..

Please try re-creating the account using account setup.
Enter owa url with the mailbox name in it.

Once your create the account, set the auth type to "plaintext"
and try it?
Comment 5 Tommi Komulainen 2005-03-16 17:29:26 UTC
Had to hit 'Authenticate' twice to get asked for password,
evolution-alarm-notify crashed once the account was created.  But
after changing the authentication method to 'Plaintext' mail works.

Uhh, scary, now everything else seems to be working as well.  I think
there's something fishy going on with x-c-s.
Comment 6 Sushma Rai 2005-03-17 06:17:22 UTC

*** This bug has been marked as a duplicate of 273722 ***
Comment 7 Sushma Rai 2005-03-17 06:18:57 UTC
by mistake marked as duplicate..
Comment 8 Sushma Rai 2005-03-17 13:06:55 UTC
*** bug 269942 has been marked as a duplicate of this bug. ***
Comment 9 Bryan Christ 2005-03-17 21:52:58 UTC
I also need a way to specify the mailbox.  We use DOMAIN\user for
authentication but the mailbox is firstname.lastname

Previous version of Evolution/Connector allowed this specificity. 
Curretnly using the following packages from Fedora Core 4 test 1:

Comment 10 Sushma Rai 2005-03-21 11:33:33 UTC
This should work in 2.2.x
Comment 11 Bryan Christ 2005-03-21 23:06:13 UTC
If it is supposed to work, then how do I specify the mailbox name?  I 
upgraded to package evolution- and still see no place to 
supply that information.
Comment 12 Bryan Christ 2005-03-24 22:35:29 UTC

As far as I can tell, this does not work.  I have tried using the 
following as my OWA and the message back says that there is no such 
mailbox on the server (using my domain name).

Comment 13 Sushma Rai 2005-03-26 08:18:16 UTC
is the correct way to specify the URL.

Can you look at the gconf entry created 
at /apps/evolution/mail/ and see the values of "owa_path" and 
"mailbox" parameters?
owa_path should be set to "/exchange" and
mailbox to "firstname.lastname".
Comment 14 Bryan Christ 2005-03-28 18:48:37 UTC
Created attachment 45032 [details]
Comment 15 Bryan Christ 2005-03-28 18:50:12 UTC
I have attached a screenshot.  As you can see I do not have these
entries under apps->evolution->mail

Have I misunderstood something?
Comment 16 Sarfraaz Ahmed 2005-03-29 07:13:43 UTC
Well, you clicked on evolution and not on "mail". When you click on
"mail" [ this is present under "evolution" ], you will see on the
right hand side an attribute called "accounts". This will have an
entry for each account you have in evolution. [ Yeah the interface
isnt that great, you could actually see it in your file system under
$HOME/.gconf if you like ]. Find the exchange account entry that you
have configured and find the values of the attributes "owa_path" and
Comment 17 Sushma Rai 2005-03-29 10:17:48 UTC
Noticed that owa_path was set as "exchange" and "/exchange".
Not sure if that was causing any problem.

Now fixed that and committed the fix to cvs head and gnome-2-10 branches.
Comment 18 Bryan Christ 2005-03-30 00:14:27 UTC
In HOME/.gconf/apps/evolution/mail I did a 'cat %gconf.xml |grep 
mailbox' and the results returned nothing.  Also no output when grep 
for owa_path
Comment 19 Sushma Rai 2005-03-30 09:05:16 UTC
Authentication itself is failing for you, during account creation?
Or you are able to create the account and while trying to access 
it is failing?

You should use "DOMAIN\user" for user name and for OWA url.

If account creation is failing, get E2K_DEBUG traces for evolution, 
when you try to create the account.

(Run evolution as $E2K_DEBUG=4 <your_prefix>/bin/evolution-2.2 )
Comment 20 ximian 2005-03-31 09:17:44 UTC
*** bug 274168 has been marked as a duplicate of this bug. ***
Comment 21 ximian 2005-03-31 09:19:16 UTC
Are there plans to return the separate username and mailbox name
dialogs to the gui?
Comment 22 Bryan Christ 2005-03-31 19:28:38 UTC
I ran evolution with E2K_DEBUG=4 and am attaching a log file.  Before 
I did that, I deleted my previous account using the "Preferences" 
dialog.  Afterward, I did an evolution --force-shutdown and then I 
launched /usr/bin/evolution-2.2

During the Setup Assistant, I was unable to proceed past the second 
dialog box "Receiving Email".  At this point the "Forward" button is 
disabled because I have not yet authenticated.  When I try to 
authenticate, I get an error saying, "Could not authenticate to the 
Exchagne server.  Make sure that the username and password are 
correct and try again"  I assume this failure is because SPA is being 
used when I need to use plain text.  However, there is no option to 
choose otherwise.  To get past this, I have to set up a "dummy" email 
account (using IMAP or POP) so that I can get into Evolution.  Then I 
add an account which behaves differently.

I am attaching a log of the console messages. 
Comment 23 Bryan Christ 2005-03-31 19:30:42 UTC
Created attachment 45043 [details]
Comment 24 Bryan Christ 2005-03-31 19:32:40 UTC
I should also mention that the logfile contains only information up
until the point where I cancel because the forward button is disabled
in the initial attempt.
Comment 25 ximian 2005-04-05 09:21:22 UTC
I'm confused. There is no file containing the word owa_path under
.gconfd, nor can I find it using a key search with Configuration Editor.
There is an owa_url though.

Using my browser, I can go to
and authenticate using
and it works fine.

Entering the same information into evolution, and watching the debug
messages using the E2K_DEBUG=4 option shows me that evolution is
getting a 404 error.
Comment 26 ximian 2005-04-05 11:29:38 UTC
Created attachment 45064 [details]
exchangeserver.local/exchange/first.last@domain/ works.

my e2debug output - seems to be working at least on the exchange side now

my e2debug output - seems to be working at least on the exchange side now
Comment 27 ximian 2005-04-05 12:43:56 UTC
bryan.christ: IMAP works for me.
I had to make sure the Alias section for my account was correct. I
changed it from first.last to username.
Comment 28 Bryan Christ 2005-04-05 19:31:34 UTC
I have no problem with IMAP.  I am trying to connect to my Exchange 
server (this is done via the webdav protocol).

Sushma:  I think there are several relevant questions.  Is there a 
possible workaround given my current situation (edit gconf data, 
etc)?  What future version will provide the necessary override fields 
for mailbox and password mechanisms?
Comment 29 Sushma Rai 2005-04-06 07:51:08 UTC
Try next version 2.2.2, of Evo and connector, 
which will be available next week.
That should fix the problem I feel.

With 2.2.2
Re-create the account with
URL as
and user name as "DOMAIN\user"

If you have problem with authenticate type, you can set it in account
editor once the account is created.

Comment 30 Bryan Christ 2005-04-08 21:54:29 UTC
Okay.  I will retest when 2.2.2 becomes available.
Comment 31 Bryan christ 2005-04-12 15:48:40 UTC

I have retested this bug with version 2.2.2.  I followed the steps above to
recreate the problem, but the problem still exists.  Here's what I did:

1.  Proceed to recreate new account.
2.  Set URL to
3.  Set username to DOMAIN\user
4.  Could not authenticate therefore the "forward" button was not enabled
5.  Changed type to IMAP in order to set up a "dummy" account and enable
"forward" button
6.  When the Evolution main window appeared I went to properties and changed the
type to exchange, made sure the URL was correct, and set the authentication
method to "plain text"
7.  Quit Evolution
8.  Restarted backend (evolution --force-shutdown)
9.  Received message "No mailbox for user NAME on" after
entering password
Comment 32 Sushma Rai 2005-04-15 04:43:16 UTC
Can you try creating the account using tool ximian-connector-setup-2.2  ?
Comment 33 lsof 2005-04-15 07:04:02 UTC
WFM - Excellent :)

One question - why does the wizard require a replica be entered, and not work
with the GCS in the second field?
Comment 34 Bryan christ 2005-04-15 14:59:57 UTC

It did not work for me.  I got a message:

"Could not authenticate to the Exchange server.  Make sure the username and
password are correct and try again."

I think this is because the default mechanism might be secure password and not
plain text authentication.  Is my assumption correct?  If so, there needs to be
a way to choose the authentication method.

Also, I noticed that after I received the error, my username gets truncated from
domain\user to simply user in the dialog box.
Comment 35 lsof 2005-04-15 15:18:40 UTC
I had the same problem with a truncated username, but user@domain worked (which
is what I tend to use anyway).

For the OWA url I had to use server/exchange/first.last/, i.e. the same url that
OWA uses if you open the right-pane in a new frame.
Comment 36 Bryan christ 2005-04-15 17:26:51 UTC

Thanks for the tip, but that also did not help.  It did resolve the truncation
problem, but I think the root cause, in my case, is that our server uses plain
text authentication and I am not able to choose that.
Comment 37 Sushma Rai 2005-04-16 05:29:03 UTC
Bryan, can you export E2K_DEBUG=4 and run Evolution-2.2 from the same console and
attach the traces here when u try create account using Evolution (not x-c-s)?
Connector actually reads the server response and decides on plain text or secure
authentication. Need to see where it fails.

Comment 38 Bryan christ 2005-04-18 18:52:17 UTC
Okay.  I am attaching the log.
Comment 39 Bryan christ 2005-04-18 18:53:22 UTC
Created attachment 45410 [details]
logfile with E2KDEBUG=4
Comment 40 Bryan christ 2005-04-26 16:00:40 UTC
Sushma:  Has the logfile revealed anything for you?
Comment 41 Bryan christ 2005-05-09 15:09:15 UTC
I found a bug report at
which is sounds *very* similar.  Initially, it is a discussion of evo 1.4 vs evo
2.0 but it becomes more relevant as you read down the page.  Looks like there
was a patch applied to correct the problem in 2.0.  It also looks like it was
*supposed* to be checked-in for 2.2.  Maybe it didn't?

I hope to hear back from you, using the MS web interface is getting tiresome.
Comment 42 Sarfraaz Ahmed 2005-05-14 11:06:51 UTC
Yes, #66926 was about FBA not working .. This has been fixed and the fix is also
there in the 2.2 branch. From the traces, the login is failing for
authentication. Few places where you could look for are ..
1. Do you have openldap with the NTLM patch applied ?
2. If you have SSL enabled on your server, you will have to use a "https://" as
your OWA url. Are you sure that your server is not SSL enabled?
3. Also, could you let us know if you are able to create the account using x-c-s ?

[ Also, please reopen the bug once you attach some information. ]
Comment 43 Bryan christ 2005-05-16 14:20:48 UTC
1.  How would I know of openldap has the NTLM patch applied?  I am using the 
version with Fedora Core 4 test 3.
2.  I do not use https:// when accessing MS OWA.
3.  I have been unsuccessfully in creating an account with x-c-s.

Comment 44 Dave Malcolm 2005-05-16 22:02:42 UTC
Fedora Core's evolution-connector package statically links to a version of
OpenLDAP with the NTLM patch applied (openldap-devel provides a
/usr/lib/evolution-openldap/ which we statically link the Connector against)

Bryan: what happens if you simply telnet into port 80 of the Exchange server and
type something like this:
GET /exchange HTTP/1.1
Host: name of exchange server

What's the response from the server (in particular, what are the
WWW-Authenticate: lines?)
Comment 45 Ronny Buchmann 2005-05-17 10:08:18 UTC
With ximian-connector-setup-2.2 I can setup the account and succesfully connect
in evolution.

The account setup in evolution still doesn't work.
I get no error message when presssing "Legitimation", but "Forward" stays disabled.
Comment 46 Ronny Buchmann 2005-05-17 10:10:04 UTC
Created attachment 46536 [details]
evolution log file with E2K_DEBUG=4

last step was pressing Legitimation
Comment 47 Bryan christ 2005-05-17 19:11:15 UTC

I get no response from the server when I telnet in on port 80 and issue "GET
/exchange HTTP/1.1" (without the quotes obviously).  I know the server is
listening because if I just do "GET" the response is:

HTTP/1.1 400 Bad Request
Content-Type: text/html
Date: Tue, 17 May 2005 19:10:38 GMT
Connection: close
Content-Length: 35

<h1>Bad Request (Invalid Verb)</h1>Connection closed by foreign host.
Comment 48 Bryan christ 2005-05-17 19:15:47 UTC
I tried again with x-c-s but still was unable to create an account.
Comment 49 Ronny Buchmann 2005-05-22 17:33:39 UTC
Brian, maybe you forgot the "Host: servername" line? HTTP/1.1 needs this.

if you have an ssl enabled server you can use:

$ openssl s_client -connect servername:443 -quiet
GET /exchange HTTP/1.1
Host: servername
<empty line>

Comment 50 Bryan christ 2005-05-26 15:54:26 UTC

Thanks for the tip.  Here's the results from telneting to the server:

Connected to (
Escape character is '^]'.
GET /exchange HTTP/1.1

HTTP/1.1 401 Unauthorized
Content-Length: 83
Content-Type: text/html
Server: Microsoft-IIS/6.0
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
WWW-Authenticate: Basic realm=""
MicrosoftOfficeWebServer: 5.0_Pub
X-Powered-By: ASP.NET
Date: Thu, 26 May 2005 15:50:46 GMT

<html><head><title>Error</title></head><body>Error: Access is Denied.</body></html>
Comment 51 Bryan christ 2005-07-19 19:44:17 UTC
Any progress on this?
Comment 52 Vesa Halttunen 2005-08-12 15:35:38 UTC
Same problem here. FC4 x86_64, Evolution 2.2.3, connector 2.2.2. Fix badly needed.
Comment 53 Bryan christ 2005-08-16 17:51:10 UTC
It seems to me the problem could be resolved by using the old evo 1.4 style
configuration dialog which allows you to override the mailbox name.  As it
stands, I can either supply domain\user and properly authenticate, but then get
a message "mo mailbox for USERNAME found on this server" (that was a
paraphrase).  If I supply, the proper mailbox name (first.last) then I fail to
authenticate.  I would think that in
combination with domain\username would work, but it doesn't.  I have even gone
back and change auth type from SPA to plain-text but I still get the "no mailbox
for USERNAME..." message.

*Please help*  Using RDP just to access Outlook and get my calendar is quite
cumbersome and tiersome.
Comment 54 Poornima 2005-10-17 17:13:54 UTC
Changed the state of bug as reporter has given reply to all queries
Comment 55 Sushma Rai 2005-12-02 12:55:26 UTC
increasing the priority.
Comment 56 Bryan christ 2006-02-17 22:41:57 UTC
Any update on this?
Comment 57 Bryan christ 2006-03-10 15:42:12 UTC
I was finally able to get some level of connectivity using Evolution 2.5.92 and Connector 2.5.92 on Fedora Core 5 test 3.  However, I was unable to create my account using the default "wizard".  Instead, I had to use ximian-connector-setup-2.6.  Otherwise, I ran into the same error.
Comment 58 Sushma Rai 2006-03-11 07:16:27 UTC
for x-c-s, what is the format of the URL and user name you provided?

Comment 59 Bryan christ 2006-03-13 16:24:52 UTC

I cannot recall the exact text which i typed in for x-c-s.  Is there anyway to retrive that string value?
Comment 60 Bryan christ 2006-03-16 16:36:22 UTC

I accidentally changed a setting in the Account Edtior->Receiving Email.  In that dialog box I changed it from domain\login (using backslash) to domain/login (using forwardslash).  To say the least, it ruined my configuration.  Evolution kept trying to connect to a server that *was not* my OWA URL.  Even when I changed it back to forwardslash it was still trying to connect to this other server.  There is definitely a difference between x-c-s and "Receiving Email tab" configuration.

Fortunately for you, this meant that I had to delete my account and use x=c=s to setup my account again.  Here are the is the format of the URL which I used in x-c-s (your answer for comment 58).

     ^^^ notice the forwardslash

I know that I have stated this before, by my NT login and Exchange Mailbox names are different.  My exchange mailbox is firstname.lastname and my login is a different.
Comment 61 Sushma Rai 2006-03-17 05:50:36 UTC
Thanks for the information.
The code handles both "/" and "\", anyway I will look into this.
Comment 62 Ted Rodriguez-Bell 2006-03-28 07:37:41 UTC
Created attachment 62182 [details]
Log of exchange connector session, E2K_DEBUG=4

Ted Rodriguez-Bell evolution-exchange-storage session
Comment 63 Ted Rodriguez-Bell 2006-03-28 07:38:16 UTC
I'm having the same problem as Brian.  I created my account with ximian-connector-setup-2.6; this is FC5.  My ID is trb, my mailbox is tedrb.  The Exchange servers are exchange-server02 and 19; the OWA URL I entered was; it bounces to exchange-server02.mycompany.corp and exchange-server19.mycompany.corp

I entered my ID and password four times:  twice on startup and twice after I clicked on the Exchange mailbox.
Comment 64 Sushma Rai 2006-04-04 09:29:48 UTC
Ted Rodriguez-Bell, works for you?
Comment 65 Ted Rodriguez-Bell 2006-04-04 17:37:04 UTC
It does with Evolution 2.0.4 and 1.4.  It does not with subsequent versions.  This is a regression problem

The attachment I made in Comment 62 was using /tedrb.
Comment 66 Sushma Rai 2006-04-18 15:11:46 UTC
Ted Rodriguez-Bell,
If you try to create account using ximian-account-setup will it work?
Comment 67 Sushma Rai 2006-04-18 15:13:10 UTC
sorry, I meant ximian-connector-setup tool.
Comment 68 Ted Rodriguez-Bell 2006-04-19 18:55:58 UTC
No, I've been using ximian-connector-setup-2.6 and it doesn't work.  That's what's in the attached error output from 28 March.

The initial setup works; connector-setup takes my password, talks to our Active Directory server, and finds my screen name and email ID.  When I run evolution it prompts me for a password twice and then says that I must have entered the password or account name wrong.  I didn't.

Is there any other information you need to help resolve this?
Comment 69 Sushma Rai 2006-04-20 04:43:21 UTC
I have a test server where my windows logon id is "rsushma",
my mail ID is "" and my mailbox name (alias)
is "sush"
and creating the account using Evolution account setup, it works fine
for me with owa url "" and username "rsushma".

Anyone here has any idea, what I am missing and how can I setup an account
where my mailbox path is different than userid in Exchange server?
Comment 70 Bryan christ 2006-04-20 14:28:33 UTC
I know that in my case, exchange was accessed via http and not https.  Also, my username is DOMAIN\USERNAME
Comment 71 Ted Rodriguez-Bell 2006-04-20 17:59:35 UTC
Our Exchange setup uses https, not http.  I can connect to OWS from a browser with https: and not http:.  The browser method doesn't care if I say DOMAIN\username or just username; neither does connector-setup.  Evolution doesn't care either; it fails both ways.

When I go in through the browser I get asked if I'm sure because the certificate has expired and because it points to Exchange-server instead of  I also noticed I'm getting the message
  ** (evolution:18360): WARNING **: Unexpected kerberos error -1765328164
from Evolution.  Could that be part of it?

I've left a level 4 trace of the exchange-connector output here; is there anything else I can do?

Thanks for the suggestions!
Comment 72 Luke Hewitt 2006-09-22 00:22:26 UTC
I have the same problem:

The url given by the menu in the OWA is:

but my login is different.

The authentication button in the setup works, but it tries to guess the folder and messes up giving me an authentication failure.

Comment 73 Bryan christ 2007-01-30 16:58:38 UTC
For quite some time, connector was working properly for me.  As long as I used the "setup wizard" to configure my exchange server, everything worked fine.  If I tried to change the exchange server settings in the "Receiving Mail" tab, the I would have authentication problems.

Today, our IT dept. moved my mailbox to a new exchange server.  I grabbed the new fqdn from my outlook client which I'll call  The full OWA path to my mailbox on this new server appears to be:

However, when I login in, I somehow get redirected to server_y.  The peculiar thing is that I can login to using my browser.  However, if I do that, I get redirected to server_x.

As best I can guess, server_y must be some sort of authentication server and server_x is where my mailbox actually resides.  When Connector trys to auth with server_x he gets redirected to server_y, but somehow manages to mangle my credentials in the process.  My Windows login is domain\username and I noticed that Connector passes \username to server_y.  I deduce this because I get prompted for a password for \ (notice that the domain is missing before the slash).
Comment 74 Bryan christ 2007-01-30 19:41:47 UTC
As addtl. information regarding comment #73, I should mention that I am using more recent versions of Evolution and Connector.  My fc packages are:

Comment 75 Veerapuram Varadhan 2007-02-07 15:30:38 UTC
What is your OWA_URL and username in the "Edit->Preferences->Receiving Mail" tab?

And can you get E2K_DEBUG trace for Evolution (during the authentication process)?
Comment 76 Bryan christ 2007-02-07 17:44:24 UTC
Veerapuram:  I looked in the preferences and noticed that my username was not set to "domain\username" but instead was truncated to "username".  I am certain that when I went through the account setup wizard I supplied "domain\username".  Now that I have corrected it, I can no longer open the preferences dialog box.  When I try, Evolution just freezes.  I have even tried by starting Evolution with --offline but that still does not help.  I have also tried restarting Evolution by first doing a --force-shutdown.

As for the debug, I just need to 'export E2K_DEBUG=[debug_level]' and then run Evo from the terminal right?  If so, what debug level do you want me to supply?
Comment 77 Veerapuram Varadhan 2007-02-07 19:45:21 UTC
E2K_DEBUG=4 should be okay.  Also, what is your owa_url in the "Receiving Mail" tab?
Comment 78 Bryan christ 2007-02-07 20:38:16 UTC
Veerapuram:  I will run the debug soon, but as I mentioned in comment #76, I can no longer go into preferences.
Comment 79 Bryan christ 2007-02-09 22:33:20 UTC
Created attachment 82252 [details]
logfile with E2K_DEBUG=4
Comment 80 Bryan christ 2007-02-09 22:34:21 UTC
Veerapuram:  Comment #79 is the E2K_DEBUG you asked for.
Comment 81 Veerapuram Varadhan 2007-02-10 06:19:23 UTC
(In reply to comment #79)
> Created an attachment (id=82252) [edit]
> logfile with E2K_DEBUG=4
According to the log, it has authenticated successfully - can you get gdb traces when evolution freezes? (while accessing Edit->Preferences)

Just in case:
1) Find the pid of evolution that just froze
2) gdb -p <pid>
3) In the gdb prompt:
        gdb> thread apply all bt
4) copy and past the traces to the bug.
Comment 82 Bryan christ 2007-02-12 16:17:55 UTC
Veerapuram:  Somehow preferences didn't hang this time :/  My ows_url is:

Comment 83 Bryan christ 2007-03-06 16:23:47 UTC
Retested with Evolution 1.8.3 and problem still happens:
(packages feteched via yum on fc6)
Comment 84 Bryan christ 2007-03-06 16:25:25 UTC
typo in comment #83 Evolution = 2.8.3
Comment 85 Bryan christ 2007-06-14 18:39:50 UTC
Retested with evolution 2.10 and connector 2.10.  The problem still exists.

Comment 86 Matthew Barnes 2008-03-11 00:50:38 UTC
Bumping version to a stable release.
Comment 87 Milan Crha 2008-06-03 11:11:43 UTC
Created attachment 112042 [details] [review]
proposed eds patch

for evolution-data-server;

This is necessary to be able to pass to the e2k_validate_user a mailbox name we want to use and not parse the mailbox name from the home_uri. (So in case you've the old eds and new evo, then you'll see the mailbox name will change back to the "default" after validate).
Comment 88 Milan Crha 2008-06-03 11:14:57 UTC
Created attachment 112044 [details] [review]
proposed evo patch

for evolution;

For exchange-operation plugin, to show and work with an UI entry.
Comment 89 Srinivasa Ragavan 2008-06-04 05:12:26 UTC
Bharath: Can you look at it ?
Comment 90 Bharath Acharya 2008-06-04 06:41:39 UTC
Srini, Akhil is on leave. Would get it tested for this scenario once he's back and then proceed. Milan a week's wait on this one :) hope you don't mind
Comment 91 Bharath Acharya 2008-06-14 11:20:29 UTC
Can anyone try out this patch if they do have the scenario mentioned. I don't have a setup to test this. Patch looks good to me. But I would like someone to verify it out.
Comment 92 Chenthill P 2008-06-16 10:28:31 UTC
Very nice patch!! The patch seems to work fine with the current setup and should work fine in the setup where mailbox and username are different too. This patch can be committed to svn HEAD.  I think we should request for a freeze break from the release team and get this patch in stable branch too once someone verifies as bharath has mentioned. But if no one is able to respond quick enough, we can go ahead and request for the freeze break. IMHO this is a blocker in certain setups.

Bharath, what do you feel?
Comment 93 Bharath Acharya 2008-06-16 10:55:15 UTC
Yup. If someone can just verify it out I'll be overjoyed. Commit to Trunk. 

and to Stable if freeze break approved. Thanks.
Comment 94 Milan Crha 2008-06-16 11:41:31 UTC
eds part committed to trunk. Committed revision 8986.
evo part committed to trunk. Committed revision 35642.
Comment 95 André Klapper 2008-06-16 11:46:10 UTC
hmm, did chen CC me because his browser plugin beeped when he wrote "freeze break"? :-)
This is a string break, an UI break, and the documentation has to be updated. Feel free to use the normal channels for a request, but do it earlier than on the friday evening before monday's tarballs due. ;-)
Comment 96 Chenthill P 2008-06-18 05:59:47 UTC
Andre, yeah :) Milan, please send a mail to the release team and CC'ing doc team requesting for a freeze break for committing to the stable branch.
Comment 97 Milan Crha 2008-06-18 07:47:24 UTC
e? I'm sorry for my ignorance, but what are those addresses? I like coding, the paper work is not my part at all.
Comment 98 Chenthill P 2008-06-18 08:52:16 UTC
Here is the link which explains it :)
Comment 99 André Klapper 2008-06-18 13:12:27 UTC
@chen: the link also lists the required teams. your list was not complete. ;-)
Comment 100 André Klapper 2008-06-18 13:14:24 UTC
if you send an email to the r-t, it would be helpful to tell us whether the userdocs will be updated in the next days, and whether screenshots are affected or not. if you want to save some time (harhar), then please at least attach a screenshot here that shows the UI changes and link to it in your request.
Comment 101 Radhika PC 2008-06-28 07:45:34 UTC
updated the user guide with text and new screenshot
Comment 102 André Klapper 2008-06-28 11:56:44 UTC
Actually having the user documentation patch against upstream SVN evolution.xml and the two new screenshots attached here would be very nice.
Comment 103 Chenthill P 2008-06-29 20:20:21 UTC
Patches have been committed to stable branch. The screen shot exchng-rec-mail.png is not updated since the MailBox field does not appear while editing an account. This should be fixed for HEAD.
Comment 104 Chenthill P 2008-06-29 20:21:39 UTC
Created attachment 113641 [details]
Updated screen shot .
Comment 105 Milan Crha 2008-07-07 11:04:15 UTC
*** Bug 523605 has been marked as a duplicate of this bug. ***
Comment 106 Milan Crha 2008-07-07 11:04:46 UTC
*** Bug 302255 has been marked as a duplicate of this bug. ***