GNOME Bugzilla – Bug 644086
Inform the user if a channel is for SMS
Last modified: 2011-05-05 07:44:21 UTC
The SMS.SMSChannel property defines whether or not a channel is used for SMS. http://telepathy.freedesktop.org/spec/Channel_Interface_SMS.html#Property:SMSChannel I am proposing that SMS channels replace the user's presence with a picture of a mobile phone, since the presence is a lot less useful. We should also add some text to indicate it's an SMS channel. Perhaps in the chat window itself.
Agreed. We could have "SMS with Alice" or "Alice (SMS)" or something.
Created attachment 185381 [details] [review] SMS support for Empathy http://git.collabora.co.uk/?p=user/danni/empathy.git;a=shortlog;h=refs/heads/sms-support This patch adds a menu item for requesting SMS channels on contacts that support it, and adds an icon + text to chat windows that are for sending SMSes. Depends on #644085
Review of attachment 185381 [details] [review]: Looks pretty good. Not directly related; but we should keep bug #647000 in mind while implementing this. ::: libempathy/empathy-dispatcher.h @@ +74,3 @@ +empathy_dispatcher_sms_contact_id (TpAccount *account, + const gchar *contact_id, + gint64 timestamp); empathy-dispatcher has been dropped in master; this should be in libempathy/empathy-request-util now. ::: libempathy-gtk/empathy-chat.c @@ +173,1 @@ }; I'd rename it dup_name() to make clearer it returns a new leak. (and renaming will also ensure that you have checked all the calls :) ::: src/empathy-chat-window.c @@ +670,3 @@ } + else if (empathy_chat_is_sms_channel (chat)) { + icon_name = EMPATHY_IMAGE_SMS; Is that translator friendly?
(In reply to comment #3) > empathy-dispatcher has been dropped in master; this should be in > libempathy/empathy-request-util now. Ok. Should this util be backported to 2.34, or should we just change the code that gets merged to master? > I'd rename it dup_name() to make clearer it returns a new leak. > (and renaming will also ensure that you have checked all the calls :) Done (and squashed in). > ::: src/empathy-chat-window.c > @@ +670,3 @@ > } > + else if (empathy_chat_is_sms_channel (chat)) { > + icon_name = EMPATHY_IMAGE_SMS; > > Is that translator friendly? How do you mean? Why do we translate icon-names?
(In reply to comment #4) > > ::: src/empathy-chat-window.c > > @@ +670,3 @@ > > } > > + else if (empathy_chat_is_sms_channel (chat)) { > > + icon_name = EMPATHY_IMAGE_SMS; > > > > Is that translator friendly? > > How do you mean? Why do we translate icon-names? Ok ignore that, I don't remember what I meant (I blame my cold).
Created attachment 185766 [details] [review] now including a bug fix One more patch, being this very important bug fix for channels without Chan.I.SMS. http://git.collabora.co.uk/?p=user/danni/empathy.git;a=commitdiff;h=4a6c023d435bf3346e5232ef835770cbbe2499ab
Review of attachment 185766 [details] [review]: ::: libempathy/empathy-tp-chat.c @@ +65,1 @@ } EmpathyTpChatPriv; This name is a bit miss leading. 'waiting_sms_channel' or 'fetching_sms_channel' maybe?
(In reply to comment #7) > This name is a bit miss leading. 'waiting_sms_channel' or > 'fetching_sms_channel' maybe? I copied the name from got_password_flags. I think it should remain the same for consistency.
fair enough; ++
Merged into master.