GNOME Bugzilla – Bug 739839
Add Back and Forward mouse button constants in GDK
Last modified: 2018-05-02 16:17:52 UTC
Mouses with back/forward buttons exist, but unfortunately I haven't found the constants for these buttons in gtk+/gdk. Some facts: * java-gnome has constants defined for these [1] and I can confirm the values are 8 and 9 indeed, although I have only tested with a single mouse * GDK has constants defined GDK_BUTTON_PRIMARY[2], GDK_BUTTON_SECONDARY and GDK_BUTTON_MIDDLE, so the best place for the new constants would be along these constants * GdkEventButton docs say that the button value from the structure is between 1 and 5, which is obviously not the case for 8 and 9, so the docs will also need an update [1] http://java-gnome.sourceforge.net/doc/api/4.1/org/gnome/gdk/MouseButton.html [2] https://developer.gnome.org/gdk3/stable/gdk3-Events.html#GDK-BUTTON-PRIMARY:CAPS [3] https://developer.gnome.org/gdk3/stable/gdk3-Event-Structures.html#GdkEventButton
Marked several reports requesting mouse back-forward button support in GTK+ apps as blocked by this one. Even more proof that 8 and 9 should be the codes to use is that some of these bugs have patches attached, and all of them are using 8 and 9 as button codes. Marking as NEW based on the number of blocked reports.
the reason we added the symbolic constants was because it brought us on par with other toolkits; the general consensus is to only name the first three buttons, though — see bug 668688, which has links to other API references. I'm slightly less inclined to add symbolic constants for buttons >5, considering that people, especially on X11, tend to remap those buttons. in theory, wouldn't make more sense to have those pointers with tons of buttons emit key codes? back and forward keys are already mapped to GDK_KEY_Back and GDK_KEY_Forward key symbols. I know that X11 has issues with hybrid devices that expose both buttons and keys, but I think that's the right place to solve the issue, rather than hardcoding buttons >3 inside GDK.
adding Carlos, since he's working on the GDK input layer.
(In reply to comment #2) > the reason we added the symbolic constants was because it brought us on par > with other toolkits; the general consensus is to only name the first three > buttons, though — see bug 668688, which has links to other API references. > > I'm slightly less inclined to add symbolic constants for buttons >5, > considering that people, especially on X11, tend to remap those buttons. Given that people remap them so that the numbers (eg. button 5) generate other numbers (eg. button 8) so the action they take corresponds to what's expected (eg. "Back"), you seem to support adding a constant. Applications expect button 8 to be the back button, whether GDK defines it or not. Having the constant in GDK would save us having magic numbers in all the applications. > in theory, wouldn't make more sense to have those pointers with tons of buttons > emit key codes? back and forward keys are already mapped to GDK_KEY_Back and > GDK_KEY_Forward key symbols. I know that X11 has issues with hybrid devices > that expose both buttons and keys, but I think that's the right place to solve > the issue, rather than hardcoding buttons >3 inside GDK. If it were easy, we'd have done it that way before. The problem is that mouse button clicks don't act like keyboard keys, they carry extra context (the location of the pointer, whether keyboard modifiers are pressed) that keyboard clicks don't.
(In reply to comment #4) > (In reply to comment #2) > > the reason we added the symbolic constants was because it brought us on par > > with other toolkits; the general consensus is to only name the first three > > buttons, though — see bug 668688, which has links to other API references. > > > > I'm slightly less inclined to add symbolic constants for buttons >5, > > considering that people, especially on X11, tend to remap those buttons. > > Given that people remap them so that the numbers (eg. button 5) generate other > numbers (eg. button 8) so the action they take corresponds to what's expected > (eg. "Back"), you seem to support adding a constant. > > Applications expect button 8 to be the back button, whether GDK defines it or > not. Having the constant in GDK would save us having magic numbers in all the > applications. the constants would be: #GDK_BACKWARD_BUTTON (8) #GDK_FORWARD_BUTTON (9) so if somebody remapped button 8 and 9 to do something other than back/forward it would be fairly odd. there's also the issue of whether or not these numbers would be supported elsewhere. we are okay supporting 1, 2, and 3 everywhere, but if we add back/forward constants it may give the impression that these values will work on MacOS or Windows as well. it's also stomping fairly hard on the global namespace. > > in theory, wouldn't make more sense to have those pointers with tons of buttons > > emit key codes? back and forward keys are already mapped to GDK_KEY_Back and > > GDK_KEY_Forward key symbols. I know that X11 has issues with hybrid devices > > that expose both buttons and keys, but I think that's the right place to solve > > the issue, rather than hardcoding buttons >3 inside GDK. > > If it were easy, we'd have done it that way before. I'm not saying it's easy. I'm saying it may be more worthwhile fixing this in a different way than just adding symbolic constants mapping to integers to the global GDK namespace. > The problem is that mouse > button clicks don't act like keyboard keys, they carry extra context (the > location of the pointer, whether keyboard modifiers are pressed) that keyboard > clicks don't. keyboard modifiers are also available for key events, and we can have ancillary data for GdkEvent in case a key event is generated from a GdkDevice slaved to a pointer device. after all, isn't that how we handle things like tablets, which expose multiple input devices, and that can have both pointer-like and keyboard-like behaviour?
(In reply to comment #5) > (In reply to comment #4) > > (In reply to comment #2) > > > the reason we added the symbolic constants was because it brought us on par > > > with other toolkits; the general consensus is to only name the first three > > > buttons, though — see bug 668688, which has links to other API references. > > > > > > I'm slightly less inclined to add symbolic constants for buttons >5, > > > considering that people, especially on X11, tend to remap those buttons. > > > > Given that people remap them so that the numbers (eg. button 5) generate other > > numbers (eg. button 8) so the action they take corresponds to what's expected > > (eg. "Back"), you seem to support adding a constant. > > > > Applications expect button 8 to be the back button, whether GDK defines it or > > not. Having the constant in GDK would save us having magic numbers in all the > > applications. > > the constants would be: > > #GDK_BACKWARD_BUTTON (8) > #GDK_FORWARD_BUTTON (9) > > so if somebody remapped button 8 and 9 to do something other than back/forward > it would be fairly odd. Remapped how? The only thing you can do with mouse buttons is swap numbers around. There's no "symbolic action" for the buttons, equivalent to keymaps for keyboard keys. > there's also the issue of whether or not these numbers would be supported > elsewhere. we are okay supporting 1, 2, and 3 everywhere, but if we add > back/forward constants it may give the impression that these values will work > on MacOS or Windows as well. it's also stomping fairly hard on the global > namespace. That's certainly a better reason to not accept a patch for this, at least until some research is done on that side. MacOS X supports extra mouse buttons, but "The Application Kit does not define any default behavior for third (“other”) mouse buttons", and we don't know what the drivers for those mice would trigger on OSX either. I couldn't find what Windows does in those cases.
(In reply to comment #6) > Remapped how? The only thing you can do with mouse buttons is swap numbers > around. There's no "symbolic action" for the buttons, equivalent to keymaps for > keyboard keys. > In theory, XIQueryDeviceInfo can give us 'button labels' as atoms in the XIButtonClassInfo struct: ⎜ ↳ TPPS/2 IBM TrackPoint id=14 [slave pointer (2)] Reporting 3 classes: Class originated from: 14. Type: XIButtonClass Buttons supported: 5 Button labels: "Button Left" "Button Middle" "Button Right" "Button Wheel Up" "Button Wheel Down" ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ But who knows if this is going to yield useful and reliable information that allows to identify back/forward buttons...
(In reply to comment #7) > But who knows if this is going to yield useful and reliable information that > allows to identify back/forward buttons... Here's the info from my mouses (I hope I got the right device), even though they both have some buttons labeled "Button unknown", they both have "Button Forward" and "Button back" Mouse 1. ⎜ ↳ A4TECH USB Device id=9 [slave pointer (2)] Reporting 7 classes: Class originated from: 9. Type: XIButtonClass Buttons supported: 24 Button labels: "Button Left" "Button Middle" "Button Right" "Button Wheel Up" "Button Wheel Down" "Button Horiz Wheel Left" "Button Horiz Wheel Right" "Button Side" "Button Extra" "Button Forward" "Button Back" "Button Task" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" Mouse 2. ⎜ ↳ A4Tech USB Optical Mouse id=12 [slave pointer (2)] Reporting 7 classes: Class originated from: 12. Type: XIButtonClass Buttons supported: 14 Button labels: "Button Left" "Button Middle" "Button Right" "Button Wheel Up" "Button Wheel Down" "Button Horiz Wheel Left" "Button Horiz Wheel Right" "Button Side" "Button Extra" "Button Forward" "Button Unknown" "Button Unknown" "Button Unknown" "Button Unknown" I hope this helps. If you need any more info, feel free to ask.
Any updates on this? I would really like to have support for this. If we manage to decide on the details, I could come up with a patch, or if it's not going to happen, let's close this as WONTFIX.
-- GitLab Migration Automatic Message -- This bug has been migrated to GNOME's GitLab instance and has been closed from further activity. You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.gnome.org/GNOME/gtk/issues/515.