After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 729010 - Can't copy a file from SMB share to the local file system: Software caused connection abort
Can't copy a file from SMB share to the local file system: Software caused co...
Status: RESOLVED DUPLICATE of bug 729298
Product: nautilus
Classification: Core
Component: File and Folder Operations
Other Linux
: Normal major
: ---
Assigned To: Nautilus Maintainers
Nautilus Maintainers
Depends on:
Reported: 2014-04-26 09:28 UTC by Jan Goyvaerts
Modified: 2014-05-03 18:36 UTC
See Also:
GNOME target: ---
GNOME version: ---

Screenshot of Nautilus of the error. (74.81 KB, image/png)
2014-04-26 09:28 UTC, Jan Goyvaerts
The demanded log file (119.16 KB, text/plain)
2014-05-03 10:12 UTC, Jan Goyvaerts

Description Jan Goyvaerts 2014-04-26 09:28:13 UTC
Created attachment 275196 [details]
Screenshot of Nautilus of the error.

The error reported is "Software caused connection abort". See the screenshot.

  It pops up right at the end of the copy operation. This doesn't happen
  when copying the very same file using a different protocol. Neither
  does it happen when using another device to copy the very same file
  over SMB.

  It worked until the upgrade from 13.10 to 14.04.

  Also see
Comment 1 Ross Lagerwall 2014-05-02 06:26:23 UTC
Thanks for the report.

Please run the following in a terminal:
pkill gvfs; GVFS_DEBUG=all GVFS_SMB_DEBUG=10 `find /usr/lib* -name 'gvfsd'` &> ~/log.txt

Then mount the smb share, reproduce the problem, and then upload log.txt in your home directory so we can see a log of what is happening.  If possible, it would be good if you could do the same but reproduce the problem using the gvfs command-line tools; e.g. gvfs-copy smb://host/path/to/image.jpg ~/Downloads/image.jpg

Please also indicate what smb server you are using and whether you have any smb.conf changes.
Comment 2 Jan Goyvaerts 2014-05-02 08:13:41 UTC
I'll have a try tonight.

What I can tell about the server is that it is the "MEDION LIFE P89635 2 TB NAS server". I'll poke it with nmap to see if I can extract more info.

But it worked fined for prior release of Ubuntu. Other devices have no problems with it either.
Comment 3 Jan Goyvaerts 2014-05-03 10:12:35 UTC
Created attachment 275743 [details]
The demanded log file

gvfs-copy gives the same result: 

/tmp$ gvfs-copy smb://nas-server/public/meteo.log /tmp/met2.txt

Error copying file smb://nas-server/public/meteo.log: Software caused connection abort
Comment 4 Jan Goyvaerts 2014-05-03 10:24:18 UTC
A few scraps from nmap. Hope it helps.

Device type: general purpose
Running: Linux 2.6.X
OS CPE: cpe:/o:linux:linux_kernel:2.6
OS details: Linux 2.6.19 - 2.6.36
TCP Sequence Prediction: Difficulty=203 (Good luck!)
IP ID Sequence Generation: All zeros
Service Info: OS: Linux; CPE: cpe:/o:linux:linux_kernel:2

| nbstat: 
|   NetBIOS name: NAS-SERVER, NetBIOS user: <unknown>, NetBIOS MAC: <unknown>
|   Names
|     NAS-SERVER<00>       Flags: <unique><active>
|     NAS-SERVER<03>       Flags: <unique><active>
|     NAS-SERVER<20>       Flags: <unique><active>
|     \x01\x02__MSBROWSE__\x02<01>  Flags: <group><active>
|     WORKGROUP<1d>        Flags: <unique><active>
|     WORKGROUP<1e>        Flags: <group><active>
|_    WORKGROUP<00>        Flags: <group><active>
| smb-os-discovery: 
|   OS: Unix (Samba 3.0.32)
|   Computer name: nas-server
|   NetBIOS computer name: 
| smb-security-mode: 
|   Account that was used for smb scripts: *******
|   User-level authentication
|   SMB Security: Challenge/response passwords supported
|_  Message signing disabled (dangerous, but default)
|_smbv2-enabled: Server doesn't support SMBv2 protocol
Comment 5 Ross Lagerwall 2014-05-03 14:27:17 UTC
Thanks. The error message in that log is coming from libsmbclient, the underlying library that gvfs uses to speak to the server. There seems to be a problem with the updated Samba version used in Ubuntu 14.04 when used with that particular NAS smb server (e.g. see

There's not much we can do here but I have opened a bug on the Samba bugzilla [1]. If you can provide them with any more info, that would be great!

Comment 6 Ross Lagerwall 2014-05-03 14:27:49 UTC

*** This bug has been marked as a duplicate of bug 729298 ***
Comment 7 Jan Goyvaerts 2014-05-03 15:59:12 UTC
Is there a possible workaround ? Because this is a blocking problem - I can't download anything from the nas anymore.
Comment 8 Ross Lagerwall 2014-05-03 18:36:38 UTC
(In reply to comment #7)
> Is there a possible workaround ? Because this is a blocking problem - I can't
> download anything from the nas anymore.

You may have some luck mounting using the cifs kernel module instead (thereby avoiding gvfs and libsmbclient):