After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 655601 - Brasero finishes without error but unusable media
Brasero finishes without error but unusable media
Product: brasero
Classification: Applications
Component: general
Other Linux
: Normal normal
: ---
Assigned To: Brasero maintainer(s)
Brasero maintainer(s)
Depends on:
Reported: 2011-07-29 20:08 UTC by Pedro Villavicencio
Modified: 2018-09-21 17:21 UTC
See Also:
GNOME target: ---
GNOME version: 2.91/3.0

Brasero burning with on-fly option leads to unreadable data DVD (39.48 KB, image/png)
2011-09-26 14:16 UTC, Xavier Guillot
Ubuntu 10.10 log without problem (Brasero 2.32.0) (116.09 KB, text/plain)
2012-01-16 10:17 UTC, Nico Zanferrari
Ubuntu 11.04 log with problem (Brasero 2.32.1) (146.35 KB, text/plain)
2012-01-16 10:18 UTC, Nico Zanferrari
Fedora Live 16 with problem (Brasero 3.2.0) (125.82 KB, text/plain)
2012-01-16 10:19 UTC, Nico Zanferrari
Patch to reduce the priority of liburn. (843 bytes, text/plain)
2012-05-18 18:40 UTC,
Patch that disables libisofs and libburnia based plugin. (1.32 KB, patch)
2012-05-18 18:52 UTC,
none Details | Review
[PATCH] Libburnia plugin: Fix while loop in `brasero_libisofs_write_image_to_fd_thread()` (#655601) (2.68 KB, patch)
2012-10-11 14:40 UTC, Paul Menzel
rejected Details | Review

Description Pedro Villavicencio 2011-07-29 20:08:29 UTC
this report has been filed here:

"When I burn a DVD (4,7 and 8,5 GB) Brasero show the progressbar till about 30-40% (exact point is randomly) and than says, that it is finalizing the media. This finalizing messages is showing for the rest of the burning process (~10min @8x 8,5GB). After that, it ejects the media without any error. But when I insert the media again, nothing happens, except, that the DVD-Drive disappears from the "computer:///" location in nautilus.

This problem only exists when burning On-The-Fly. Burning ISO Images or automatic creation of ISO Images before burning works without problems. The burning speed doesn't matter to this problem. I test 8x, 4x and 2x. All the same problem. On-The-Fly burning using K3B works quite well @8x speed.

One thing I also notice is, that Brasero uses 100% CPU on one core, while K3B uses just about 5-15%.

I attached the last Brasero log. I don't know, why it just says, that it was only at 49% and then says it's finished. The burning took about 28 minutes. The media was unusable on all my three devices (Linux/Windows)."

Comment 1 Xavier Guillot 2011-09-26 14:15:24 UTC

I confirm this bug on Brasero in Ubuntu Oneiric beta : when I want to burn a data DVD, if I select option "burn directly without saving on hard disk", burning progress until 100%, Brasero tells me it has succeeded, but when I run the DVD, nothing appears in the file manager (as if there was non DVD), in Ubuntu (tested on 2 computers), Windows...

If I do the same burning, but unthick the option and save on the disk before, burning works well and DVD is readable.
Comment 2 Xavier Guillot 2011-09-26 14:16:16 UTC
Created attachment 197480 [details]
Brasero burning with on-fly option leads to unreadable data DVD
Comment 3 VPablo 2011-12-15 21:45:32 UTC
Is there any advance on this bug?
Comment 4 Nico Zanferrari 2011-12-30 09:36:12 UTC
This bug affect me, too. 

Latest 3.x version on Ubuntu 11.10 32 bit, also with CR-R and CD-RW.
Comment 5 Nico Zanferrari 2012-01-16 10:15:30 UTC
OK, I've made some additional tests. Now, for me it's clear that:

- the bug started on Brasero version 2.32.1 and it's still present in 3.2.x. It was not present in version 2.32.0.
- it happens on all hw, and all current distros
- it happens only with on-the-fly burning, which is the default option by the way. 

I'm attaching debug logs, from Ubuntu 10.10 (without the problem) and Ubuntu 11.04  + Fedora 16 (with the problem). 
They were obtained with the standard ISO placed on a bootable USB stick, after having disabled all plugins, trying to write on-the-fly a single 135 Mb file. According to the program window, the burn process always completed succesfully.

Comment 6 Nico Zanferrari 2012-01-16 10:17:09 UTC
Created attachment 205342 [details]
Ubuntu 10.10 log without problem (Brasero 2.32.0)
Comment 7 Nico Zanferrari 2012-01-16 10:18:04 UTC
Created attachment 205343 [details]
Ubuntu 11.04 log with problem (Brasero 2.32.1)
Comment 8 Nico Zanferrari 2012-01-16 10:19:07 UTC
Created attachment 205344 [details]
Fedora Live 16 with problem (Brasero 3.2.0)
Comment 9 Vincent 2012-01-16 10:23:28 UTC
How is it possible that this bug is still UNCONFIRMED when 27 peoples report it on launchpad? Also, its importance should be higher because the loss of physical CD and DVD cost money to every users...
Comment 10 Vincent 2012-02-15 15:13:48 UTC
Is there any Brasero dev here???
Comment 11 Christian Dysthe 2012-03-15 04:13:41 UTC
I created an unreadable backup one week ago. So glad I discovered this bug since it would be a disaster if I had discovered it while trying to restore a backup. Please put some attention on this. What makes it extra serious is that there's no error indication after burn.
Comment 12 Nico Zanferrari 2012-03-25 13:45:13 UTC
There is a simple fix, lowering the libisofs priority - see the Launchpad bug for details!
Comment 13 Christian Dysthe 2012-03-25 13:56:55 UTC
Thanks, I found that fix and it works. I still wonder why that fixes it though, if it's a fix or a workaround.
Comment 14 2012-05-18 18:40:06 UTC
Created attachment 214393 [details]
Patch to reduce the priority of liburn.
Comment 15 2012-05-18 18:41:51 UTC
Review of attachment 214393 [details]:

Sorry -- attached wrong file.
Comment 16 2012-05-18 18:52:15 UTC
Created attachment 214394 [details] [review]
Patch that disables libisofs and libburnia based plugin.
Comment 17 Luis Medinas 2012-05-18 23:38:24 UTC
(In reply to comment #16)
> Created an attachment (id=214394) [details] [review]
> Patch that disables libisofs and libburnia based plugin.

You are not expecting we would accept this patch right ? This you can do using dconf no need for patches.
Comment 18 2012-05-21 00:53:31 UTC

The libburn based plugin is broken across platforms but is the default one chosen.  It seems to make sense to disable it by default until the code is fixed.
Comment 19 Paul Menzel 2012-07-05 19:34:01 UTC
A similar bug report is on Debian [1], but it is not known yet if all talk about the same cause the original reporter was seeing.

Anyway the libburnia developers stepped up and cooked up some patches for you to try please to gather some more information what goes wrong.

So please apply Georges patch [3] and post the result to the discussion (on the Debian bug tracker, since they are doing the work currently) doing the following to keep threading.

        $ sudo aptitude install devscripts
        $ bts show --mbox 617409 # downloads the messages from the archive \
        # quit possible opened mail client like mutt by pressing key q

Now import that file from `$HOME/.devscripts_cache/bts/` into your mail program. Choose George’s message and hit reply to all and write your results (quote properly and delete unimportant stuff in George’s message) and attach the log files.



PS: I do not see the messages sent to the brasero list in your archive. Is the list moderated?

Comment 20 Paul Menzel 2012-10-11 14:40:45 UTC
Created attachment 226266 [details] [review]
[PATCH] Libburnia plugin: Fix while loop in `brasero_libisofs_write_image_to_fd_thread()` (#655601)

This is the patch fixing this problem for me and others.

1. Please apply this to *all* versions since 3.x as otherwise burning on the fly does not work.
2. Without Thomas Schmitt and Michael Biebl this patch would not exist. So please consider donating to the libburnia project [1] (and to Debian and GNOME).
3. I hope everything works now. ;-)

Comment 21 Paul Menzel 2012-10-11 15:43:24 UTC
Review of attachment 226266 [details] [review]:

Thomas Schmitt pointed out [1] that the patch cannot fix the problem described by the original reporter. Therefore I opened a separate bug 685983, where I also pasted the error message I was seeing without the patch.

Comment 22 GNOME Infrastructure Team 2018-09-21 17:21:24 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: