After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 580055 - no indication that i've run out of puzzles in "print multiple sudokus"
no indication that i've run out of puzzles in "print multiple sudokus"
Product: gnome-sudoku
Classification: Applications
Component: general
git master
Other All
: High major
: ---
Assigned To: gnome-sudoku-maint
: 685601 704300 (view as bug list)
Depends on:
Blocks: 731215
Reported: 2009-04-24 00:17 UTC by Avery Fay
Modified: 2014-08-06 22:55 UTC
See Also:
GNOME target: ---
GNOME version: 2.23/2.24

Description Avery Fay 2009-04-24 00:17:28 UTC
Please describe the problem:

If you select "print multiple sudokus" of a particular difficulty and you don't have enough puzzles available, there's no indication that there aren't enough available. For example, I tried to print 50 "hard" sudokus and I had 0 available. Everything seemed to work fine except nothing printed. I had to run gnome-sudoko from the command line to find out what was wrong. Ideally, gnome-sudoku should tell me or even better offer to generate enough to print.

Steps to reproduce:

Actual results:

Expected results:

Does this happen every time?

Other information:
Comment 1 BenWiederhake.GitHub 2014-02-27 09:37:10 UTC
5 years later, this bug STILL exists.

My installation, too, of gnome-sudoku has run out of sudokus, yielding this output on the console:
    $ gnome-sudoku -v
    Starting GNOME Sudoku in debug mode
    gnome_sudoku.main.UI __init__ () {}
    <class 'gnome_sudoku.gsudoku.SudokuGameDisplay'> __init__ () {}
    <class 'gnome_sudoku.gsudoku.SudokuGameDisplay'> setup_grid (None, 9) {}
    gnome_sudoku.main.UI setup_tracker_interface () {}
    <class 'gnome_sudoku.main.TrackerBox'> __init__ (<gnome_sudoku.main.UI instance at 0x151cdd0>,) {}
    <class 'gnome_sudoku.main.TrackerBox'> setup_actions () {}
    <class 'gnome_sudoku.main.TrackerBox'> setup_tree () {}
    <class 'gnome_sudoku.main.TrackerBox'> get_tracker_pixbuf ((0, 0, 0),) {}
    gnome_sudoku.main.UI auto_hint_cb (<ToggleAction object at 0x16b0780 (GtkToggleAction at 0x1671150)>,) {}
    gnome_sudoku.main.UI tracker_toggle_cb (<ToggleAction object at 0x16b07d0 (GtkToggleAction at 0x16712b0)>,) {}
    <class 'gnome_sudoku.main.TrackerBox'> reset () {}
    gnome_sudoku.game_selector.NewOrSavedGameSelector __init__ () {}
    gnome_sudoku.game_selector.NewOrSavedGameSelector make_new_game_model () {}
    WARNING: Not able to provide 1 puzzles in levels ['very hard']
    WARNING: Generate more puzzles if you really need this many puzzles!
    WARNING: Repeating puzzle for difficulty very hard -- generate more puzzles to avoid this.
    gnome_sudoku.game_selector.NewOrSavedGameSelector make_saved_game_model () {}`

It doesn't mention on the man page or anywhere on the first few google result pages how to do this "generating more puzzles" :(

This is very strange, as I'm surely not the exception when I install the game and actually play it quite a while?

I tried moving the config dir ( `$HOME/.config/gnome-sudoku` ), so that I can at least replay all the sudokus from the beginning, but this doesn't work, either. Then I checked whether the regenerated config-files are any different from what I just moved out of the way:
    ~/.config$ diff -s gnome-sudoku.bak/puzzles/very_hard gnome-sudoku/puzzles/very_hard 
    Dateien gnome-sudoku.bak/puzzles/very_hard und gnome-sudoku/puzzles/very_hard sind identisch.

Playing around a bit more with `diff`, it looks like there is absolutely nothing "generating new puzzles", since there's no difference between the files just generated and the files accumulating over roughly 1 year (except the "finished" directory and its contents).

Isn't there anyone who is bother by the fact you can only play 150 or so puzzles, and after that the game just breaks, even though "puzzle generation" is advertised (and probably at some point was implemented)?
Comment 2 Mario Wenzel 2014-02-27 09:55:01 UTC

we understand your frustration and quite frankly, we are a bit frustrated with the state of the codebase ourselves. That's why we're working on a Vala-Port to bring Sudoku up to scratch with the newest features the GTK-Stack has to offer.

In the meantime: Is it possible for you to take a look into dconf (with dconf-editor) in org.gnome.gnome-sudoku. My settings say "generate endlessly" but I haven't played at all. Maybe you can fiddle a bit there. I am not a core sudoku developer but I can try to dig in a bit over the weekend to find a "fix" for cases like yours.

If you find something that helps I would be very happy if you could share that.

Comment 3 Michael Catanzaro 2014-02-27 14:21:34 UTC
My intention is to make this work transparently to the user, or as transparently as possible (I guess if it's slow, we might need a progress dialog), without any configuration settings (especially hidden settings!).  There's no reason the user should have to know whether a puzzle was read from a config file or generated on the fly, and also no reason he should ever get the same sudoku twice.

Unfortunately, this won't be fixed in time for the 3.12 release.  We're not doing any development on the Python version, and the Vala version does not have a Sudoku generator yet -- though that is on the TODO list.
Comment 4 BenWiederhake.GitHub 2014-02-27 15:42:36 UTC
Using dconf-editor, I saw that "generate endlessly" was (and still is) activated as it should. I reset the option "difficulty" to it's default, and enabled the option "generate for target".

Indeed, the error messages disappeared, and I'm able to do sudokus, with certain restrictions, so thank you for that.

Frankly, I'm not sure whether the error actually occurred, because

The error message on the console just made me think that a lack of sudokus is the reason why the gui isn't displaying properly.
Comment 5 Michael Catanzaro 2014-05-20 01:05:30 UTC
*** Bug 685601 has been marked as a duplicate of this bug. ***
Comment 6 Michael Catanzaro 2014-05-30 13:40:11 UTC
*** Bug 704300 has been marked as a duplicate of this bug. ***
Comment 7 Michael Catanzaro 2014-08-01 22:57:54 UTC
Removing whiteboard; this is a priority for me but not related to the success of GNOME 3.14.
Comment 8 Michael Catanzaro 2014-08-06 22:55:16 UTC
This will be fixed in 3.14, yay!