After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 516088 - No drop shadow on panel after login
No drop shadow on panel after login
Product: metacity
Classification: Other
Component: Iain's compositor
Other Linux
: Normal normal
: ---
Assigned To: Metacity compositor maintainers
Metacity compositor maintainers
: 570810 (view as bug list)
Depends on:
Reported: 2008-02-12 19:38 UTC by Sven Arvidsson
Modified: 2020-11-06 20:05 UTC
See Also:
GNOME target: ---
GNOME version: 2.19/2.20

Description Sven Arvidsson 2008-02-12 19:38:12 UTC
When using the compositor, the panel doesn't get a drop shadow after login. One must manually restart metacity for this to work, restarting the panel is not enough.

I this was mentioned on the blog earlier, but I decided to properly file it as a bug so it isn't forgotten.
Comment 1 Thomas Thurman 2008-03-21 03:36:04 UTC
Hm.  This works for me.  Iain, any ideas why this might fail?
Comment 2 Sven Arvidsson 2008-03-23 15:57:45 UTC
Another Debian user have reported similar behaviour,

I wonder if this bug could be specific to Debian in some way?
Comment 3 Andrea Cimitan 2008-03-30 01:49:20 UTC
Not debian specific (same issue with archlinux).

maybe could be related to the startup order, (before metacity, than panel, or viceversa)
Comment 4 Sven Arvidsson 2008-03-30 14:55:44 UTC
Restarting a panel (when it has a shadow) doesn't work, metacity needs to be restarted for the shadow to return. So I don't think it has anything to do with startup order?
Comment 5 Andrea Cimitan 2008-03-30 15:27:14 UTC
That's true, but if you run metacity after the panel it should work... isn't it?

Btw I've just tried to killall metacity, -panel has shadows-, killall gnome-panel, -no shadow-
Comment 6 Luca Ferretti 2008-04-08 12:22:37 UTC
Note that in GNOME 2.22 the panel has a little animation on its start-up. Top and bottom panels (default layout) are initially placed outside the screen edges, then they "slide" on place.

I remember in 2.21.x releases the panel shadows was fine, starting to disappear after this panel animation commit.

PS: compiz (on my ubuntu hardy) works fine with animation too.
Comment 7 Sven Arvidsson 2008-04-08 21:55:11 UTC
I tried downgrading gnome-panel to 2.20, with no difference. So that's probably not it.
Comment 8 iain 2008-04-08 23:59:16 UTC
Its a race condition between metacity discovering the desktop window and the window registering itself as a desktop.
Comment 9 Andrea Cimitan 2008-05-27 12:20:44 UTC
still having this with metacity 2.23.21
Comment 10 gan lu 2008-10-20 14:04:40 UTC
I got the same problem with metacity 2.24 under fedora 9/rawhide. A simple restart of metacity through "pkill metacity" works it around.
Comment 11 Andrea Cimitan 2009-01-10 12:06:50 UTC
Vuntz told me this bug is related with the fact metacity is registering itself before it is ready. Maybe fixing the other bug will have positive effects here.
Comment 12 gan lu 2009-01-10 13:56:11 UTC
(In reply to comment #11)
> Vuntz told me this bug is related with the fact metacity is registering itself
> before it is ready. Maybe fixing the other bug will have positive effects here.
What bug exactly? Is there a bug report? thanks.
Comment 13 iain 2009-02-06 23:43:47 UTC
*** Bug 570810 has been marked as a duplicate of this bug. ***
Comment 14 Andrea Cimitan 2009-06-29 02:37:21 UTC
Still the issue from various PCs and distro... basically we have to start metacity after the panel...
Comment 15 Kao Dome 2011-06-26 22:51:14 UTC
Although almost 2 years have passed since the last comment in this bug report and the issue is still there.

Would there be a way to fix the race condition? Besides the "sleep X; metacity --replace" procedure. Even though this bug report is treated as normal priority it would be nice to have it fixed.
Comment 16 Antonio Ospite 2012-05-16 10:02:42 UTC

I too experience this, a workaround is also to turn compositing off and on again (cit.):

gconftool -s /apps/metacity/general/compositing_manager --type bool false
gconftool -s /apps/metacity/general/compositing_manager --type bool true

Here is the ubuntu bug about that:

Comment 17 André Klapper 2020-11-06 20:05:31 UTC is being replaced by We are closing all old bug reports in Bugzilla which have not seen updates for many years.

If you can still reproduce this issue in a currently supported version of GNOME (currently that would be 3.38), then please feel free to report it at

Thank you for reporting this issue and we are sorry it could not be fixed.