After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 354634 - GtkAdjustment upper/lower is confusing
GtkAdjustment upper/lower is confusing
Status: RESOLVED NOTABUG
Product: gtk+
Classification: Platform
Component: Widget: Other
2.9.x
Other Linux
: Normal normal
: ---
Assigned To: gtk-bugs
gtk-bugs
Depends on:
Blocks: 347771
 
 
Reported: 2006-09-06 14:59 UTC by Johan (not receiving bugmail) Dahlin
Modified: 2006-09-06 18:08 UTC
See Also:
GNOME target: ---
GNOME version: ---



Description Johan (not receiving bugmail) Dahlin 2006-09-06 14:59:10 UTC
The names of the attributes on GtkAdjustment are confusing, it'd be better to use the following names:

upper -> maximum
lower -> minimum

I recently added this in a project of mine (python) where the code suggests that
it should be scrolled to the top, but in reality it's to the bottom:

  # Scroll to the bottom of the scrolled window
  vadj = self.scrolled_window.get_vadjustment()
  vadj.set_value(vadj.upper)
Comment 1 Owen Taylor 2006-09-06 17:13:24 UTC
It's just not worth making random renames, even if the new names are a little better. The amount of confusion you introduce as the names are phased and the old names deprecated over the next five years will outweight anything you save.
Comment 2 Tim Janik 2006-09-06 18:05:15 UTC
(In reply to comment #0)
> The names of the attributes on GtkAdjustment are confusing, it'd be better to
> use the following names:
> 
> upper -> maximum
> lower -> minimum

i do agree with Owen's comment. however i'd like to add that i prefer "upper" over "maximum", because the maximum value that can be set on an adjustment is actually (upper - page_size). so i like the somewhat more vague notion of "upper" better than "maximum".
Comment 3 Matthias Clasen 2006-09-06 18:08:48 UTC
If the terms maximum and minimum are reducing the confusion, we should consider
adding some docs explaining that the upper value is the maximum...