After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 342437 - crash when copying large files to vfat
crash when copying large files to vfat
Product: nautilus
Classification: Core
Component: File and Folder Operations
Other Linux
: High critical
: ---
Assigned To: Nautilus Maintainers
Nautilus Maintainers
: 341784 365885 402568 604386 614614 (view as bug list)
Depends on:
Reported: 2006-05-20 17:52 UTC by Markus Johnsson
Modified: 2010-04-09 11:14 UTC
See Also:
GNOME target: ---
GNOME version: 2.21/2.22

Description Markus Johnsson 2006-05-20 17:52:52 UTC
Please describe the problem:
I was copying a 7.7 Gb tar'd copy of my home dir to a fat32 file system and
ended up with just a 4.0 Gb file on the target drive. Did the same thing in
gnome-terminal and got the message (something like:) 'File size limit exceeded'
(Swedish: "Begränsning av filstorlek överskriden").

Steps to reproduce:
1. Copy a large file to a file system with a file size limit usin nautilus

Actual results:
The file copies until file size limit is reached, then silently dies. 

Expected results:
I would like to get a message telling me the operation wasn't successful.

Does this happen every time?

Other information:
The target file system was a lacie firewire drive, but it shouldn't matter since
I successfully made a copy of the file to an ext2 partition on the same drive.
Comment 1 Fabio Bonelli 2006-05-22 18:41:21 UTC
*** Bug 341784 has been marked as a duplicate of this bug. ***
Comment 2 Guillaume Desmottes 2006-10-04 11:19:32 UTC
I can confirm this issue with nautilus 2.16.
Comment 3 cimarosti 2007-01-30 19:59:50 UTC
*** Bug 402568 has been marked as a duplicate of this bug. ***
Comment 4 cimarosti 2007-01-30 20:04:29 UTC
I have filed the bug I found as a duplicate of this one, but in my case nautilus crashed instead of silently aborting and no data was copied, but a 0-byte file was present at the final location. This was executing a move operation.
Comment 5 Teppo Turtiainen 2007-02-18 18:20:27 UTC
*** Bug 365885 has been marked as a duplicate of this bug. ***
Comment 6 Teppo Turtiainen 2007-02-18 19:29:32 UTC

Thread 20 (Thread 1090525520 (LWP 7631))

  • #0 __write_nocancel
    from /lib/
  • #1 do_write
    at file-method.c line 472
  • #2 gnome_vfs_write_cancellable
    at gnome-vfs-cancellable-ops.c line 167
  • #3 copy_file
    at gnome-vfs-xfer.c line 1268
  • #4 copy_items
    at gnome-vfs-xfer.c line 1820
  • #5 gnome_vfs_xfer_uri_internal
    at gnome-vfs-xfer.c line 2564
  • #6 _gnome_vfs_xfer_private
    at gnome-vfs-xfer.c line 2650
  • #7 _gnome_vfs_job_execute
    at gnome-vfs-job.c line 1557
  • #8 thread_entry_point
    at gnome-vfs-job-queue.c line 66
  • #9 g_thread_pool_thread_proxy
    at gthreadpool.c line 265
  • #10 g_thread_create_proxy
    at gthread.c line 553
  • #11 start_thread
    from /lib/
  • #12 clone
    from /lib/
  • #13 ??

Comment 7 vj 2007-08-27 02:43:50 UTC
I did not get a crash, but (arguably worse), when I tried to copy several files, including a 7Gb file to a FAT32 partition (ironically enough as a backup on an external drive), it seemed that the copy worked.
It was only when I did a subsequent diffs (being paranoid) to see if all the files had copied over, that I found the problem.
Nautilus had truncated the file to 4Gb, but had not displayed any warnings or errors.  This bug is serious as the user is led to think that the copy succeeded - but is left with a useless file.

Kernel 2.6.15-28-686
Nautilus 2.14.3
Gnome 2.14.3
Ubuntu 6.06
Comment 8 mike.simonson 2008-01-07 11:23:41 UTC
Same problem with a 4,4GB files on fat32.
Nautilus silently crash at 4 GB and didn't warn at any time that the copy was impossible.

Gnome 2.20
Nautilus 2.20
Ubuntu 7.10
Comment 9 Martin Wegener 2008-03-31 17:14:08 UTC
Same problem, original file size > 4GB copied to a vfat file system with nautilus
--> file size = 4GB.
No warning, the copying dialog simply crashed/closed.
Ubutnu 7.10 2.6.22-14-generic, up-to-date installation.
Gnome version: 2.20.1
Comment 10 Cosimo Cecchi 2008-11-07 13:48:04 UTC
Dear reporters,

could you please try to reproduce this bug with Nautilus >= 2.22? Most of its I/O codebase has been rewritten and ported from gnome-vfs to GIO, so this might have been fixed as a result of the transition.
Comment 11 mike.simonson 2008-11-07 19:38:22 UTC
I run the test with nautilus  again, received no warning.
The file I tried to copy was to large and stopped at 4G, but all nautilus windows where frozen and i needed to kill nautilus to have it working. So I can say the problem worse now.
Comment 12 Cosimo Cecchi 2008-11-08 00:25:16 UTC
Thanks for the follow-up, confirming with 2.22 then.
Comment 13 Markus Johnsson 2008-11-10 20:14:44 UTC
I would rather have a crashing file manager than one that acts as if the file was copied OK. So I actually prefer a complete freeze :)

I can't understand that this isn't a bigger issue to the devs though. 
Comment 14 Martin Lettner 2009-04-01 19:39:01 UTC
I had exactly that problem today with Nautilus-2.26.0:
I wanted to copy a 4.4GB file to a FAT32 formatted memory-stick. At 4.0GB the copy process got cancelled and an error message popped up telling me the file is to big or something similar.

In fact this is not a real bug in nautilus rather a limitation of FAT32 or vfat file system. "The maximum possible size for a file on a FAT32 volume is 4 GiB minus 1 byte (232−1 bytes)" (this is why there is exFAT or FAT64 now)

So Nautilus should check the filesystem and it's supported filesizes before the copy process! (like the check if there is enough space) And Nautilus should tell the user in friendly words that that filesystem cannot manage files that big.

- User wants to copy a 1GB, and 2 5GB files onto a flashdrive
- Nautilus should inform the user that 2 files cannot be copied because of the reason above
- User clicks "Skip all" or something similar
- copying starts and only the one 1GB file is copied.
Comment 15 Dmitry Bashkatov 2010-03-25 15:29:59 UTC
I investigated this bug and found that problem is in gio. I have filed a bug including a patch that fixes the problem here
Comment 16 Cosimo Cecchi 2010-04-09 10:56:59 UTC
Dmitry: could you confirm that the GIO patch fixes this issue for you? We can probably close this bug then.
Comment 17 Cosimo Cecchi 2010-04-09 10:57:10 UTC
*** Bug 604386 has been marked as a duplicate of this bug. ***
Comment 18 Cosimo Cecchi 2010-04-09 10:57:36 UTC
*** Bug 614614 has been marked as a duplicate of this bug. ***
Comment 19 Dmitry Bashkatov 2010-04-09 11:02:52 UTC
I confirm.
Comment 20 Cosimo Cecchi 2010-04-09 11:14:19 UTC
Closing then.

Please reopen the bug if it's still somehow broken with GLib 2.24.x and Nautilus 2.30.x.