After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 168250 - Crash due to duplicate report names in saved custom report
Crash due to duplicate report names in saved custom report
Product: GnuCash
Classification: Other
Component: Reports
Other All
: High critical
: ---
Assigned To: David Hampton
Chris Lyttle
: 305611 312625 319173 327393 328510 336374 347060 (view as bug list)
Depends on:
Reported: 2005-02-23 12:24 UTC by qaz
Modified: 2018-06-29 20:50 UTC
See Also:
GNOME target: ---
GNOME version: ---

saved-reports-1.8 (1.81 KB, text/plain)
2005-02-24 10:52 UTC, qaz
similar saved report (1.76 KB, text/plain)
2005-03-07 18:27 UTC, ted creedon
saved-reports-1.8 crash when opening report called "Income/Expense Chart" (22.62 KB, application/octet-stream)
2005-03-24 00:57 UTC, Bill Skellenger
backtrace of crash in svn 13702 (1.72 KB, text/plain)
2006-03-29 05:39 UTC, Flavio

Description qaz 2005-02-23 12:24:03 UTC
Steps to reproduce:
1. save report 
2. restart gnucash 
3. load custom report 

Stack trace:
In /home/gnucashuser101/.gnucash/saved-reports-1.8:  
   5: 83269  (let ((options #)) (let (#) (# option)) (let (#) (# option)) ...)  
   5: 83270* [gnc:report-template-new-options/name "Expense Accounts"]  
In /usr/share/gnucash/scm/report.scm:  
 127: 83271  (let ((templ #)) (if templ (gnc:report-template-new-options  
templ) #f))  
In unknown file:  
   ?: 83272  [gnc:report-template-new-options #]  
In /usr/share/gnucash/scm/report.scm:  
 146: 83273  (let (# # #) (if # # #))  
 153: 83274* [gnc:make-multichoice-option "General" "Stylesheet" ... ...  
 157: 83275* [map #<procedure #f (ss)> (# #)]  
In unknown file:  
   ?: 83276  (if (null? rest) (map1 f list1) ...)  
   ?: 83277  (begin (set-cdr! p (list (f #))) (lp (cdr ls) (cdr p)))  
   ?: 83278* [set-cdr! (#(Default "Default" "Default Stylesheet")) ...  
   ?: 83279* [list ...  
   ?: 83280* [#<procedure #f #> #]  
In /usr/share/gnucash/scm/report.scm:  
 159: 83281  [vector Technicolor "Technicolor" ...  
 162: 83282* [string-append ...  
 162: 83283* [gnc:html-style-sheet-name #]  
In unknown file:  
   ?: 83284  (and (eq? (quote #) (record-type-descriptor obj)) (struct-ref obj  
   ?: 83285* [eq? #<record-type <html-style-sheet>> ...  
   ?: 83286* [record-type-descriptor #]  
   ?: 83287  (if (struct? obj) (struct-vtable obj) (error (quote not-a-record)  
   ?: 83288* (struct? obj)  
<unnamed port>: In expression (struct? obj):  
<unnamed port>: Stack overflow  

Other information:
Comment 1 Christian Stimming 2005-02-24 08:59:06 UTC
Do I understand this correctly: Since you saved your custom report, gnucash
crashes now everytime you try to start it? That's bad.

Your quick workaround would be to open the file ~/.gnucash/saved-reports-1.8
with a text editor, find the section that deals with the "Expense Accounts"
report, and delete the whole section (from the leading ";;;;;;;;" line to the
finishing one).

If we, the developers, should help you with this, then you would have to attach
your errornous ~/.gnucash/saved-reports-1.8 file here to this bugreport so that
we can reproduce this behaviour. The file does not contain any of your financial
information. Please do not copy&paste it to here but click "Create a New
Attachment" below. Thanks.
Comment 2 qaz 2005-02-24 10:52:45 UTC
Created attachment 37884 [details]
Comment 3 qaz 2005-02-24 10:57:57 UTC
gnucash only crashes when i try to load the custom report(menubar: Reports--> 
Custom-->Expense Over Time), not when i try to start it. 
Comment 4 Christian Stimming 2005-02-25 10:00:44 UTC
Ok, thanks for this information. Can you also supply the exact version number of
gnucash (1.8.10 I suppose) and also the program "guile" (e.g. try "guile
--version")? Thanks.
Comment 5 Derek Atkins 2005-02-25 15:31:17 UTC
Another question: What OS/Distro do you run?
Comment 6 Ludovic 2005-02-25 18:38:27 UTC
Just to mention i get the same crash in similar circumstances.

I am using MacOSX 10.3.8
I built GnuCash on that mac using the fink system, using the source distro 1.8.11-1 (the -1 is just an 
internal versioning system within fink).
Guile 1.6.4 is being used, built as well within fink.

Now, some extra details.
Case 1.
Starting with a clean .gnucash folder with no saved-report-1.8 file
1. launching gnucash
2. create a report from the Income&Expenses report menu
3. quit gnucash
4. relaunch gnucash
Result: the gnucash report reloads automatically and is perfectly fine. NO BUG here.

Case 2
we are at the end of case 1, and then 
5a. "save report" on the currently working P&L report
6a. quit gnucash
7a. relaunch gnucash
Result : the second tab, the one that is supposed to show the P&L account, prints "Report not found", 
and is mostly a "dead tab"

Case 3 
We are at the end of case 1 again (means, i flushed all saved report, and started over again at step 1, 
for testing)
5b. "save report" on the currently  working P&L report
6b. close the report
7b. quit gnucash
8b. relaunch gnucash
9b. choose Report/custom/P&L report
Result: the app crashes in scheme code, almost identical to what the original bug report is, with stack 
overflow at the end.

Other considerations:
I tried with a different report than P&L (cash flow i tried), and as expected, same crash, exact same 
logic. Moreover, if two saved reports coexist in the file, it's the same source code lines in the saved-
report-1.8 file that are pointed to in the backtrace, so it,s the common part that crashes, not apparently 
in each report-specific section.

Aside that, dunno what else i can add yet.

Comment 7 qaz 2005-02-27 23:37:23 UTC
GnuCash 1.8.10  (from debian package Version: 1.8.10-7) 
Guile 1.6.7 
Comment 8 qaz 2005-02-28 00:36:55 UTC
>Another question: What OS/Distro do you run? 
Debian unstable i386 
Comment 9 lduperval 2005-03-02 04:50:28 UTC
I'm getting similar problems running 1.8.10 on Gentoo, guile 1.6.4.

Comment 10 ted creedon 2005-03-07 18:27:56 UTC
Created attachment 38379 [details]
similar saved report

same saved report problem on SUSE 9.2 postgres 7.4 guile 1.6.4

(saving ot postgres)
Comment 11 Bill Skellenger 2005-03-24 00:57:34 UTC
Created attachment 39171 [details]
saved-reports-1.8 crash when opening report called "Income/Expense Chart"

I've got the exact same Backtrace as the original reporter.

Gnucash 1.8.10 on Gentoo.
Comment 12 Sloan Poe 2005-04-20 15:39:42 UTC
I'm having the same problem on gentoo amd64
Gnucash 1.8.11
Guile 1.6.7

The only custom reports I can load are Profit/Loss reports
Comment 13 Derek Atkins 2005-05-27 21:56:01 UTC
*** Bug 305611 has been marked as a duplicate of this bug. ***
Comment 14 Derek Atkins 2005-12-11 21:54:48 UTC
FYI, the problem is when you save a report without changing the report name.
Comment 15 Derek Atkins 2005-12-11 21:55:28 UTC
*** Bug 319173 has been marked as a duplicate of this bug. ***
Comment 16 Sloan Poe 2005-12-12 17:25:46 UTC
Wow.  That's a great thing to know.  I just tried it, creating custom reports
and renaming them to something other than the default.  It works like a charm. 
finally i can have my huge list of custom reports back.
Comment 17 qaz 2005-12-12 21:01:00 UTC
i can confirm that changing the name of the report solves the problem     
additional info:     
my ~/.gnucash/saved-reports-1.8  with name changed report has a few extra    
>(let ((option (gnc:lookup-option options    
>                                 "General"    
>                                 "Report name")))    
>  ((lambda (option) (if option ((gnc:option-setter option) "test"))) option))    
adding these lines to a version with the default report name doesn't solve the    
problem for me    
(btw could/should someone change the status of this bug to confirmed?)    
Comment 18 lloyd brookes 2006-01-12 21:09:54 UTC
bug still present in 1.8.12.

i'm running gnucash-1.8.12-0.fc4 from the FC4 repositories. 

Problem solved by giving "name" property from the section below (in file ~/.gnucash/saved-reports-1.8) a name other that the default template name.

  'version 1
  'name "Transaction Report LB"
  'options-generator options-gen
  'menu-path (list gnc:menuname-custom)
  'renderer (gnc:report-template-renderer/name "Transaction Report")))
Comment 19 Christian Stimming 2006-01-18 12:51:02 UTC
*** Bug 312625 has been marked as a duplicate of this bug. ***
Comment 20 Christian Stimming 2006-01-18 12:51:51 UTC
*** Bug 327393 has been marked as a duplicate of this bug. ***
Comment 21 Christian Stimming 2006-01-18 12:53:06 UTC
Raising severity because of multiple additional bug reports.
Comment 22 Derek Atkins 2006-01-25 18:22:24 UTC
*** Bug 328510 has been marked as a duplicate of this bug. ***
Comment 23 Christian Stimming 2006-02-22 09:16:20 UTC
Development on 1.8.x has stopped, and in 1.8.x we won't fix anything anymore (sorry). Can someone reproduce this bug with 1.9.1 or SVN? 
Comment 24 Flavio 2006-03-29 05:36:54 UTC
(In reply to comment #23)
> Development on 1.8.x has stopped, and in 1.8.x we won't fix anything anymore
> (sorry). Can someone reproduce this bug with 1.9.1 or SVN? 

yes, just had the same. 
see attachment for details
Comment 25 Flavio 2006-03-29 05:39:24 UTC
Created attachment 62269 [details]
backtrace of crash in svn 13702
Comment 26 Christian Stimming 2006-03-30 08:44:59 UTC
*** Bug 336374 has been marked as a duplicate of this bug. ***
Comment 27 David Hampton 2006-04-29 07:29:26 UTC
Fixed in r13877 for gnucash 1.9.6.
Comment 28 David Hampton 2006-07-24 11:32:06 UTC
*** Bug 347060 has been marked as a duplicate of this bug. ***
Comment 29 John Ralls 2018-06-29 20:50:21 UTC
GnuCash bug tracking has moved to a new Bugzilla host. This bug has been copied to Please update any external references or bookmarks.