After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 139195 - customfields values not initialized properly in some bugs, causing errors
customfields values not initialized properly in some bugs, causing errors
Classification: Infrastructure
Component: general
Other Linux
: Urgent critical
: ---
Assigned To: Bugzilla Maintainers
Bugzilla Maintainers
: 139125 (view as bug list)
Depends on:
Reported: 2004-04-05 22:33 UTC by Brian "netdragon" Bober
Modified: 2004-12-22 21:47 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Brian "netdragon" Bober 2004-04-05 22:33:38 UTC
I can neither comment in, nor CC myself in bug 118372. I get a blank page with
only the Gnome header. Nothing changes in the bug. I can reply and CC myself on
other bugs. Its almost like the data is going to /dev/null from this bug.

I'm trying to add this to the bug along with CC myself:

Rob: Some of this discussion is beyond me and I'm just interested in this from a
user's perspective. I'm still not sure on what the answer to the question in
comment #40 is. Will a window still get raised/focused unless the application
supplies some hint? Or will an application get raised/focused ony if it supplies
a hint? By transparently, do you mean that without the hint, the application
window will not be raised or focused? Will this also apply to when a window has
existed for a while and there is new activity (such as a gaim window that was
minimized popping up while you are typing an essay in openoffice)? Will the
windows be flashed along with the entries in the window list?

Will this fix affect the sawfish Window manager too, or do they need independent
fixes? It'd be nice if it could be fixed for every window manager.
Comment 1 Luis Villa 2004-04-07 15:33:44 UTC
Also being seen by <>.
Comment 2 Luis Villa 2004-04-07 16:57:52 UTC
*** Bug 139125 has been marked as a duplicate of this bug. ***
Comment 3 Juergen Kreileder 2004-04-07 19:08:02 UTC
It's getting better... Now I've been able to add myself to the cc list of this
bug.  Let's see if adding comments works too.
Comment 4 Juergen Kreileder 2004-04-07 19:09:57 UTC
Yes, it works.  But for other bugs (e.g. bug 133444) it still doesn't.
Comment 5 David Marín Carreño 2004-04-07 19:33:26 UTC
I'm having the same problem with 136654
Comment 6 Christopher Warner 2004-04-07 20:07:17 UTC
Lets see if adding a comment works.
Comment 7 Christopher Warner 2004-04-07 20:10:48 UTC
Can't add comments to 130175 or CC myself.
Comment 8 Brian "netdragon" Bober 2004-04-07 23:18:41 UTC
I still can't do either on bug 118372
Comment 9 Luis Villa 2004-04-08 13:01:13 UTC
Urk. Offhand, I see nothing in common between those bugs. Varying states,
varying number of emails, varying numbers of comments. This one may just suck a
lot of track down :/
Comment 10 Luis Villa 2004-04-08 13:53:49 UTC
If someone who can duplicate this would join IRC again, I'd appreciate it- the
error messages don't indicate accesses to specific pages, so if someone could
join, give me their IP, and then try to duplicate, I can scan the logs for an
error message.
Comment 11 Juergen Kreileder 2004-04-08 14:47:57 UTC
I was able to add a comment to bug 133444 now (after Luis added a comment there)
but I still have problems with other bugs.
Comment 12 Luis Villa 2004-04-08 15:08:18 UTC
OK, I'm comitting something that should at least cause this to not fail
silently. It should now error and ask you to email bugmaster@ with some
pertinent details.
Comment 13 Luis Villa 2004-04-08 15:08:48 UTC
Juergen: can you try again now?
Comment 14 Luis Villa 2004-04-08 15:50:56 UTC
So it looks like, judging from bug 138066, the problem here is that the gnome
milestone and gnome version fields are not getting initialized correctly, and so
when someone without perms goes to change a field, it tries to leave the fields
null and *boom* error. I'm not clear on what the best solution is at this point-
either make '' a valid value for gg_milestone/version, or do an audit to figure
out where the default_value is not being used. I guess I'll look at where the
code is trying to use default_value, to see if it is being used at all.
Comment 15 Luis Villa 2004-04-08 16:14:10 UTC
Blah. I've tested bug creation from the web with both my account and a totally
unprivileged user account, and both set the defaults correctly (as
post_bug.cgi's code says they should.) So... I /think/ that this is old bugs
that did not get set correctly, which I can fix. My worry is incoming bugs from
bug_buddy- I'm guessing they don't get set correctly. Will investigate that now.
Comment 16 Juergen Kreileder 2004-04-08 16:15:07 UTC
Tried with bug 133584: The html_quote(gg_milestone) value is not a valid value...
Comment 17 Luis Villa 2004-04-08 16:18:24 UTC
oh-ho. It gets more interesting. Bug 133584 says that gg_milestone is '
Unspecified' whereas 'Unspecified' is the legal value. Wonder how that happened.
Comment 18 Luis Villa 2004-04-08 16:41:10 UTC
OK. Very few bugs have gg_ that is blank, and no bugs created since the 29th of
march have this, so I think that is an artifact of the database horkage we had.
This is now fixed.

We still have some bugs shifting from 'Unspecified' to ' Unspecified' though,
which  affects about 4x more bugs. I'm looking more at that now.
Comment 19 Luis Villa 2004-04-08 16:54:23 UTC
OK, I think I know what happened, and I think it is fixed. For the record, when
we rebuilt the customfields stuff, the pattern match became ' Unspecified'
instead of 'Unspecified' which seems to have had the side effect of changing
bugs from one to the other, if someone had sufficient perms. I've fixed all
instances of this in the DB, and fixed the regexp so it shouldn't happen again.
Cross our fingers. :) At any rate, the error message is much improved now so
this should be easier to debug in the future. Thanks to everyone who provided
the data that helped me track this down.
Comment 20 Luis Villa 2004-04-08 17:01:17 UTC
Testing something, please ignore.
Comment 21 Brian "netdragon" Bober 2004-04-08 17:15:30 UTC
The html_quote(gg_milestone) value is not a valid value. If you see this error,
please report it to with the name of the value and the bug
number. Thanks!

IP:, bug 118372, attempt to CC
Comment 22 Brian "netdragon" Bober 2004-04-08 17:58:46 UTC
It works now :-)