GNOME Bugzilla – Bug 354634
GtkAdjustment upper/lower is confusing
Last modified: 2006-09-06 18:08:48 UTC
The names of the attributes on GtkAdjustment are confusing, it'd be better to use the following names: upper -> maximum lower -> minimum I recently added this in a project of mine (python) where the code suggests that it should be scrolled to the top, but in reality it's to the bottom: # Scroll to the bottom of the scrolled window vadj = self.scrolled_window.get_vadjustment() vadj.set_value(vadj.upper)
It's just not worth making random renames, even if the new names are a little better. The amount of confusion you introduce as the names are phased and the old names deprecated over the next five years will outweight anything you save.
(In reply to comment #0) > The names of the attributes on GtkAdjustment are confusing, it'd be better to > use the following names: > > upper -> maximum > lower -> minimum i do agree with Owen's comment. however i'd like to add that i prefer "upper" over "maximum", because the maximum value that can be set on an adjustment is actually (upper - page_size). so i like the somewhat more vague notion of "upper" better than "maximum".
If the terms maximum and minimum are reducing the confusion, we should consider adding some docs explaining that the upper value is the maximum...