After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 796825 - Cannot export rpl_printf: symbol not found
Cannot export rpl_printf: symbol not found
Product: GStreamer
Classification: Platform
Component: cerbero
git master
Other Windows
: Normal normal
: 1.15.1
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Reported: 2018-07-17 21:12 UTC by Marcos Kintschner
Modified: 2018-07-22 14:29 UTC
See Also:
GNOME target: ---
GNOME version: ---

The patch that fix this error (6.31 KB, patch)
2018-07-18 01:10 UTC, Marcos Kintschner
committed Details | Review

Description Marcos Kintschner 2018-07-17 21:12:36 UTC
I found this error when installing the gettext-tools recipe on windows with -c config/w32-msvc-shell.cbc. I found out that this error was caused by gnulib and it was already solved by this commit:

After adding these changes to the gnulib, gettext-tools is installed without errors.

I'm not sure if I should create a patch for this and put it on recipes/gettext/ and just reference the original patch on the commit body or if I should use (somehow) the patch that was already created on gnulib project.
Comment 1 Marcos Kintschner 2018-07-18 01:10:00 UTC
Created attachment 373080 [details] [review]
The patch that fix this error

The patch is based on from

I have tested it on Windows 10 only.
Comment 2 Nirbheek Chauhan 2018-07-19 06:30:19 UTC
(In reply to Marcos Kintschner from comment #0)
> I found this error when installing the gettext-tools recipe on windows with
> -c config/w32-msvc-shell.cbc. 

You should definitely not use that argument for building recipes. That is *only* for running `cerbero-uninstalled shell` when you want an MSVC-only environment. I am not sure what compiler it ends up using when you build it like this.

We should probably error out when someone tries to use that config profile to build an autotools recipe, but I didn't think it would work at all.

Can you please try without any `-c ` arguments?
Comment 3 Marcos Kintschner 2018-07-20 00:49:08 UTC
I must add that those errors happened during the bootstrap phase that install the recipe gettext-tools, i.e., the command line was:

$ python ./cerbero-uninstalled -c config/win32-msvc-shell.cbc bootstrap

Not sure if I should add the '-c' argument at this moment.

I've tried again with a fresh cloned cebero project without any '-c' arguments (python ./cerbero-uninstalled bootstrap) and I've got the same error as before.
Comment 4 Nirbheek Chauhan 2018-07-22 14:25:33 UTC
The issue is in the m4 macro that detects whether symbols should be underscore
or not, which is why this was detected only on 32-bit (in your testing) and not
on 64-bit (which is what I test) on Windows.

Thanks for the patch!

For future reference, for 32-bit you should use `config/win32.cbc` (after
commenting out the `prefix=` line in that file) and not `win32-msvc-shell.cbc`.