After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 795675 - Run GCMD as root not working in Ubuntu Mate 18.04
Run GCMD as root not working in Ubuntu Mate 18.04
Product: gnome-commander
Classification: Other
Component: application
Other Linux
: Normal normal
: 1.8
Assigned To: GNOME Commander maintainer(s)
GNOME Commander maintainer(s)
Depends on: 589069
Reported: 2018-04-30 01:02 UTC by Bill Wood
Modified: 2018-08-03 18:07 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Bill Wood 2018-04-30 01:02:28 UTC
Recently installed Ubuntu Mate 18.04 and then installed Gnome-Commander from the repos.  It is version 1.4.8.

When I open it and select the option to launch it as root, that fails with the error message that one of these is needed:  xdg-su, gksu, gnomesu, kdesu, beesu -- but (from what I can find out) NONE of these are supported anymore with Ubuntu 18.04.

Also tried to install gksu -- but that is not in the repos for Ubuntu 18.04.

When it DID work, it launched another instance of GCMD but with a different color scheme.

I can create a desktop launcher to run GCMD as root, but I can find no way to have that use a different color scheme.
Comment 1 Uwe Scholz 2018-05-03 19:53:51 UTC
Thank you very much for reporting this issue. As far as I can see from the news, gksu has been removed from Ubuntu 18.04 completely. Instead, the admin feature of gvfs is used now for gaining admin rights. (

As Gnome Commander doesn't use gvfs, I cannot really help here, unless bug #589069 is fixed. Sorry to say that.

Regarding the color scheme: It is hard coded in Gnome Commander for the case that you are using it with root privileges. This is a warning for the user so that he is always aware that Gnome Commander can delete all files on the system.
Comment 2 Bill Wood 2018-05-04 22:11:47 UTC
While I appreciate the link about using "admin://" I can see now way to use that to launch gcmd as root.

I was hoping you would tell me this bug is fixed in the latest gcmd version or is being fixed for the next version.

When I DO launch gcmd using SUDO, it does NOT launch with the hard-coded color scheme; instead, it launches with whichever color scheme I set in options.
Comment 3 David Kohen 2018-06-03 09:08:07 UTC
I think there is a simpler way resolve this - add pkexec as an alternative to or replacement for gksu. 

This would required adding a polkit file like this: 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policyconfig PUBLIC
 "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
  <action id="org.gnome.gnome-commander">
    <message>Authentication is required to run Gnome-Commander as root</message>
    <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/gparted</annotate>
    <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>

as /usr/share/polkit-1/actions/org.gnome.gnome-command.policy

I tried running gnome-commander from the command line like this using pkexec: it correctly asked for the password, but failed on "Cannot open display:"

When I tried adding --display=:0 and all sorts of variations I still got the same problem - I'll revisit it later
Comment 4 GNOME Infrastructure Team 2018-08-03 18:07:31 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: