After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 793039 - gst-plugings-bad fails to build if gst-plugins-base built without OpenGL support
gst-plugings-bad fails to build if gst-plugins-base built without OpenGL support
Product: GStreamer
Classification: Platform
Component: gst-plugins-bad
git master
Other Linux
: Normal normal
: 1.13.1
Assigned To: Tim-Philipp Müller
GStreamer Maintainers
Depends on:
Reported: 2018-01-30 21:28 UTC by Omar Akkila
Modified: 2018-02-01 11:26 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Omar Akkila 2018-01-30 21:28:57 UTC
I am trying to cross-build GStreamer from source for the raspberry pi 2 using cerbero and I get an error when compiling -bad:

In file included from gstopengl.c:47:0:
gstglmixerbin.h:26:10: fatal error: gst/gl/gl.h: No such file or directory
 #include <gst/gl/gl.h>
compilation terminated.

I was informed that gstgl is being moved to -base and so I had a look at the logs for the -base build and found that gl was not installed, rendering the header unavailable.

I presume we should probably check if gl is installed otherwise we shouldn't build.
Comment 1 Tim-Philipp Müller 2018-01-31 13:12:50 UTC
This fixes it for me:

commit bd37da2de43e43fa33e46fcffa0b34c3012eb91b
Author: Tim-Philipp Müller <>
Date:   Wed Jan 31 13:02:07 2018 +0000

    autotools: fix build if OpenGL support is not available

Please re-open if there are still issues after this commit, thanks!
Comment 2 Omar Akkila 2018-01-31 20:53:01 UTC
Unfortunately I am still getting the same error message even with commit 	4167b020 :/
Comment 3 Tim-Philipp Müller 2018-01-31 21:09:45 UTC
Is it the exact same dir/file? (gstglmixerbin.* in ext/gl?)

Did you try a clean rebuild (git clean -x -d -f; ./ ?

If it still doesn't work perhaps you could to debug a bit yourself.

the ext/gl subdir is guarded in ext/ by USE_GL.

USE_GL is set in line 1942.

Add an AC_MSG_NOTICE(["have gl: $HAVE_GL"]) before that line perhaps to see what it shows. Maybe also check the value of $HAVE_GST_GL
Comment 4 Tim-Philipp Müller 2018-02-01 11:26:24 UTC
Found it. The problem was elsewhere: -base installed the .pc file even if gl support isn't actually there.

commit d4d1ae95d1de9149b44ed8428c0aa03110d627ed (in gst-plugins-base)
Author: Tim-Philipp Müller <>
Date:   Thu Feb 1 11:21:19 2018 +0000

    pkgconfig: only install gstreamer-gl-1.0.pc if OpenGL support was built