After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 788537 - Opusenc fails with exception
Opusenc fails with exception
Product: GStreamer
Classification: Platform
Component: gst-plugins-base
Other Windows
: Normal major
: git master
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Reported: 2017-10-04 22:18 UTC by Steve Chapman
Modified: 2018-11-03 12:00 UTC
See Also:
GNOME target: ---
GNOME version: ---

Console log of gst-launch with gst_debug=4 (57.54 KB, text/plain)
2017-10-04 22:18 UTC, Steve Chapman

Description Steve Chapman 2017-10-04 22:18:03 UTC
Created attachment 360934 [details]
Console log of gst-launch with gst_debug=4

When I use the opusenc documented example pipeline from gst-launch-1.0 it fails with an exception in libopus-0.dll. 

i.e. gst-launch-1.0 -v audiotestsrc wave=sine num-buffers=100 ! audioconvert ! opusenc ! oggmux ! filesink location=sine.ogg

Results in exception:
Unhandled exception at 0x6252D01B (libopus-0.dll) in gst-launch-1.0.exe: 0xC0000005: Access violation reading location 0xFFFFFFFF

I am testing this on Windows 10 with GStreamer 1.12.0.

GST_DEBUG=4 log of console activity attached as 

I have also tried a variation on the pipeline that calls out most of the opusenc parameters but that also fails with the same exception, i.e.

gst-launch-1.0 audiotestsrc  num-buffers=100 ! "audio/x-raw,channels=1,rate=48000" ! opusenc audio-type=2048 bandwidth=1103 bitrate=20000 bitrate-type=1 inband-fec=FALSE packet-loss-percentage=0 dtx=FALSE ! fakesink

I then tried updating to GStreamer 1.12.3 but the result was the same.

Finally I extracted libopus-0.dll from the 1.10.2 GStreamer MSI and put it in place of the 1.12.3 version and find the problem goes away.
Comment 1 GStreamer system administrator 2018-11-03 12:00:30 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: