GNOME Bugzilla – Bug 777741
avwait: Rename timecodewait to avwait, add modes
Last modified: 2017-01-26 14:22:41 UTC
Renamed timecodewait to avwait. Added running-time and video-first modes. Default mode is timecode (the previous behaviour).
Created attachment 344211 [details] [review] 0001-avwait-Rename-timecodewait-to-avwait-add-modes.patch
Created attachment 344245 [details] [review] 0001-avwait-Rename-timecodewait-to-avwait-add-modes.patch
Created attachment 344253 [details] [review] 0001-avwait-Rename-timecodewait-to-avwait-add-modes.patch
Review of attachment 344253 [details] [review]: This should probably go into a different plugin at some point ::: gst/timecode/gsttimecodewait.c @@ +398,3 @@ + } else { + GST_DEBUG_OBJECT (self, "First time reset in settings"); + self->running_time_to_wait_for = GST_CLOCK_TIME_NONE; Only if the mode has changed, otherwise you might wait again without reason. Or maybe all these properties must only be set in NULL/READY but not in PAUSED/PLAYING? @@ +425,3 @@ } + if (self->mode != MODE_RUNNING_TIME) { + GST_DEBUG_OBJECT (self, "First time reset in video segment\n"); \n not needed @@ +443,3 @@ g_mutex_lock (&self->mutex); + if (self->mode != MODE_RUNNING_TIME) { + GST_DEBUG_OBJECT (self, "First time reset in video segment\n"); \n not needed @@ +527,3 @@ GstClockTime timestamp; + GstAvWait *self = GST_AVWAIT (parent); + /*GstClockTime duration; */ Why commented out? @@ +538,3 @@ + /*duration = GST_BUFFER_DURATION (inbuf); + if (duration != GST_CLOCK_TIME_NONE) + self->vsegment.position += duration; */ And this
Created attachment 344319 [details] [review] 0001-avwait-Rename-timecodewait-to-avwait-add-modes.patch Thanks for the review, cleaned up the patch, re-uploading. The "duration" part is now removed instead of commented out - it should really go away, the running_time_to_wait_for should be the beginning and not the end of the video frame.
commit 9e4e447ad4dedb6dd7903abe88c0d0aef1b28e68 Author: Vivia Nikolaidou <vivia@toolsonair.com> Date: Wed Jan 25 13:06:28 2017 +0200 avwait: Rename timecodewait to avwait, add modes Renamed timecodewait to avwait. Added running-time and video-first modes. Default mode is timecode (the previous behaviour). https://bugzilla.gnome.org/show_bug.cgi?id=777741