GNOME Bugzilla – Bug 777607
canvas-view: port from old-style type declarations
Last modified: 2017-02-03 13:54:09 UTC
See bug 771777.
Created attachment 344534 [details] [review] canvas-view: port to G_DECLARE* type declaration This patch reduces the manual definition of macros and ports it to G_Declare type declaration, which make the code cleaner and easier to read and understand. The NautilusCanvasDetails has been renamed to NautilusCanvasViewPrivate. Every instance of canvas_view->details has been modified to priv (reference to the private Structure)
Review of attachment 344534 [details] [review]: Cool, thanks! As I mentioned last time, I’m paying more attention to the commit message. > The NautilusCanvasDetails has been renamed to NautilusCanvasViewPrivate. > Every instance of canvas_view->details has been modified to priv (reference to > the private Structure) This is unnecessary, since the diff already tells us that. Take a look at the tips section: https://wiki.gnome.org/Newcomers/CodeContributionWorkflow#Commit_guidelines I think the first paragraph alone will do. ::: src/nautilus-canvas-view.c @@ +1969,2 @@ static void nautilus_canvas_view_finalize (GObject *object) Since we’re only chaining up to the parent method, this no longer needed (don’t forget the override as well). ::: src/nautilus-canvas-view.h @@ +43,2 @@ int nautilus_canvas_view_compare_files (NautilusCanvasView *canvas_view, + NautilusFile *a, Please do style changes separately. Attach another patch for these.
Created attachment 344577 [details] [review] canvas-view: port to G_DECLARE* type declaration This patch reduces the manual definition of macros and ports it to G_Declare type declaration, which make the code cleaner and easier to read and understand.
Created attachment 344578 [details] [review] canvas-view: port to G_DECLARE* type declaration This patch reduces the manual definition of macros and ports it to G_Declare type declaration, which make the code cleaner and easier to read and understand.
Review of attachment 344578 [details] [review]: LGTM, thanks. :)
Review of attachment 344578 [details] [review]: yep!
Attachment 344578 [details] pushed as 04811bc - canvas-view: port to G_DECLARE* type declaration