GNOME Bugzilla – Bug 757344
[PATCHes] password-dialog.ui: Unbloat.
Last modified: 2015-11-01 16:11:14 UTC
Created attachment 314437 [details] [review] passwords-dialog.ui:Manually unbloat. Here are a few patches to unbloat the PasswordsDialog class. They are quite similar to a similar set for the HistoryDialog’s (bug 757228).
Created attachment 314438 [details] [review] PasswordsDialog: Use tree_selection.
Created attachment 314439 [details] [review] PasswordsDialog: Kill a level of GtkBox.
Created attachment 314440 [details] [review] PasswordsDialog: Call response_cb from the UI file.
Created attachment 314441 [details] [review] PasswordsDialog: Use GActions.
Created attachment 314456 [details] [review] Create popup menu from a model.
Created attachment 314464 [details] [review] Define keybindings in UI file.
Created attachment 314479 [details] [review] Visual refresh (GtkActionBar, GtkSearchBar).
Created attachment 314480 [details] [review] Kill a (now) unneeded level of GtkBox.
Please do take a look at bug #757344 if you have a chance.
(In reply to Michael Catanzaro from comment #9) > Please do take a look at bug #757344 if you have a chance. I meant bug #723237
Review of attachment 314437 [details] [review]: It astounds me that Jon managed to do this in Glade.
Review of attachment 314438 [details] [review]: If you prefer this way
Review of attachment 314439 [details] [review]: Unreviewable, but the dialog still works, so it must be fine ;)
Review of attachment 314440 [details] [review]: ::: src/passwords-dialog.c @@ +389,3 @@ gtk_widget_class_bind_template_callback (widget_class, on_copy_username_menuitem_activate); + + gtk_widget_class_bind_template_callback (widget_class, passwords_dialog_response_cb); I almost asked you to get rid of the blank line and rename this to use an on_ style name, but I guess the response callback is special because it's the response callback.
Review of attachment 314441 [details] [review]: ::: src/passwords-dialog.c @@ +529,3 @@ + { "show-passwords", show_passwords } + }; + GSimpleActionGroup *group; I would add a blank line between entries and group.
Review of attachment 314456 [details] [review]: OK
Review of attachment 314464 [details] [review]: OK
Review of attachment 314479 [details] [review]: OK
Review of attachment 314480 [details] [review]: Dialog still works