After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 749566 - HIDPI problems throughout the place
HIDPI problems throughout the place
Product: Gnumeric
Classification: Applications
Component: GUI
Other Linux
: Normal normal
: ---
Assigned To: Jody Goldberg
Jody Goldberg
: 795507 (view as bug list)
Depends on:
Reported: 2015-05-19 07:41 UTC by ma.jiehong
Modified: 2018-05-22 14:19 UTC
See Also:
GNOME target: ---
GNOME version: ---

Screenshot of the toolbar icons, showing their small size. (15.03 KB, image/png)
2015-05-26 09:11 UTC, ma.jiehong
Gnumeric within Gnome 3.16.2 (fullscreen screenshot, native resolution) (138.74 KB, image/png)
2015-07-18 08:27 UTC, ma.jiehong
gnumeric 1.12.18 120dpi font too big to fit in cells (82.60 KB, image/png)
2015-08-05 14:56 UTC, Wirawan Purwanto

Description ma.jiehong 2015-05-19 07:41:40 UTC

I possess a screen with a dpi value of 192, and Gnumeric does not handle well some things I would like to group in this bug report if you don't mind.

My tests are in the following conditions: Archlinux, Plasma 5.3.0.

1. The dpi value of the DE does not seem to be taken into account automatically.
Indeed, by default, horizontal and vertical dpi values are set to 96.0. Yet, some parts seem fine, others do not. Here is a screenshot to give you an idea:

Here is a list of what seems wrong:

- the cells width and height;
- toolbars icons;
- mouse pointer inside the table pane;
- charts legend sizes (not visible on the screenshot).

However, the cell name, input area and zoom values seem just fine.

2. Setting the dpi value (horizontal and vertical) to 192 does not fix everything. Here is a screenshot of the result:

Here is a list of things not impacted by the dpi value:

- mouse pointer inside the table pane (I've just found out that the mouse pointer theme is actually different in the pane! Not matching the breeze theme of plasma 5);
- toolbars icons;

Would you mind having a look at those issues?
Comment 1 Morten Welinder 2015-05-20 20:15:28 UTC
I don't believe there are any plans for working on this.  In part because
we need the toolkit to have proper support (and for the desktop and toolkit
to talk to each other!) and in part because it is unclear what the right
thing to do is.

For example, when you write "toolbars icons" [are wrong] I answer "why?"
Comment 2 ma.jiehong 2015-05-26 09:10:25 UTC
> For example, when you write "toolbars icons" [are wrong] I answer "why?"

The size of the icons in the toolbars are not re-sized, and appear quite small.
I've checked with Libreoffice, and the icons' sizes are bigger.
I've compared with a computer having a 96 dpi screen to confirm.

I believe this part is actually fixable. What do you think about it?

However, I suppose the toolkit support issue you mentioned has more to do with the table pane and the pointer not following the dpi value.

Note: I've added a screenshot of part of the toolbar, so you can better see the icons' sizes. It seems that the space for each icon is correct, but the icon does not fill the entire space.
Comment 3 ma.jiehong 2015-05-26 09:11:03 UTC
Created attachment 303974 [details]
Screenshot of the toolbar icons, showing their small size.
Comment 4 Andreas J. Guelzow 2015-06-30 04:25:08 UTC
The size of the toolbar icons depends on your setting
gconftool-2 --set --type=string /desktop/gnome/interface/toolbar_icons_size "large-toolbar"

So if you have a high resolutions you probably wan tto choose a large (in terms of pixels) size for your toolbar icons.
Comment 5 ma.jiehong 2015-07-01 09:13:16 UTC
Well, this setting doesn't seem to change anything.

First, it seems to be /schemas/desktop/gnome/interface/toolbar_icon_size (so, icon without an "s"), and it expects an int, not a string.

Nevertheless, with an int or the string you gave me, the size is not changed in gnumeric (tried with "large-toolbar", and ints such as 12, 24, 50, 96, 500).

I changed the size, and then start gnumeric, and then close it again. Still no luck.
Comment 6 ma.jiehong 2015-07-18 08:26:59 UTC
The same issue appears with Gnome desktop (3.16.2).

I've attached another screenshot: as you can see, the tool bar size seems fine, but each button is filled with a tiny image (look at the New document icon on the left, or any of them).
Comment 7 ma.jiehong 2015-07-18 08:27:55 UTC
Created attachment 307654 [details]
Gnumeric within Gnome 3.16.2 (fullscreen screenshot, native resolution)
Comment 8 Wirawan Purwanto 2015-08-05 14:55:19 UTC
I noted the same problem with gnumeric version 1.12.18-2, Debian 8 (Jessie) amd64, under xfce4 (version 4.10.1). I set the DPI to 120 (not that much larger like the OP's), but still it results in fonts that are too big to fit in the cells. See next attachment. I believe this is related to the original bug report, so I file it here.
Comment 9 Wirawan Purwanto 2015-08-05 14:56:14 UTC
Created attachment 308796 [details]
gnumeric 1.12.18 120dpi font too big to fit in cells
Comment 10 ma.jiehong 2015-08-05 18:49:03 UTC
@Wirawan Purwanto: gnumeric 1.12.23, and same issue, but not under Gnome 3.

This is the same as issue 1.

Indeed, I think you changed the DPI value under the fonts settings of Xfce, but Gnumeric does not detect the DPI value used in the table pane. Results: fonts are rendered at a higher DPI value, so bigger in term of pixels, but the boxes of the table are the same size, so it's too big.

To fix this issue, you need to provide Gnumeric with the right dpi value to use for the pane under Preferences / Windows / Screen, and set the horizontal and vertical dpi value of your choice.
Comment 11 Kacper Wysocki 2016-07-27 10:34:19 UTC
I have the same problem: cell font too big to fit in cell, which made all my spreadsheets look like garbage on the new screen. My DPI is 192 and setting this in Prefs / Windows / Screen and then restarting gnumeric makes the sheets look OK again. 
In particular, even though I looked briefly for the setting, I did not find it because I did not think to look under "Windows", and so I started to look for a bug report.

A user might give up and use libreoffice rather than look for a preference to set. 

I think people are going to keep reporting this bug, or even give up on gnumeric, until gnumeric automatically detects the DPI size, since there are few other apps that require you to set it in some preference. 

Maybe gnumeric should autodetect the DPI size?
Comment 12 Andreas J. Guelzow 2018-04-28 21:18:14 UTC
*** Bug 795507 has been marked as a duplicate of this bug. ***
Comment 13 GNOME Infrastructure Team 2018-05-22 14:19:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: