After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 749268 - [Regression] 1.22 breaks user <note/>-s
[Regression] 1.22 breaks user <note/>-s
Status: RESOLVED DUPLICATE of bug 749142
Product: gtk-doc
Classification: Platform
Component: general
Other Linux
: Normal critical
: ---
Assigned To: gtk-doc maintainers
gtk-doc maintainers
Depends on:
Reported: 2015-05-12 15:10 UTC by Milan Crha
Modified: 2015-05-15 10:16 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Milan Crha 2015-05-12 15:10:57 UTC
evolution-data-server contains custom gtk-doc code, like <note></note> [1], written exactly the same the guide at [2] suggests, but the new gtk-doc 1.22 fails to build HTML with it. Furthermore, it's gtk-doc 1.22 itself breaking the structure.

The thing is that the generated .xml file has <para><note></para>, which breaks the XML parser. You can try to build evolution-data-server docs to get more similar oddities, which block it from building against 1.22. gtk-doc 1.21 doesn't have this issue.

Comment 1 Stefan Sauer (gstreamer, gtkdoc dev) 2015-05-12 16:19:03 UTC
Isn't this a dupe of #749142 - can you try todays git?
Comment 2 Milan Crha 2015-05-13 09:04:42 UTC
(In reply to Stefan Sauer (gstreamer, gtkdoc dev) from comment #1)
> Isn't this a dupe of #749142 - can you try todays git?

(side note: if you prefix the bug number with a 'bug' word, then it'll be clickable and easier accessible, like here: bug #749142)

gtk-doc git master at commit 0ea674a lets me build the gtk-doc for evolution-data-server, but still has some kind of regression of too many warnings like:
> Warning: multiple "IDs" for constraint linkend: api-index-3.2.
> Warning: multiple "IDs" for constraint linkend: api-index-3.12.
> Warning: multiple "IDs" for constraint linkend: api-index-2.26.
which are new here. the CPU usage is significantly higher too, noticed when it was printing these false warnings.
Comment 3 Stefan Sauer (gstreamer, gtkdoc dev) 2015-05-13 13:58:46 UTC
The warnings are new because gtk-doc now links to the api-index from since tags. For that it needs to give the index an id. It cannot rely on the user giving it an id like eds does

You can either ignore the warning, or drop the id tags from the index in your master doc.

For the CPU usage, do you have before/after figures? E.g. doing
make clean; time make docs;
a few times? There are many changes in the release, but nothing that would explain a significant slowdown.
Comment 4 Stefan Sauer (gstreamer, gtkdoc dev) 2015-05-13 14:05:06 UTC
I looked at some other projects and it seems to be common to use
id="api-index-3-12" on the index tags, allthough its like 60:30. From my jhbuild checkout:

> find . -name "*-docs.*ml" -exec grep "<index id=\"[a-z-]*[0-9-]*\"" {} \; | wc -l
> find . -name "*-docs.*ml" -exec grep "<index id=\"[a-z-]*[0-9.]*\"" {} \; | wc -l
Comment 5 Milan Crha 2015-05-13 16:10:12 UTC
Do you mean that eds should use dash in the version, instead of the dot? That's easily doable, if it's the way it should be done.

The time difference is very significant, that I run it only once. With git master of gtk-doc I get:

   $ cd docs && make clean && time make

   real	1m34.108s
   user	1m32.724s
   sys	0m1.445s

and with gtk-doc-1.21-1.fc21.noarch:

   $ cd docs && make clean && time make

   real	1m29.596s
   user	1m28.112s
   sys	0m1.513s

The difference felt longer than 5 seconds, somehow.

I changed the eds-docs.sgml to use api-index-X-YZ, but it still produces the warnings. This is out of scope of this bug report, thus I'd simply ignore this.

Thanks and feel free to close this as a duplicate of bug #749142.
Comment 6 Stefan Sauer (gstreamer, gtkdoc dev) 2015-05-15 10:16:59 UTC
I run a git bisect. We loose 2.5 seconds due to
commit 6d82b2651bac715be19a4d5fbb03052a6c000549. Hard to believe but I double checked. I filed bug #749419 to track it, but I think I'll release 1.23 without that being fixed, as it might be not trivial.

Regarding the duplicated id's - changing the '.' for '-' in the ids worked for me, could you please check again? I can also submit that fix if you want.

I'll mark this as duplicate for now.

*** This bug has been marked as a duplicate of bug 749142 ***