After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 712340 - GDM, GNOME Shell and Totem don't start with Catalyst 13.11 beta 6
GDM, GNOME Shell and Totem don't start with Catalyst 13.11 beta 6
Product: cogl
Classification: Platform
Component: general
Other Linux
: Normal critical
: ---
Assigned To: Cogl maintainer(s)
Cogl maintainer(s)
Depends on:
Reported: 2013-11-14 22:32 UTC by Eddy Castillo
Modified: 2021-06-10 11:20 UTC
See Also:
GNOME target: ---
GNOME version: ---

backtrace (8.92 KB, text/plain)
2015-03-31 20:54 UTC, sl
glxinfo (26.00 KB, text/plain)
2015-03-31 21:04 UTC, sl

Description Eddy Castillo 2013-11-14 22:32:01 UTC
I'm trying Fedora "20 Beta" release and Catalyst "13.11 beta 6" and gdm is giving me a black screen at startup. I searched on internet about this issue and found bug 701445, but I failed miserably trying to compile all packages mentioned there with those parameters.

GDM does no seem to crash, instead is like is waiting there with a black screen, and I do not know about the internals of GDM, but maybe is GNOME Shell failing to start that does not allow GDM to load completely.

Starting GNOME Shell from terminal it gives this error:

[dyskette@prism ~]$ gnome-shell

(gnome-shell:4856): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed

(gnome-shell:4856): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined
Window manager error: Unable to initialize Clutter.

But, trying to get a trace from that it just tell me "No stack.".

Then I installed LXDE and lxdm to find out if it was a problem of Catalyst, and apparently all games and other software are working fine, except for Totem.

Totem gives this error in terminal.

[dyskette@prism ~]$ totem

(totem:4836): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed

(totem:4836): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined

(totem:4836): Totem-WARNING **: gtk-clutter failed to initialise, expect problems from here on.

(totem:4836): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed

(totem:4836): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined
Segmentation fault (core dumped)

And gives me these traces.

  • #0 cogl_matrix_entry_ref
    at ./cogl-matrix-stack.c line 332
  • #1 cogl_matrix_stack_new
    at ./cogl-matrix-stack.c line 662
  • #2 _cogl_framebuffer_init
    at ./cogl-framebuffer.c line 118
  • #3 cogl_onscreen_new
    at ./cogl-onscreen.c line 104
  • #4 clutter_stage_x11_realize
    at x11/clutter-stage-x11.c line 594
  • #5 clutter_stage_realize
    at ./clutter-stage.c line 789
  • #6 _g_closure_invoke_va
    at gclosure.c line 840
  • #7 g_signal_emit_valist
    at gsignal.c line 3238
  • #8 g_signal_emit
    at gsignal.c line 3386
  • #9 clutter_actor_realize
    at ./clutter-actor.c line 1936
  • #10 _clutter_stage_manager_set_default_stage
    at ./clutter-stage-manager.c line 226
  • #11 clutter_stage_constructed
    at ./clutter-stage.c line 1714
  • #12 g_object_new_with_custom_constructor
    at gobject.c line 1721
  • #13 g_object_new_internal
    at gobject.c line 1744
  • #14 g_object_newv
    at gobject.c line 1890
  • #15 g_object_new
    at gobject.c line 1556
  • #16 clutter_stage_new
    at ./clutter-stage.c line 3384
  • #17 gtk_clutter_embed_init
    at ./gtk-clutter-embed.c line 965
  • #18 g_type_create_instance
    at gtype.c line 1862
  • #19 g_object_new_internal
    at gobject.c line 1746
  • #20 g_object_new_valist
    at gobject.c line 2012
  • #21 g_initable_new_valist
    at ginitable.c line 227
  • #22 g_initable_new
    at ginitable.c line 149
  • #23 bacon_video_widget_new
    at bacon-video-widget.c line 6077
  • #24 video_widget_create
    at totem-object.c line 4160
  • #25 ??
  • #26 ??
  • #27 ??
  • #28 ??

Is this a regression to the bug mentioned earlier or is it another one? And, is there a workaround in the meantime? I really like GNOME Shell and I don't feel comfortable with other DE's.

P.S. I'm filling this bug in cogl following the same pattern as bug 701445. I'm sorry if this does not belong here.
Comment 1 Tommy He 2013-11-15 13:11:24 UTC
I met exactly the same issue with Fedora 20 Beta with:

Comment 2 Eddy Castillo 2013-11-18 01:17:48 UTC
OK, I have GNOME Shell and Totem working with Catalyst 13.11 beta 6 finally, rebuilding rpms.

In cogl spec file, %build section 
  --enable-cogl-gles2=no \
  --enable-wayland-backend=no \
#  --enable-kms-egl-platform \
#  --enable-wayland-egl-platform \
#  --enable-wayland-egl-server \
#  --enable-xlib-egl-platform

In clutter spec file, %build section
        --enable-wayland-backend=no \
        --enable-wayland-compositor=no \
#%if %{with_wayland}
#        --enable-egl-backend \
#        --enable-evdev-input \
#        --enable-wayland-backend \
#        --enable-wayland-compositor \

In gnome-shell spec file, 
%prep section, commented:
# %patch10 -p1 -b .fix-wayland-build
%install section, commented:
# desktop-file-validate %{buildroot}%{_datadir}/applications/gnome-shell-wayland.desktop
# %{_bindir}/gnome-shell-wayland
# %{_datadir}/applications/gnome-shell-wayland.desktop

Totem spec file did not need any modification, just rebuilding again is enough.

Source rpm files are:
Comment 3 Tommy He 2013-11-18 02:48:02 UTC
Informative result you have find. Thanks!

I just filed an issue against Catalyst Driver on AMD Bugzilla:
It should be able to deal with EGL.
Comment 4 Eddy Castillo 2013-11-21 22:11:50 UTC
Bijiben and Cheese are also not starting. Rebuilding (with custom cogl and clutter from previous comment) fix them.
Comment 5 Giuseppe Castagna 2013-12-20 22:34:09 UTC
Unfortunately the fix in Comment 2 no longer works with the Fedora 20. The gnome-shell package no longer compiles. The reason I think is because the wayland patch has been included in gnome-shell. I have tried to disable in the spec file for gnome-shell everything concerning wayland but it does not compile.

Any suggestion?
Comment 6 Giuseppe Castagna 2013-12-20 23:35:32 UTC
Well actually not ... the compilation still works. I had just to remove mutter-wayland-devel-3.10.1-1.fc20.x86_64 since otherwise configure detected it and tried to call the inexistent wayland libraries when rebuilding gnome-shell
Comment 7 drago01 2014-01-11 15:58:16 UTC
Can you attach your glxinfo output?
Comment 8 Kamil Páral 2014-01-17 09:37:07 UTC
This might be relevant:
Comment 9 Tobias Hansen 2014-05-09 15:06:40 UTC
The bug has now also reached Debian (unstable and testing) [1]. It seems like the correct explanation is given in [2]: glGetString(GL_VERSION) finds a string in another library than the fglrx libGL. The workaround mentioned in [2] to preload works on Debian.

Comment 10 sl 2014-12-18 13:33:14 UTC
any news?
but still reproducible with  libcogl20 1.18.2, fglrx 14.12 (debian)
Comment 11 Vinz 2015-01-04 21:43:19 UTC
I can confirm 1.18.2 is affected too.

This bug is open for more than a year, now. Any chance to get this fixed in a coming release of cogl ?

Does any developer need some logs, trace or anything else helping ?
Comment 12 Emmanuele Bassi (:ebassi) 2015-03-31 15:00:58 UTC
It seems that there's something wrong with the AMD drivers on Linux.

Using dlopen/dlsym on is not weird: it's pretty much how people have been using libGL since forever. Maybe fglrx expects people to link directly to libGL? That would be weird, and it would not allow things like shipping Cogl with support for desktop GL and GLES in the same shared library. It could also be an artefact of the linking done when building the shared library.

Obviously, without knowing how these libraries are being built, there's not much we, as free software developers, can do. It would be helpful to notify AMD and see what are the requirements in order to use their libraries via libdl.
Comment 13 sl 2015-03-31 20:54:34 UTC
Created attachment 300709 [details]
Comment 14 sl 2015-03-31 21:04:55 UTC
Created attachment 300713 [details]
Comment 15 André Klapper 2021-06-10 11:20:39 UTC
GNOME is going to shut down in favor of
As part of that, we are mass-closing older open tickets in
which have not seen updates for a longer time (resources are unfortunately
quite limited so not every ticket can get handled).

If you can still reproduce the situation described in this ticket in a recent
and supported software version of cogl, then please follow
and create a ticket at

Thank you for your understanding and your help.