After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 693151 - ftpadmin install is failing with IO error on master.g.o
ftpadmin install is failing with IO error on master.g.o
Product: sysadmin
Classification: Infrastructure
Component: Mirrors
Other Linux
: Normal major
: ---
Assigned To: GNOME Sysadmins
GNOME Sysadmins
Depends on:
Reported: 2013-02-04 16:41 UTC by Aaron D Borden
Modified: 2013-02-22 14:01 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Aaron D Borden 2013-02-04 16:41:25 UTC
[adborden@master ~]$ ftpadmin install tomboy-1.13.5.tar.gz 
Gathering information and sorting on version: ., done
Preparing installation of tomboy-1.13.5.tar.gz:
 - Checking consistency: ..........., done
 - Checking previous tarball: ..........., done
 - NEWS, done (diff, 5 lines)
 - ChangeLog, done (diff, 116 lines)
 - Creating tar.xz from tar.gz: ..........., done
 - Creating sha256sum, done

      Module: tomboy
     Version: 1.13.5   (previous version: 1.13.4)
 Destination: /ftp/pub/GNOME/sources/tomboy/1.13/

Install tomboy? [Y/n] Y
Installing tomboy-1.13.5.tar.gz:
 - Moving files: Traceback (most recent call last):
  • File "/usr/local/bin/ftpadmin", line 1688 in <module>
  • File "/usr/local/bin/ftpadmin", line 1673 in main
    options.func(options, parser)
  • File "/usr/local/bin/ftpadmin", line 1363 in cmd_install
  • File "/usr/local/bin/ftpadmin", line 964 in install
    shutil.move(fn, dest)
  • File "/usr/lib64/python2.6/", line 260 in move
    copy2(src, real_dst)
  • File "/usr/lib64/python2.6/", line 95 in copy2
    copyfile(src, dst)
  • File "/usr/lib64/python2.6/", line 52 in copyfile
    copyfileobj(fsrc, fdst)
IOError: [Errno 5] Input/output error

Comment 1 Paolo Bacchilega 2013-02-04 19:57:43 UTC
This happens to me as well.
Comment 2 Paolo Bacchilega 2013-02-04 20:34:46 UTC
I just tried again and it works now.
Comment 3 Olav Vitters 2013-02-04 20:35:28 UTC
Disk space issues. I've removed some stuff, but have issues with amount of space.
Comment 4 Olav Vitters 2013-02-04 21:08:41 UTC
commits-list archives make up 42GB…
Comment 5 Xan Lopez 2013-02-06 18:06:32 UTC
This is happening again as I write this.
Comment 6 Andrea Veri 2013-02-06 19:38:33 UTC
It should be OK again, I'll migrate our main NFS node next week so we can finally have some more free space.
Comment 7 Andrea Veri 2013-02-22 14:01:58 UTC
We've migrated our main NFS node to another machine, we have plenty of free space now, so this should be fixed. Thanks for reporting!