After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 692929 - [rtpopuspay] - No rtp timestamp
[rtpopuspay] - No rtp timestamp
Product: GStreamer
Classification: Platform
Component: gst-plugins-bad
Other Linux
: Normal major
: 1.0.6
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Reported: 2013-01-31 11:00 UTC by Daniel
Modified: 2013-01-31 11:37 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Daniel 2013-01-31 11:00:21 UTC
It seems like rtpopuspay does not produce RTP timestamp as it should. All packets gets the same timestamp. Here is an example of a pipeline I have tried:
gst-launch-1.0 autoaudiosrc ! opusenc ! rtpopuspay pt=97 ! udpsink port=45001

I have tried adding a lof caps and properties as well, but none seem to help me to get timestamps. I have also added rtpbin hoping that would help, but it did not.

If I use exactly the same pipeline but with ulaw/pcmu it works fine:
gst-launch-1.0 autoaudiosrc ! mulawenc ! rtppcmupay pt=97 ! udpsink port=45001
Comment 1 Wim Taymans 2013-01-31 11:37:07 UTC
commit de648b8832f386726088aebf610159c0e72c2ce1
Author: Wim Taymans <>
Date:   Thu Jan 31 12:30:49 2013 +0100

    opuspay: fix timestamps
    Copy timestamps to payloaded buffer.
    Avoid input buffer memory leak.