After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 690730 - Error pushing files to gnome-calculator
Error pushing files to gnome-calculator
Product: sysadmin
Classification: Infrastructure
Component: Git
Other Linux
: Normal normal
: ---
Assigned To: GNOME Sysadmins
GNOME Sysadmins
Depends on:
Reported: 2012-12-26 09:08 UTC by Daniel Mustieles
Modified: 2012-12-30 18:39 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Daniel Mustieles 2012-12-26 09:08:02 UTC
When I try to push some translations into gnome-calculator, I get the following error message:

$ git push
Counting objects: 9, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (5/5), 616 bytes, done.
Total 5 (delta 3), reused 0 (delta 0)
error: insufficient permission for adding an object to repository database ./objects

fatal: failed to write object
error: unpack failed: unpack-objects abnormal exit
To ssh://
 ! [remote rejected] master -> master (n/a (unpacker error))
error: failed to push some refs to 'ssh://'

I've deleted my local copy and cloned a fresh one, but I still get the error. Where is the problem?

Comment 1 Andrea Veri 2012-12-28 10:02:42 UTC
Try again now.
Comment 2 Daniel Mustieles 2012-12-28 12:15:48 UTC
Still the same error :(
Comment 3 Olav Vitters 2012-12-28 21:10:29 UTC
For some reason only this repository did not have group write permissions. Fixed that now..
Comment 4 Daniel Mustieles 2012-12-30 18:39:57 UTC
Now it works. Thanks!