After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 687836 - Copy button not enabled in Copy CD/DVD dialog when using two drives
Copy button not enabled in Copy CD/DVD dialog when using two drives
Product: brasero
Classification: Applications
Component: libbrasero-burn
git master
Other Linux
: Normal normal
: ---
Assigned To: Brasero maintainer(s)
Brasero maintainer(s)
Depends on:
Reported: 2012-11-07 11:57 UTC by Paul Menzel
Modified: 2018-09-21 17:41 UTC
See Also:
GNOME target: ---
GNOME version: ---

Screencast showing the problem of disabled button Copy (583.18 KB, application/octet-stream)
2012-11-07 12:39 UTC, Paul Menzel

Description Paul Menzel 2012-11-07 11:57:54 UTC
In contrast to bug 661394 the copy button is not enabled in the Copy CD/DVD dialog. Running `brasero -g` from the command line I see the following message.

    BraseroBurn: (at brasero-session-cfg.c:567) Session currently not ready for flag computation: adding flags (will update later)

Could that point out the problem?

I am running Brasero 3.4.1-4 and GTK+ 3.4.2-4 from Debian Sid/unstable but could also reproduce this with a build from the master branch of the Git repository.
Comment 1 Paul Menzel 2012-11-07 12:39:29 UTC
Created attachment 228360 [details]
Screencast showing the problem of disabled button Copy

I made a screencast with Ctrl + Shift + Alt + r showing the problem of the disabled button Copy and the misbehaving combo box, which is bug 661394 [2].

Comment 2 Paul Menzel 2012-11-09 16:41:52 UTC
Using two drives seems to trigger this problem. People, I asked to reproduce this, having only one drive (the CD/DVD burner) could not reproduce this. I can also work around it by putting the to be copied medium/disc into the burner. Of course no direct copy is possible then.

I am not even sure if Brasero is supposed to support burning directly from a medium from one drive to another.
Comment 3 Paul Menzel 2012-11-11 15:58:53 UTC
Alright. Here are some more news. After trying to debug this issue and not finding the cause, I tried a different audio CD with no CD Text. And lo and behold, it worked. Trying a third one with CD Text it worked. Looking at the difference, it turns out the first non-working audio CD, which was also the first to be copied, has »ù« in its volume ID (CD name/title) which seems to cause the problem. :(
Comment 4 Paul Menzel 2012-11-11 16:01:01 UTC
Trying this CD with Rhythmbox, it is also was not accepted, that means the CD symbol shows up shortly but then is removed again. I will file a separate report for that but I guess the problem lies deeper. Brasero is able to display the special char though (when using an UTF-8 character set, that means »_« is displayed with `LANG=C brasero`)).
Comment 5 GNOME Infrastructure Team 2018-09-21 17:41:05 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: