After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 684907 - ftpadmin abort with a timeout
ftpadmin abort with a timeout
Status: RESOLVED DUPLICATE of bug 657832
Product: sysadmin
Classification: Infrastructure
Component: Other
Other Linux
: Normal normal
: ---
Assigned To: GNOME Sysadmins
GNOME Sysadmins
Depends on:
Reported: 2012-09-26 19:41 UTC by Sébastien Granjoux
Modified: 2013-01-16 10:07 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Sébastien Granjoux 2012-09-26 19:41:34 UTC
I run the following command
ftpadmin install gdl-3.6.0.tar.xz

and get
Preparing installation of gdl-3.6.0.tar.xz:
 - Checking consistency: .., done
 - Checking previous tarball: .., done
 - NEWS, done (diff, 5 lines)
 - ChangeLog, ignored (no change)
 - Copying tar.xz, done
 - Creating sha256sum, done

      Module: gdl
     Version: 3.6.0   (previous version: 3.5.91)
 Destination: /ftp/pub/GNOME/sources/gdl/3.6/

Install gdl? [Y/n] Y
Installing gdl-3.6.0.tar.xz:
 - Creating directory, done
 - Moving files: ..., done
 - Updating LATEST-IS, done
 - Updating known versions, done
 - Removing original tarball, done
Doing notifications:
 - Informing ftp-release-listTraceback (most recent call last):
  • File "/usr/local/bin/ftpadmin", line 1688 in <module>
  • File "/usr/local/bin/ftpadmin", line 1673 in main
    options.func(options, parser)
  • File "/usr/local/bin/ftpadmin", line 1363 in cmd_install
  • File "/usr/local/bin/ftpadmin", line 994 in install
  • File "/usr/local/bin/ftpadmin", line 1043 in inform
    desc = self.moduleinfo.get_one_from_doap('description')
  • File "/usr/local/bin/ftpadmin", line 743 in get_one_from_doap
    for node in self.doap:
  • File "/usr/local/bin/ftpadmin", line 736 in doap
    self._doap = semi_rdf.read_rdf(self.DOAPURL % self.reponame)
  • File "/home/admin/bin/git/", line 174 in read_rdf
  • File "/usr/lib64/python2.6/xml/sax/", line 102 in parse
    source = saxutils.prepare_input_source(source)
  • File "/usr/lib64/python2.6/xml/sax/", line 298 in prepare_input_source
    f = urllib.urlopen(source.getSystemId())
  • File "/usr/lib64/python2.6/", line 86 in urlopen
  • File "/usr/lib64/python2.6/", line 207 in open
    return getattr(self, name)(url)
  • File "/usr/lib64/python2.6/", line 349 in open_http
    errcode, errmsg, headers = h.getreply()
  • File "/usr/lib64/python2.6/", line 1064 in getreply
    response = self._conn.getresponse()
  • File "/usr/lib64/python2.6/", line 990 in getresponse
  • File "/usr/lib64/python2.6/", line 391 in begin
    version, status, reason = self._read_status()
  • File "/usr/lib64/python2.6/", line 349 in _read_status
    line = self.fp.readline()
  • File "/usr/lib64/python2.6/", line 433 in readline
    data = recv(1)
IOError: [Errno socket error] [Errno 104] Connection reset by peer

I think only the notification has not been sent. Is it ok or should I send again the module?
Comment 1 Frederic Peters 2012-09-26 20:05:35 UTC
I don't know about the timeout but you can try running "ftpadmin notify TARBALL" to do the notification part.
Comment 2 Sébastien Granjoux 2012-09-26 20:25:22 UTC
(In reply to comment #1)
> I don't know about the timeout but you can try running "ftpadmin notify
> TARBALL" to do the notification part.

Thanks, I have done it and it has worked.
Comment 3 Robert Roth 2013-01-16 10:07:19 UTC

*** This bug has been marked as a duplicate of bug 657832 ***