After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 671920 - DVD menus not shown when interlacing enabled, as in Bug 668762
DVD menus not shown when interlacing enabled, as in Bug 668762
Product: GStreamer
Classification: Platform
Component: gst-plugins-bad
Other Linux
: Normal normal
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Reported: 2012-03-12 17:03 UTC by Julian Andres Klode
Modified: 2012-12-01 19:33 UTC
See Also:
GNOME target: ---
GNOME version: ---

Compressed log with GST_DEBUG=5 (416.93 KB, application/x-xz)
2012-03-12 17:03 UTC, Julian Andres Klode

Description Julian Andres Klode 2012-03-12 17:03:04 UTC
Created attachment 209510 [details]
Compressed log with GST_DEBUG=5

I basically have exactly the same problem as in bug 668762. I tested with 0.10.23. This release includes the patch for that bug according to git. I have attached a log for a run of totem at GST_DEBUG=5. This bug is the same as
Comment 1 Julian Andres Klode 2012-03-23 19:04:53 UTC
Comments would be appreciated.

As a further note for everyone here (I wrote that in the Debian bug, but forgot to add it here): This bug does not happen with any DVD. I tested a Firefly DVD and a Doctor Who DVD, and only the Doctor Who DVD was affected.

If you need further information, let me know. If you happen to have a Doctor Who DVD 3 of Series 3 (the one including Daleks in Manhattan) you might be able to reproduce it yourself. It should probably be reproducible with other discs as well, but I have only tried the Firefly and the Doctor Who one yet.

For reference, I am also quoting the Debian bug report for you:

-- Debian bug report:
Totem does not play my Doctor Who DVD. Instead of displaying the menu,
it just displays a black image. The DVD can be played back correctly
using VLC, mplayer, and via:
	gst-launch-0.10 playbin2 uri=dvd://

Totem also seems to not have a general problem with DVDs, as it can
play my first Firefly DVD correctly. I have attached a log file of
totem with GST_DEBUG=5 and a screenshot of totem.

I did not such problems with Doctor Who DVDs in the past either, so
this must be a relatively new problem.
Comment 2 Vincent Penquerc'h 2012-06-07 14:25:57 UTC
Looking at my comments on the other bug to refresh my memory, it's possible that some other element sends an event to a blocked pad here as well.

Could you generate a stack trace with all threads by attaching to totem after it's started not displaying what it ought to be displaying ?

gdb `which totem` `pidof totem` >& /tmp/totem-bt
thread apply all bt
Comment 3 Tim-Philipp Müller 2012-10-16 22:13:10 UTC
If you're on debian sid, could you re-test with GStreamer 1.0.x ?

Don't think it's got new-enough totem yet, but this should do as well:

  $ gst-launch-1.0 playbin uri=dvd://

(or uri=dvd:///path/to/foo/VIDEO_TS/ )
Comment 4 Julian Andres Klode 2012-10-16 22:18:45 UTC
Yes, I think I can do this during the weekend.
Comment 5 Tim-Philipp Müller 2012-11-27 20:24:25 UTC
Julian: have you had a chance to re-test with 1.0.3 yet?
Comment 6 Julian Andres Klode 2012-12-01 18:29:50 UTC
It seems to work with 1.0.3 and with 0.10.36 as well, so some commit after 0.10.23 probably fixed it.
Comment 7 Tim-Philipp Müller 2012-12-01 19:33:45 UTC