After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 655928 - Mouse buttons not working in dialog boxes in Gtk3 when using xmodmap -e pointer = "3 2 1"
Mouse buttons not working in dialog boxes in Gtk3 when using xmodmap -e point...
Product: gtk+
Classification: Platform
Component: Widget: Other
Other Linux
: Normal critical
: ---
Assigned To: gtk-bugs
: 666457 (view as bug list)
Depends on:
Reported: 2011-08-03 20:03 UTC by dann
Modified: 2011-12-19 13:10 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description dann 2011-08-03 20:03:44 UTC
This is on Fedora 15 with gtk3-3.0.11-1.fc15.i686

I use fvwm2 and also
xmodmap -e "pointer = 3 2 1"

to make the mouse left handed.

When running 

selecting "Dialog and Message Boxes"

opens a dialog box, but the buttons in that dialog box do not react to any
mouse clicks, what is strange is that item selected the main gtk3-demo window
changes when clicking on the dialog box...

No other widgets seem to have this problem.

gtk3-demo is just an example, the problem happens in all Gtk3+ applications.

gtk2-demo does NOT have this problem.

This setup has worked for 10+ years, no other toolkits have the same problem.
Comment 1 Larik Ishkulov 2011-12-01 10:23:34 UTC
I have the same proble with gentoo and awesome. gtk version 3.2.2.
Comment 2 Larik Ishkulov 2011-12-02 06:00:37 UTC
In my case all windows I open in gtk3-demo doesn't react on mouse clicks exept first window. And all clicks on secondary windows are propagated to the first window.
Comment 3 ExecutorElassus 2011-12-15 15:48:47 UTC
I'd like to point out that this bug is appearing in multiple bug trackers and forums:
etc etc

I have the same problem, starting from about 1. December, affecting all GTK apps (audacious, evince) in multiple WMs (GNOME, FVWM). The only consistent feature is that I have "pointer = 3 2 1 4 5 ..." set via xmodmap. 

added info: I ran xev on the mouse, and pasted the output doing some basic actions with audacious to this forum post:

Hope this helps, and that we can get a fix soon.
Comment 4 Matthias Clasen 2011-12-16 01:25:43 UTC
This is a problem in XI2.
As a quick workaround, you can set GDK_CORE_DEVICE_EVENTS=1
Comment 5 ExecutorElassus 2011-12-16 02:40:24 UTC
thank you for the workaround. Since I'm kinda dumb about setting envvars, where and how do I set that? Just include that line in my .xsession file? in xorg.conf?

Comment 6 Matthias Clasen 2011-12-16 02:45:07 UTC
If you want it for your entire session, you can put it in ~/.bash_profile
Comment 7 Peter Hutterer 2011-12-16 02:45:13 UTC
This actually turned out to be a server bug. For a fix see
Comment 8 ExecutorElassus 2011-12-16 03:05:56 UTC
hurrah! glad to see a patch is up. Any estimates when it will filter downstream? (or, for that matter, how I can apply the patch myself? I'm dumb about that, too)
Comment 9 Peter Hutterer 2011-12-19 02:38:58 UTC
Since the original reporter is on Fedora, here are the update links:

For other distributions, please file a bug against the X.Org X server component and get them to include the patch linked in Comment #7.

This bug should be closed as NOTGNOME, the real bug is filed here now:
Comment 10 Matthias Clasen 2011-12-19 04:57:01 UTC
*** Bug 666457 has been marked as a duplicate of this bug. ***