After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 654201 - Wrong track metadata with multiple CD
Wrong track metadata with multiple CD
Status: RESOLVED DUPLICATE of bug 652972
Product: rhythmbox
Classification: Other
Component: Importing
Other Linux
: Normal normal
: ---
Assigned To: RhythmBox Maintainers
RhythmBox Maintainers
Depends on:
Reported: 2011-07-07 22:24 UTC by elvellon
Modified: 2011-07-31 22:39 UTC
See Also:
GNOME target: ---
GNOME version: ---

Calls to MusicBrainz Database (4.84 KB, application/octet-stream)
2011-07-07 22:24 UTC, elvellon

Description elvellon 2011-07-07 22:24:19 UTC
Created attachment 191499 [details]
Calls to MusicBrainz Database

I tried to import a set of 3 CDs (precisely : ).
First CD went fine, but when fetching tracks metadata for the other two, Rhythmbox displayed metadata from CD 1.

In example : when entering CD 3, rhythmbox displays "Piano Concerto No. 1 in C major, Op. 15", part 1, 2 and 3 (which are the first three tracks of CD 1) instead of "Piano Concerto No. 5 in E-flat major, Op. 73", part 1, 2 and 3 (the actual tracks).

Launching from CLI shows that MusicBrainz is prompted a first time for 
which returns the correct set of tracks, and a second time for
which returns the complete recording (ie tracks from CD 1, 2 and 3).

My guess is that RB takes metadata from the X first tracks of the second call, which leads to the mentionned error with multiple CD releases.

My version of RB is 2.90.1.git20110610-2, fetched from the Arch Linux repositories. It is the latest version for Arch right now.

To reproduce : buy this wonderfull recording and import it ! ;)
Comment 1 Claudio Saavedra 2011-07-20 08:35:49 UTC
I could reproduce this as well. Basically it's impossible to rip an album that comes from a multiple disc release. I tried with this album:

Soundjuicer has a similar problem, see bug 654756.
Comment 2 Christophe Fergeau 2011-07-31 22:39:00 UTC

*** This bug has been marked as a duplicate of bug 652972 ***