After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 637376 - Evoultion periodically hangs for seconds while e-addressbook-factory uses 100%CPU
Evoultion periodically hangs for seconds while e-addressbook-factory uses 100...
Status: RESOLVED DUPLICATE of bug 629945
Product: evolution
Classification: Applications
Component: Mailer
2.32.x (obsolete)
Other Linux
: Normal critical
: ---
Assigned To: evolution-mail-maintainers
Evolution QA team
Depends on:
Reported: 2010-12-16 09:12 UTC by Giacomo
Modified: 2011-03-31 08:00 UTC
See Also:
GNOME target: ---
GNOME version: ---

evolution strace (190.97 KB, text/plain)
2011-01-04 11:34 UTC, Giacomo

Description Giacomo 2010-12-16 09:12:00 UTC
While writing mails but also doing everything else, evolution hangs
for a while (10 seconds more or less). top shows e-addressbook-factory
using 100%CPU.
After that period you can go on working, but periodically (seconds)
the program hangs again.
top often shows  e-addressbook-factory, even when you are not using
evolution, so I do not know whether the issues are related.

This problem makes the application unusable.

version 2.32, but also 2.30 was affected by similar behaviour, even
worse (periodical random crashes on receiving mails).

Gnome 2.32, gentoo linux.

USE flags for gnome-extra/evolution-data-server-2.32.1
- - doc           : Adds extra documentation (API, Javadoc, etc)
 - - gnome-keyring : Enable support for storing passwords via gnome-keyring
 - - ipv6          : Adds support for IP version 6
 - - kerberos      : Adds kerberos support
 - - ldap          : Adds LDAP support (Lightweight Directory Access Protocol)
 + + ssl           : Adds support for Secure Socket Layer connections
 - - test          : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in
                     make.conf/package.use anymore
 + + weather       : Enable optional weather calendar support.

 USE flags for mail-client/evolution-2.32.1:
 U I
 - - connman        : Enable net-misc/connman support (requires 'networkmanager' USE flag to be disabled).
 + + crypt          : Enable GPG encryption support using app-crypt/gnupg and app-crypt/pinentry
 - - doc            : Adds extra documentation (API, Javadoc, etc)
 - - gstreamer      : Adds support for media-libs/gstreamer (Streaming media)
 - - kerberos       : Adds kerberos support
 - - ldap           : Enable support for fetching contacts from an LDAP or Active Directory server using net-nds/openldap
 - - networkmanager : Allows Evolution to automagically toggle online/offline mode by talking to net-misc/networkmanager and getting the current
                      network state
 - - profile        : Build support for profiling Evolution for development purposes
 + + python         : Adds support/bindings for the Python language
 + + ssl            : Adds support for Secure Socket Layer connections

Let me know if you need more info.

Thanks Giacomo.
Comment 1 André Klapper 2010-12-16 15:45:34 UTC
strace output welcome when this happens.
Comment 2 Giacomo 2011-01-04 11:34:45 UTC
Created attachment 177469 [details]
evolution strace

Hi. I attach the evolution.strace output.
Launched evolution, clicked on a item on the subject item list widget.
top shows e-addressbook-factory 100%CPU usage while evolution hangs.
Tried to close evolution. No way. Had to kill the process.

Hope the trace helps solving a problem that have affected my evolution installation for more than one year, making it unusable.

Many thanks Giacomo.
Comment 3 Felix Riemann 2011-01-07 17:20:55 UTC
I'm seeing this as well under Gentoo and Evo 2.32. It's most notable when I start evolution since it apparently blocks the rendering of the mails (just telling me it's formatting the mail). Attaching strace to e-addressbook-factory just gives lots of
sched_yield()                           = 0

Attaching gdb indicates that the gconf client blocks on dbus while trying to contact the gconf server.

It's apperently also affecting the addressbook view which first shows empty books and then shows an error dialog:

Unable to open address book

This address book cannot be opened.  Please check that the path /home/felix/.local/share/evolution/addressbook/1265194980.2103.1@localhost exists and that permissions are set to access it.

Detailed error message: Error calling StartServiceByName for org.gnome.evolution.dataserver.AddressBook: Timeout was reached
Comment 4 Felix Riemann 2011-01-07 17:27:55 UTC
Backtrace of e-addressbook-factory burning CPU-cycles:

Thread 1 (Thread 0x7fe6f8405720 (LWP 16984))

  • #0 sched_yield
    at ../sysdeps/unix/syscall-template.S line 82
  • #1 _g_dbus_shared_thread_ref
    at gdbusprivate.c line 354
  • #2 _g_dbus_worker_new
    at gdbusprivate.c line 1449
  • #3 initable_init
    at gdbusconnection.c line 2380
  • #4 g_bus_get_sync
    at gdbusconnection.c line 6273
  • #5 get_ior
    at gconf-internals.c line 2445
  • #6 gconf_get_server
    at gconf-internals.c line 2494
  • #7 gconf_activate_server
    at gconf-internals.c line 2844
  • #8 try_to_contact_server
    at gconf.c line 2315
  • #9 gconf_get_config_server
    at gconf.c line 2359
  • #10 gconf_engine_connect
    at gconf.c line 359
  • #11 gconf_engine_get_default
    at gconf.c line 608
  • #12 gconf_client_get_default
    at gconf-client.c line 452
  • #13 setup_offline_listener
    at e-offline-listener.c line 89
  • #14 e_offline_listener_new
    at e-offline-listener.c line 113
  • #15 main
    at e-data-book-factory.c line 599

Comment 5 Lukas Schneiderbauer 2011-02-12 11:12:31 UTC
I'm suffering from exactly the same issues.
Using Gentoo and evolution-2.32.2, evolution-data-server-2.32.2

For 'evolution-addressbook-export' it's the same. After some seconds waiting, it reports:
$ /usr/libexec/evolution/2.32/evolution-addressbook-export -l

(evolution-addressbook-export:19297): libebook-WARNING **: e-book.c:3079: cannot activate book: Error calling StartServiceByName for org.gnome.evolution.dataserver.AddressBook: Timeout was reached

(evolution-addressbook-export:19297): evolution-addressbook-tools-WARNING **: failed to open book

Are there any workarounds to export contact-data until this bug is fixed? I'm quite in a hurry to get the data in usable formats (like vCard).
Comment 6 Giacomo 2011-03-01 09:42:23 UTC
Are there any news?

Evolution 2.32.2-r1 is still unusable when it comes to e-addressbook factory.

I have to remove /usr/libexec/e-addressbook-factory in order to be able to use the client, but, of course, no address book :(

So evolution has been quite unusable since at least 2.28 in gentoo for me.

Eliminating the "source" entries in gconf-editor works around the problem, but
as soon as a new address book is created, e-addressbook-factory consumes 100% CPU and evolution hangs for seconds.

Let me know if there's any hope to have the issue addressed and solved.

Thanks in advance

Comment 7 Pacho Ramos 2011-03-01 17:17:02 UTC
Maybe would help if you could tell here how do you create the new addressbook, maybe it's containing something causing this problem...
Comment 8 Giacomo 2011-03-02 10:08:14 UTC
Switch to "Contacts" by clicking on the "Contacts" push button on the bottom left corner of the GUI.
Then, near the New button on the left, I select "Address Book" from the drop down list.

CPU goes 100% as to e-addressbook-factory.

Address book type is "On this computer".

Comment 9 Andrei Popa 2011-03-28 13:40:39 UTC
Please change the status to CONFIRMED as there are many other users who encountered this bug as said by:
Including me.
Comment 10 Milan Crha 2011-03-30 07:02:30 UTC
Backtrace matches bug #629945, thus I'm marking this one as a duplicate.

*** This bug has been marked as a duplicate of bug 629945 ***
Comment 11 Pacho Ramos 2011-03-30 08:45:11 UTC
If this is a dupe of bug 629945 and it's fixed with this should then be solved with glib-2.28.

Have reported tried with that glib version?
Comment 12 Felix Riemann 2011-03-30 16:47:38 UTC
(In reply to comment #11)
> If this is a dupe of bug 629945 and it's fixed with
> this should then be solved with glib-2.28.
> Have reported tried with that glib version?

Yes, I had it running with 2.28. Didn't help.

I updated to Evo 2.91.92 yesterday and the problem seems to be gone since then.
Comment 13 Andrei Popa 2011-03-30 17:37:48 UTC
I also have 2.28 and have the same problem.
Comment 14 Andrei Popa 2011-03-31 06:51:20 UTC
I upgraded evolution to 2.91.92 and now the addressbook works.
Comment 15 Giacomo 2011-03-31 07:17:11 UTC
Confirm that glib-2.28 does not solve the problem.

Comment 16 Pacho Ramos 2011-03-31 08:00:12 UTC
Would be nice to know what commit to master fixed this as I am not sure when we will be able to have Gnome3 in main tree downstream at Gentoo :-(

(Also seems clear that this is not a dupe of bug 629945 as glib-2.28 should includes referred change)