After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 633759 - Pencil tool draws 'jigsaw' line.
Pencil tool draws 'jigsaw' line.
Product: GIMP
Classification: Other
Component: Tools
Other All
: Normal major
: 2.8
Assigned To: GIMP Bugs
Depends on:
Reported: 2010-11-02 00:27 UTC by larsmednosen
Modified: 2015-10-18 21:26 UTC
See Also:
GNOME target: ---
GNOME version: ---

describing the pencil problem in gimp (751.75 KB, image/png)
2010-11-02 00:27 UTC, larsmednosen
comparison between gimp 2.4.7 and 2.6.11 pencil problem (470.04 KB, image/png)
2010-11-11 15:00 UTC, larsmednosen
A robot to test for straight line movement (3.11 KB, application/octet-stream)
2010-11-12 12:29 UTC, LightningIsMyName

Description larsmednosen 2010-11-02 00:27:15 UTC
Created attachment 173660 [details]
describing the pencil problem in gimp

1. I open a new document (I tried to make them different sizes and resolution, but this doesn't affect the problem)

2. I pick the 'pencil' tool, and try to draw a 'straight' line (of course it wont be dead straight on freehand, but you get my point)

The line are like a jigsaw with small teething(see attached .png file), but if I change the zoom-level to 200 or 400 % and make a new line, the problem doesn't occur at all. However if i set it to a lower zoom, like 50%, the problem is there.

I dont know what causes this problem, but it didn't occur before I upgraded from 10.04 to 10.10.

Comment 1 larsmednosen 2010-11-02 00:53:26 UTC
ubuntu 10.04 to 10.10 that is...
Comment 2 LightningIsMyName 2010-11-06 01:15:22 UTC
Does not seem like a bug - seems like a case of inaccuracy with the mouse (which is more visible with the pencil tool since unlike the paintbrush tool it draws rough lines and doesn't soften them).

To test that this is the case, I used a robot in my operating system to move the cursor programatically in a straight line - and I got no jaggies in the line. In fact, after training myself several minutes I could draw straight lines myself.

Further checking showed that if I put my optical mouse on a paper with small grid, I gain much more control on it than on other surfaces, and that way I could draw straight lines very easily.

The pencil tool just makes inaccuracy more visible - no bug here.
You had more control when zooming in since the pencil tool is pixel aligned, and when zooming in each pixel was "bigger" so it is easier to draw a line in the same row of pixels.

Finally, you can test that the behaviour is correct by using the straight line feature inside gimp (Click and release at some point, hold the shift button and click somewhere else) - and that way we do get a straight line. If this wouldn't draw a straight line for you - then there is a bug, otherwise it's just inaccuracy with the mouse/tablet/...

Closing as RESOLVED NOTABUG. If you have any more information which shows that there is in fact a bug, feel free to post it here and re-open the bug.
Comment 3 larsmednosen 2010-11-07 00:14:49 UTC
Please read all the information, I said in my post:

"I dont know what causes this problem, but it didn't occur BEFORE I upgraded
from 10.04 to 10.10."

I also tried to draw a line with the mouse running against a ruler (an actual ruler on the desk) and it showed the same result, a jigsaw at 100% and below, and no problem at 200% and above.

I also tried to do the same steps as I explained, in my original post, but in gimp(for windows) thru wine, and the problem didn't occur at all.

Please read the whole post next time before taking any action, please.

Comment 4 Martin Nordholts 2010-11-07 12:32:44 UTC
You can reproduce the problem in GIMP 2.6.10, but what version can you not reproduce this in?
Comment 5 larsmednosen 2010-11-11 14:00:14 UTC
There is no problem in gimp 2.4.5 or 2.4.7 and it doesn't have anything to do with ubuntu, as I thought before, cos I get the same results in windows xp and gimp 2.6.11.

I might have to clarify this:

The problem occurs when you draw a line with the pencil tool


The zoom is set to 100% or below (25%, 50% for example) 

Comment 6 larsmednosen 2010-11-11 15:00:56 UTC
Created attachment 174254 [details]
comparison between gimp 2.4.7 and 2.6.11 pencil problem

Showing the results when trying to draw a couple of 'straight' lines, by hand (mouse), in gimp 2.4.7 and 2.6.11. (at 100 %) This really shows the problem.
Comment 7 LightningIsMyName 2010-11-12 12:29:42 UTC
Created attachment 174323 [details]
A robot to test for straight line movement

I seem to be able to reproduce this bug on Ubuntu 10.10 with GIMP 2.6.10, but I can't reproduce this on Windows 7 with GIMP 2.6.4

I'm attaching a robot program in java (instructions on compiling it are inside it) which moves the mouse in a straight line - this is done by the OS and not by GIMP so it allows us to truly test how GIMP behaves when drawing straight lines.

When using gimp 2.6.10 (with the mouse disconnected from the computer so it won't conflict with the robot) I can reproduce this bug - jaggies are drawn at the bgeining of the line. When using GIMP 2.6.4 on windows 7 (Again with the mouse disconnected), the robot can not reproduce this bug.

Furthermore, testing the drawing using the PDB's gimp-pencil shows that in both cases it can draw a straight line. So I suspect that somewhere in the process of getting the points (maybe the smoothing of the points) from the input, this bug occures.
Comment 8 Alexis Wilhelm 2012-03-19 19:42:35 UTC
This bug seems to have disappeared with this commit:

commit 2b8605639d935d997dd95c3f6aebd7be91dade31
Author: Alexia Death <>
Date:   Wed Nov 17 19:55:16 2010 +0200

    app: Disable somewhat obsolete stroke smooth
Comment 9 Michael Natterer 2012-03-20 10:32:58 UTC
Nice, thanks for checking, closing as FIXED.