After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 628710 - Crash when calling "New File" with a charset <> utf8 in LANG
Crash when calling "New File" with a charset <> utf8 in LANG
Status: RESOLVED DUPLICATE of bug 624270
Product: GnuCash
Classification: Other
Component: General
Other All
: Normal critical
: ---
Assigned To: Andreas Köhler
Andreas Köhler
: 643653 646582 (view as bug list)
Depends on:
Reported: 2010-09-03 15:20 UTC by Frank H. Ellenberger
Modified: 2018-06-29 22:44 UTC
See Also:
GNOME target: ---
GNOME version: ---

Trace file recovered from german mailing list (1.32 KB, text/plain)
2010-09-04 11:59 UTC, Geert Janssens
gdb output recovered from german mailing list (1.25 KB, text/plain)
2010-09-04 12:01 UTC, Geert Janssens
gdb session with r19847 (4.03 KB, text/plain)
2010-11-20 06:40 UTC, Frank H. Ellenberger
Backtrace for crash after attempting to create preferences dialog (16.77 KB, text/plain)
2011-04-21 12:22 UTC, Martin Szulecki

Description Frank H. Ellenberger 2010-09-03 15:20:06 UTC
There is a report in the german mailing list, where a user got a crash, when calling File->New->New File.

He sent a gnucash.trace and the gdb output in .

He used LANG=de_DE@euro and solved his problems when using LANG=de_DE.UTF-8.

I could reproduce the crash also with LANG=
de_DE.ISO-8859-1, nl_NL.ISO-8859-1, fr_FR.ISO-8859-1, but not with
en_GB.ISO-8859-1 or en_US.ISO-8859-1.
Comment 1 Geert Janssens 2010-09-04 11:59:51 UTC
Created attachment 169479 [details]
Trace file recovered from german mailing list
Comment 2 Geert Janssens 2010-09-04 12:01:02 UTC
Created attachment 169480 [details]
gdb output recovered from german mailing list

For convenience I have added the trace and gdb output as attachments.
Comment 3 Geert Janssens 2010-09-04 12:17:56 UTC
I'm afraid I can't reproduce the problem here, being on Mandriva 2010.0 32-bit.

I did
* set LANG to de_DE.ISO-8859-1 or nl_NL.ISO-8859-1
* start svn build of gnucash (yesterday's checkout)
* select File -> New -> New File (which is obviously translated)

This brings up the new account hierarchy druid, which I can nicely complete.

Can you provide more details about your system, and which steps do cause the crash ?
Comment 4 Frank H. Ellenberger 2010-09-04 14:08:58 UTC
After updating to r19544 the crash still happens, when the first window of the new file druid should appear.

In gnucash.trace, I have additional some occurences of
* 15:18:32  WARN <libglade> unknown property `orientation' for class `GtkVBox'
* 15:18:32  WARN <libglade> unknown property `orientation' for class `GtkVPaned'
 but I see no negative impact of this. The rest of gnucash.trace is the same as in .

The OP used gentoo, I'm on openSUSE 11.1 (x86_64) with 
Comment 5 Christian Stimming 2010-09-23 06:57:49 UTC
@Frank: Can you provice a better stack trace? The one given in comment#2 doesn't show any debug symbols and it also doesn't indicate any gnucash function being involved in this crash.
Comment 6 Frank H. Ellenberger 2010-11-20 06:40:08 UTC
Created attachment 174902 [details]
gdb session with r19847

here is my gdb session with a fresh build r19847 
bt full gives a few locals
does this help?
Comment 7 Thomas Capricelli 2011-03-31 09:54:26 UTC
Hi, i have the same problem here. My computer is configured in italian (LC_ALL=it_IT.UTF-8) and it works well. I need to do some stuff in French, so i have this alias for gnucash : 
( setenv LC_ALL fr_FR; \gnucash )
with this configuration, clicking on the menu entry "new file" will crash badly

I gave a look to the file /etc/locale.gen, and there are those lines:
    fr_FR ISO-8859-1
    fr_FR@euro ISO-8859-15
    fr_FR@euro UTF-8

So i tried :
( setenv LC_ALL fr_FR@euro ; \gnucash )

and now this does not crash anymore.
Comment 8 Geert Janssens 2011-04-03 20:03:12 UTC
*** Bug 646582 has been marked as a duplicate of this bug. ***
Comment 9 Martin Szulecki 2011-04-21 12:21:05 UTC
I was using "LANG=de_DE gnucash" and got crashes on "strncmp" at various locations with git master.

Just run gnucash like that and either use "new file" or enter "preferences".

As this worked before though I'd say this is a regression.
Comment 10 Martin Szulecki 2011-04-21 12:22:21 UTC
Created attachment 186421 [details]
Backtrace for crash after attempting to create preferences dialog
Comment 11 Geert Janssens 2011-06-11 16:14:45 UTC
*** Bug 643653 has been marked as a duplicate of this bug. ***
Comment 12 Frank H. Ellenberger 2011-07-15 21:13:56 UTC
From []:

On Tue, 2011-07-12 at 21:46 +0200, Vincent Smeets wrote:

Thanks for your reply.
I hope you don't mind if I replied to the gnucash list.

> this looks like
Looks like the same bug. So not a GNUcash but a gtk+-2 bug according
to the patch (I am using the same gtk+-2.24.4)

--- gtk+2.0-2.24.4.orig/gtk/gtkentrycompletion.c
+++ gtk+2.0-2.24.4/gtk/gtkentrycompletion.c
@@ -790,7 +790,8 @@ gtk_entry_completion_default_completion_
       normalized_string = g_utf8_normalize (item, -1, G_NORMALIZE_ALL);
       case_normalized_string = g_utf8_casefold (normalized_string, -1);
-      if (!strncmp (key, case_normalized_string, strlen (key)))
+      if ((case_normalized_string != NULL) &&
+          !strncmp (key, case_normalized_string, strlen (key)))
        ret = TRUE;
       g_free (item);

Hm, I am not shure what to do with this bug:
* Assign to gtk+,
* Close as Not GnuCash or
* keep it open until fixed gtk+ versions are out.
Comment 13 Geert Janssens 2011-10-10 20:55:41 UTC
I don't think there is much gained with keeping this bug report open for GnuCash.

I have added an entry in our FAQ we can refer other victims of this bug to:

Other than that, I will mark this bug as a duplicate of the original gtk+ bug for this issue: bug 624270.

If you don't agree, feel free to reopen.

*** This bug has been marked as a duplicate of bug 624270 ***
Comment 14 John Ralls 2018-06-29 22:44:02 UTC
GnuCash bug tracking has moved to a new Bugzilla host. This bug has been copied to Please update any external references or bookmarks.