After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 618239 - Quickfill/Autocomplete broken when using Xfce
Quickfill/Autocomplete broken when using Xfce
Product: GnuCash
Classification: Other
Component: Register
Other Linux
: Normal major
: ---
Assigned To: David Hampton
Chris Shoemaker
Depends on:
Reported: 2010-05-10 09:20 UTC by dzsunk
Modified: 2018-06-29 22:39 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description dzsunk 2010-05-10 09:20:02 UTC
BUG: Autocomplete broken when using Xfce
EXPECTED BEHAVIOR: Autocomplete should work as advertised.
INSTEAD: Cells somehow loose the selection after the first few keypresses, so autcomplete is not useful anymore.

Steps to reproduce:
- start typing in any autocomplete-enabled cell that has a history of a few items
- first few keyresses work as expected
- selection gets lost (even when just Shift is pressed while attempting to type ':' ), but the selection marker not always!
- next keypress always hides the selection marker and appends the character at the end of the previously autocompleted word

I've just started using gnucash (great product btw.) and noticed that when typing into auto-complete enabled cells, after a few keypresses, the selection gets lost and text is being appended to the end of the previously completed suggestion.

This only happens when using Xfce (I have version 4.6.1, latest stable). Switching to gnome, blackbox, fluxbox etc. solves the problem. While I don't mind running development versions of most applications, I would not want to update to Xfce-GIT, since I have to use my desktop for work.

Since I'm a programmer, I tried tracing the culprit with no luck. I have no experience with gtk, so I just assumed that a misplaced/misbehaving gtk_editable_select_region was responsible but haven't been able to pinpoint the problem.

I don't have any more time (nor am I the best man to do it) to try and fix this issue, but it is a real annoyance for me. The bug might very well be in Xfce itself, but until I don't know what exactly is causing the problem, I'm reluctant to report to Xfce. Maybe some gnucash developer can fix this bug, or find the underlying problem and report upstream to Xfce.
Comment 1 dzsunk 2010-05-10 09:28:01 UTC
Forgot to mention that this happens with 2.2.9 too, the latest stable version of gnucash.
Comment 2 dzsunk 2010-05-10 13:34:44 UTC
Worked it out... It was the Clipman panel plugin that somehow interfered with the selection. Disabling the plugin made the "issue" go away.
Comment 3 John Ralls 2018-06-29 22:39:08 UTC
GnuCash bug tracking has moved to a new Bugzilla host. This bug has been copied to Please update any external references or bookmarks.