After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 586844 - Problem with transparency in vte
Problem with transparency in vte
Product: Sawfish
Classification: Deprecated
Component: Window Manager
Other All
: Normal minor
: 3.0.x
Assigned To: sawfish-maint
Depends on:
Reported: 2009-06-24 13:18 UTC by Jonathan W
Modified: 2011-01-06 22:16 UTC
See Also:
GNOME target: ---
GNOME version: 2.25/2.26

transparency issue with new tab in ROXTerm (29.73 KB, image/png)
2009-06-24 13:19 UTC, Jonathan W
screenshot #1 of window redrawing problem (279.83 KB, image/png)
2009-07-06 15:03 UTC, Jonathan W
screenshot #2 of window redrawing problem (459.22 KB, image/png)
2009-07-06 15:08 UTC, Jonathan W
screenshot #3 of window redrawing problem (350.54 KB, image/png)
2009-07-06 15:28 UTC, Jonathan W
problem continues with vte 0.2.22 (85.71 KB, image/png)
2009-10-06 20:52 UTC, Jonathan W

Description Jonathan W 2009-06-24 13:18:08 UTC
Please describe the problem:
Sometimes (circumstances unclear, but definitely more often than not), opening a new tab in either ROXTerm or gnome-terminal results in a tab with no transparency except where there's text. A simple ctrl-l fixes this slight annoyance, as does doing anything in the tab that makes text scroll. See example in attachment.

Steps to reproduce:
I'm using compositing via Cairo Composite Manager 0.2.93.

Actual results:

Expected results:

Does this happen every time?

Other information:
Filed original as a bug in ROXTerm at
Comment 1 Jonathan W 2009-06-24 13:19:07 UTC
Created attachment 137311 [details]
transparency issue with new tab in ROXTerm
Comment 2 Christian Persch 2009-06-24 13:27:17 UTC
Can you reproduce this in gnome-terminal when using metacity and metacity's compositor instead?
Comment 3 Jonathan W 2009-06-24 15:50:45 UTC
It seems I can't reproduce it at *all* if sawfish isn't running.  Even with Cairo CM and no window manager running, it doesn't happen (this is also the case with compiz).  But once sawfish is started back up, it starts happening again.
Comment 4 Jonathan W 2009-07-06 11:24:22 UTC
There appear to be some other problems with compositing when running sawfish (but not with compiz or even metacity+CCM):

Sometimes when tabbing between windows, a raised window doesn't redraw completely (or sometimes at all).  If a transparent window above it is redrawn, all parts of the recently raise window under the transparency are visible through the transparency, even if the rest of the window isn't otherwise visible.  This has been a problem for about the same amount of time as the issues with terminals, and my guess is that they're related.  I can apparently take screenshots of this.

I suppose the question now is who to report the problem to.  Sawfish seems like a first choice, though they're likely to blame it on Cairo CM (even though these problems don't appear to be present with metacity running with CCM).
Comment 5 Christian Persch 2009-07-06 11:51:59 UTC
It's of course possible that this is indeed a bug in vte being exposed by sawfish. But since it's not reproducible in either metacity or compiz, it's much more likely a sawfish bug. Let's try moving it there.
Comment 6 Christopher Roy Bratusek 2009-07-06 12:06:12 UTC
What CCM backend do you use? Try the different ones. 

I'm using -of course- the latest gits of sawfish/rep-gtk/librep aswell as the latest git of CCM and I never saw that problem. I'll check it later on, but try using the latest versions of all 4.
Comment 7 Jonathan W 2009-07-06 12:26:24 UTC
I'm running the latest debian unstable versions of sawfish (, rep-gtk (0.18.4-2), and librep9 (0.17.3-3).  I'm using CCM 0.2.93, which I think is the latest stable release.

I was using the X rendering backend.  When I switch to OpenGL TFP, the problem with window redrawing becomes much less severe (though there're still some problems).  The problem with terminal redrawing remains in gnome-terminal (it's completely disappeared in ROXTerm).

I'll try installing the latest git of CCM later, and move on from there to sawfish and rep.
Comment 8 Jonathan W 2009-07-06 15:03:23 UTC
Created attachment 137924 [details]
screenshot #1 of window redrawing problem
Comment 9 Jonathan W 2009-07-06 15:08:58 UTC
Created attachment 137925 [details]
screenshot #2 of window redrawing problem
Comment 10 Jonathan W 2009-07-06 15:28:13 UTC
Created attachment 137926 [details]
screenshot #3 of window redrawing problem

Multiple screenshots to give a full idea of the sorts of problems seen.  All with OpenGL backend to CCM.
Comment 11 Christopher Roy Bratusek 2009-08-16 16:13:33 UTC
... I just got that issue, too. After updating to X.Org 1.6.3 ... gimmie some time to check wether (the driver) or sawfish is causing it.
Comment 12 Jonathan W 2009-09-01 22:36:11 UTC
I should add that I tried sawfish 1.5 recently and the problem was still there.

As for xorg, I'm using version 1.6.2 and the intel driver (version 2.7.1).
Comment 13 Jonathan W 2009-09-05 18:04:35 UTC
The following bug (which also affects me) is recently looking more and more related to this bug:
Comment 14 Christopher Roy Bratusek 2009-10-05 18:28:53 UTC
... well I just updated to vte 0.22.2 (Debian SID) and the problem is gone. I had that transparency issue with GNOME-Terminal + VIm. So I guess it actually was a VTE Bug.

can you confirm that?
Comment 15 Jonathan W 2009-10-05 20:20:19 UTC
It does indeed seem to've gone away FINALLY with the latest version of vte in debian.

.....  What a relief.  I can use sawfish painlessly again.
Comment 16 Jonathan W 2009-10-06 20:50:22 UTC
On further evaluation, it seems I've been getting similar problems as before, though usually not as severe.  I finally caught one in a screenshot.
Comment 17 Jonathan W 2009-10-06 20:52:15 UTC
Created attachment 144915 [details]
problem continues with vte 0.2.22
Comment 18 Christopher Roy Bratusek 2009-12-05 16:47:01 UTC
Well I can't reproduce it with all vte-based Terminals, eg I can reproduce it from time to time with GNOME-Terminal, but never could with Guake, can you check that?
Comment 19 Christopher Roy Bratusek 2009-12-19 07:27:52 UTC
-> 3.0
Comment 20 Christopher Roy Bratusek 2011-01-06 17:33:31 UTC
Still hapening? What versions are you using?
Comment 21 Jonathan W 2011-01-06 21:42:15 UTC
Haven't seen it in quite a while.  I think there was a bug in roxterm that got fixed, and that fixed the rest of the trouble.  I just upgraded to vte 24.3-2 (debian) from 24.1-1 and I'm running sawfish 1.5.3-2, which could probably also use an upgrade.  But as relates to this bug, I think everything's been solved.
Comment 22 Jonathan W 2011-01-06 21:44:13 UTC
I should also note that I'm using xcompmgr now instead of Cairo.  It seems much more stable, and though it lacks effects, it gets along with my system a lot better.
Comment 23 Christopher Roy Bratusek 2011-01-06 22:16:24 UTC
So I guess I can close it. Seemed to be a Rox/CCM issue.
Feel free to re-open if it ever happens again.