After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 583822 - Title buttons don't work when keyboard is in Russian mode
Title buttons don't work when keyboard is in Russian mode
Product: Sawfish
Classification: Deprecated
Component: Window Manager
Other All
: Normal normal
: 1.5.x
Assigned To: Christopher Roy Bratusek
: 159284 564861 652297 (view as bug list)
Depends on:
Reported: 2009-05-25 17:27 UTC by Victor Porton
Modified: 2011-06-14 06:05 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Victor Porton 2009-05-25 17:27:24 UTC
Please describe the problem:
Window title buttons don't work when keyboard is in Russian mode (note that I use Gnome Keyboard Indicator and Gnome Keyboard Preferences to switch to Russian keyboard mode).

sawfish version 1.3.4

Steps to reproduce:
1. Switch to Russian keyboard mode
2. Click maximize or minimize button of a window

Actual results:

Expected results:
Window maximization or minimization

Does this happen every time?

Other information:
Comment 1 Christopher Roy Bratusek 2009-05-25 18:02:47 UTC
Just tried it with sawfish 1.5.0 trunk and it does not happen here.

Can you try with latest trunk?
Comment 2 Christopher Roy Bratusek 2009-07-12 19:45:27 UTC

anyone here?
Comment 3 Christopher Roy Bratusek 2009-07-12 19:46:16 UTC
What theme are you using? Try using a different one, like Crux.
Comment 4 Jan "Yenya" Kasprzak 2009-09-16 10:04:42 UTC
I have the same problem here with the Czech keyboard as a secondary layout. More info in the following thread in sawfish-list:

I have also tried the default configuration (mv ~/.sawfish ~/.sawfish-; killall sawfish; sleep 2; sawfish ), and it behaves the same: when the secondary layout is on, the window decoration buttons do not work, and it is not even possible to move the window by dragging the title bar.

I have tried 1.5.0 with the mouse patches from the trunk removed (as described in the above thread).
Comment 5 Jan "Yenya" Kasprzak 2009-09-16 10:15:04 UTC
When I start sawfish-ui and try to change the bindings for the window move
(select e.g. Bindings->Title->Move window interactively, press Edit, in
the pop-up window press Grab, switch to the secondary kbd layout and drag mouse
with button 1, the "-Button1-Move" string is filled to the "Key:" input box
(when the primary layout is in use, the same action is described as "Button1-Move", without the leading hyphen).

So apparently sawfish detects the secondary layout as some kind of unknown modifier.
Comment 6 Teika Kazura 2010-01-26 08:11:55 UTC
This is an almost duplicate of 159284 and 564861, but this file contains most informations.
Comment 7 Teika Kazura 2010-02-20 06:37:31 UTC
Finally, the fix is planned for Sawfish-3.0, but I will take months. Sorry.

As a workaround, you can switch the keyboard layout by runnig setxkbmap, triggered by a key press. Yes, it's awkward.
Comment 8 Jan "Yenya" Kasprzak 2010-02-20 10:16:38 UTC
The problem is e.g. with combining the text written in non-english language with special characters (like \ { } in TeX) - for me it is faster to write these characters using the US layout. This requires _very_ fast layout switching (I switch layouts every 10-20 characters when writing slides in LaTeX-beamer), something which setxkbmap, even mapped to a hotkey, cannot do.

Anyway, thanks for the info, I am looking forward to 3.0.
Comment 9 Teika Kazura 2010-06-15 02:18:28 UTC
Hi. I think my patch now fixes the problem. Please test this patch:

(The target versions are 1.6.1 - 1.6.3. It is not so difficult
to patch manually to 1.6 or earlier versions.)

Compile as usual. Invoke sawfish as
$ sawfish --5-buttons
You can't bind a command to buttons 6-9 any more. (This may be fixed in
future, but it'll be quite difficult.)
Comment 10 Teika Kazura 2010-07-23 23:07:59 UTC
Please give us your feedback after you try this patch. It's now in GIT source, too. Thanks.
Comment 11 Jan "Yenya" Kasprzak 2010-07-30 14:57:04 UTC
I have tested it on git version 6306ae11c0fd8c876521b286f83fba32003c2f49. So far it works for me. Thanks for fixing this!

A minor problems, though:

- "sawfish --help" should display the new "--5-buttons" option

- the Git version of sawfish now tries to decorate both GNOME panels I have, which is really ugly. After some experiments, I have discovered that with the default setup it works, but with my theme (blue-steel) it does not. The following line in ~/.sawfish/custom makes the difference:

(custom-set-typed-variable (quote default-frame-style) (quote blue-steel) (quote frame-style))

I have worked around it by adding a window rule to display frame type "none" on windows with class matching ^Gnome-panel/gnome-panel$.

Should I file a separate bug, or is blue-steel theme no longer supported? I prefer this theme for its usability: this is one of the very few themes which have the focused window clearly marked by changing the color of the _whole_ frame (not only the title bar and the left side as in the default theme). So I can find a focused window even only a part of it is visible.
Comment 12 Christopher Roy Bratusek 2010-07-30 18:14:19 UTC
Nice to see it's fixed.

I've added --5-buttons to sawfish --help in GIT.

blue-steel is not part of the default themes, so you should post your issue to the Mailinglist rather than BugZilla. ( -- please register before).

closing as FIXED.
Comment 13 Christopher Roy Bratusek 2010-07-31 06:12:24 UTC
*** Bug 159284 has been marked as a duplicate of this bug. ***
Comment 14 Christopher Roy Bratusek 2010-07-31 06:12:53 UTC
*** Bug 564861 has been marked as a duplicate of this bug. ***
Comment 15 Teika Kazura 2011-06-14 06:05:04 UTC
*** Bug 652297 has been marked as a duplicate of this bug. ***