After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 582436 - Path set to '/' for keyboard shortcuts
Path set to '/' for keyboard shortcuts
Status: RESOLVED DUPLICATE of bug 662528
Product: gnome-settings-daemon
Classification: Core
Component: media-keys
Other All
: Normal normal
: ---
Assigned To: gnome-settings-daemon-maint
: 586825 619631 665377 (view as bug list)
Depends on:
Reported: 2009-05-13 08:23 UTC by Cedric Jeanneret
Modified: 2012-03-29 11:40 UTC
See Also:
GNOME target: ---
GNOME version: 2.25/2.26

Description Cedric Jeanneret 2009-05-13 08:23:00 UTC
Please describe the problem:
I discover a nice thing, while attempting to create a custom shortcut launching a shell (system -> preferences -> kb shortcuts -> custom shortcuts) :

when launching through my shortcut, some environment things weren't exported, like my ssh-agent...

I also tried to launch it through default launcher, this works fine. it works when launching it through application->accessories->terminal

I tried to launch it through gmrun, which is really nicer than default launcher, because it has tab completion... it failed, no ssh-agent.

This bug was found on ubuntu jaunty, up-to-date, and a bug was opened there :

Steps to reproduce:
1. create a new CUSTOM shortcut, launching a shell [i.e. gnome-terminal, xterm]
2. launch your shell through your new shortcut
3. type in "env"
4. launch a shell through menu or default launcher
5. type in "env"
6. compare, especially the SSH_AUTH_SOCK line

Actual results:
gnome-settings-daemon doesn't seem to give correct environment

Expected results:
it should do.

Does this happen every time?

Other information:
Comment 1 Cedric Jeanneret 2009-08-12 06:21:58 UTC
Any news about this stuff ? as I said, it's quiet annoying. Sure we can set terminal to whatever we want through preferences, but still, it shouldn't break environment like that.

Thank you.


Comment 2 Jens Granseuer 2009-08-12 16:57:25 UTC
This actually works correctly for me with both 2.24 and current trunk.
Comment 3 Psy[H[] 2010-05-26 01:19:39 UTC
Bug still exisis. 
I'm using archlinux and gnome-control-center 2.30.1-1:
Current dir for apps launched by custom keybindings is incorrect: / instead of ~/
It's very unhandy when using custom run dialogs.
Comment 5 Bastien Nocera 2010-09-22 14:48:27 UTC
*** Bug 619631 has been marked as a duplicate of this bug. ***
Comment 6 Bastien Nocera 2010-09-22 14:54:04 UTC
That's for the path problem:
375         /* get outta the way */•
376         chdir ("/");•
377 }•

I don't know how you use your ssh-agent, but it's very likely that it's setup after gnome-settings-daemon has been launched, so there's not really that much that it can do about it.

The easiest way to reproduce is to add a shortcut to launch gnome-terminal. Fails as expected.
Comment 7 Bastien Nocera 2010-10-13 14:24:43 UTC
The path problem is fixed with this commit.

commit 00cf2e8bad7b04c22a3dc90d2550f8c34e4542cf
Author: Bastien Nocera <>
Date:   Wed Oct 13 13:58:13 2010 +0100

    daemon: Never daemonise the "daemon"
    As discussed on IRC, this makes no sense, and could potentially
    break application launching from the keybindings or media-keys
Comment 8 Bastien Nocera 2011-07-13 13:43:35 UTC
*** Bug 586825 has been marked as a duplicate of this bug. ***
Comment 9 Bastien Nocera 2011-12-03 11:44:59 UTC
*** Bug 665377 has been marked as a duplicate of this bug. ***
Comment 10 Bastien Nocera 2012-03-29 11:40:35 UTC
Duplicating against the gnome-session bug that would handle the SSH auth problem.

Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

*** This bug has been marked as a duplicate of bug 662528 ***