After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 507895 - Exporting images with filenames with international characters halts the upload
Exporting images with filenames with international characters halts the upload
Product: f-spot
Classification: Other
Component: General
Other All
: Normal major
: ---
Assigned To: F-spot maintainers
F-spot maintainers
Depends on:
Reported: 2008-01-07 18:43 UTC by
Modified: 2018-07-01 08:58 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description 2008-01-07 18:43:05 UTC
Please describe the problem:
If I choose to export (to Web Gallery) a couple of files that are named for example:


This won't work. It will halt the upload.

Steps to reproduce:
1. Export image with perhaps an 'å' in it.

Actual results:
The progress bar will halt at 100%

Expected results:
It should go on with the next image in queue or say that it's finished

Does this happen every time?

Other information:
Comment 1 Maxxer 2008-01-11 11:20:55 UTC
The error happens in src/GalleryRemote.cs:557

When uploading a photo with one of that characters inside, Gallery returns some extra response after the common "status, status_text, item_name, auth_token" headers. The extra content is the following:

<title>501 Method Not Implemented</title>
<h1>Method Not Implemented</h1>
<p>- to / not supported.<br />
<address>Apache/2.2.4 (Ubuntu) PHP/5.2.3-1ubuntu6.3 Server at Port 80</address>

Not having any = on the line, the method GetNextLine will return an array with only 1 value, which makes the WriteLine data[1] fail.

Some further investigation is needed, because it could be a Gallery [RemotePlugin] problem. Even commenting out the data[1] access, the next picture upload fails with 

System.Net.WebException: Unhanded exception ---> System.Net.WebException: The remote server returned an error: (500) Internal Server Error.

Have you ever tried uploading such pictures using GalleryRemote application?
Comment 2 2008-01-15 20:52:00 UTC
Just did, it worked with GalleryRemote although the filenames was changed to the "html-equivalent" of the international characters.

For example, å became &aring; and a file called 'test med allt åäö.jpg' became 'test med allt &aring;&auml;&ouml; &ouml;&ouml;.JPG'.

Comment 3 André Klapper 2018-07-01 08:58:41 UTC
f-spot is not under active development anymore, has not seen code changes for five years, and saw its last tarball release in the year 2010.
Its codebase has been archived:

Closing this report as WONTFIX as part of Bugzilla Housekeeping to reflect reality. Please feel free to reopen this ticket (or rather transfer the project to GNOME Gitlab, as GNOME Bugzilla is deprecated) if anyone takes the responsibility for active development again.