After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 505990 - Make distcheck fails on extension install not in --prefix
Make distcheck fails on extension install not in --prefix
Product: seahorse-plugins
Classification: Applications
Component: General
Other Linux
: High major
: 2.24
Assigned To: seahorse-plugins-maint
Depends on: 505331
Blocks: 509940
Reported: 2007-12-28 00:40 UTC by Olav Vitters
Modified: 2008-09-07 15:33 UTC
See Also:
GNOME target: ---
GNOME version: ---

Patch to fetch nautilus extension dir (2.11 KB, patch)
2008-01-01 22:55 UTC, Brian Pepple
committed Details | Review

Description Olav Vitters 2007-12-28 00:40:12 UTC
nautilus 2.21 looks for extensions in /usr/lib/nautilus/extensions-2.0
Comment 1 Olav Vitters 2007-12-28 21:40:32 UTC
Possible way to fix:

(note: the .pc file is not correct yet, should be in 2.21.2)
Comment 2 Brian Pepple 2008-01-01 22:55:03 UTC
Created attachment 101956 [details] [review]
Patch to fetch nautilus extension dir
Comment 3 Adam Schreiber 2008-01-07 18:21:47 UTC
Committed. Thanks.

2008-01-07  Adam Schreiber  <>

	* plugins/nautilus-ext/ (nautilus_extensiondir): 
	* (NAUTILUS_LIBS): Fetch nautilus extension
	dir from libnautilus-extension.pc.  Patch from Brian Pepple.  
	Fixes bug #505990
Comment 4 Stef Walter 2008-01-14 16:33:48 UTC
This does not pass make distcheck, and is preventing a 2.21.5 release. I tried to fix it by adding a $(DESTDIR) variable, but that does not work. 

I'm no wizard in the voodoo that is autotools.
Comment 5 Adam Schreiber 2008-01-14 17:19:26 UTC
I can't replicate the problem here.  make distcheck succeeds as root.

seahorse-2.21.5 archives ready for distribution: 

As far as I can tell with svn diff, there are no modified files in my local directory structure.
Comment 6 Brian Pepple 2008-01-14 17:31:32 UTC
I was able to have distcheck succeed also as root, on a fresh co.

seahorse-2.21.5 archives ready for distribution: 
Comment 7 Stef Walter 2008-01-14 17:42:25 UTC
The reason it succeeds as root is because it scribbles all over /usr/lib during a distcheck, and the same will occur for those building packages.

make distcheck shouldn't be run as root. 

Comment 8 Alexander Larsson 2008-01-16 21:25:55 UTC
distcheck uses --prefix, not DESTDIR, so adding a DESTDIR does not help.

One approach would be to add --disable-nautilus-extension (or some other flag
that just disables installing it) to DISTCHECK_CONFIGURE_FLAGS
Comment 9 Stef Walter 2008-01-18 03:43:37 UTC
Hmmm, that is a solution, but I'd certainly rather build the nautilus extension during distcheck. 

Does anyone know if there's a shell variable we can use in to detect whether the script is in distcheck mode or not? That way we can force a path within the prefix for the nautilus extension while doing a distcheck.
Comment 10 Alexander Larsson 2008-01-18 09:11:57 UTC
There is no such shell variable, but you can add one yourself, set by e.g. --disable-nautilus-extension-install which you pass in from DISTCHECK_CONFIGURE_FLAGS.
Comment 11 Adam Schreiber 2008-04-23 15:46:21 UTC
Installation of our epiphany plugin has this same issue.
Comment 12 André Klapper 2008-06-05 14:57:59 UTC
any news here? this is blocking a release.
Comment 13 Stef Walter 2008-07-22 14:45:32 UTC
Adam, how do we build the epiphany plugin? I'm on ubuntu and can't figure out what packages to install to get it to build. There's thousands of lines of autofoo being run, and it's all very confusing for me.
Comment 14 Adam Schreiber 2008-07-22 20:17:57 UTC
The easiest way to get the build dependencies on Ubuntu is to run sudo apt-get build-dep seahorse (remember that hardy doesn't reflect the package split) and sudo apt-get build dep epiphany-extensions
Comment 15 Stef Walter 2008-07-23 00:54:11 UTC
Hmmm, still doesn't work for me. Moving this build discussion to the mailing list, as it's not totally on topic for this bug report. Hope that's okay.
Comment 16 Stef Walter 2008-09-07 15:33:39 UTC
This works now.