After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 492076 - Proxy usage
Proxy usage
Product: empathy
Classification: Core
Component: Accounts
Other Linux
: Normal major
: ---
Assigned To: empathy-maint
: 533168 (view as bug list)
Depends on:
Reported: 2007-10-31 13:06 UTC by Marius M. M.
Modified: 2009-11-11 15:38 UTC
See Also:
GNOME target: 2.28.x
GNOME version: ---

Description Marius M. M. 2007-10-31 13:06:44 UTC
I'm working in a local area network containing a jabber-daemon and a squid web-proxy. For being able to access the internet over 80 and 443 I need to connect through that web-proxy, so I configured my GNOME Network Preferences to use the Squid. Unfortunatelly Empathy then automatically also tries to use that web-proxy for connecting to the given accounts. Of course, for connecting to my GoogleTalk account over 443 this is okay, but when I'm trying to connect to my internal jabber-daemon it doesn't work. It would be nice to have a per-account option for defining which proxy to use (similar to Pidgin/GAIM).
Comment 1 Xavier Claessens 2007-10-31 13:13:23 UTC
I think proxy is configured automagically by MissionControl using GNOME preferences. I think MC shouldn't do that and let Empathy decide which proxy to use by asking to the user eventually.

I confirm this bug, but parts of the fix should go to MC.
Comment 2 Guillaume Desmottes 2008-04-09 10:42:56 UTC
Is that solved by new MC Account spec?

If not, we should file a bug to MC.
Comment 3 Xavier Claessens 2008-04-09 11:37:47 UTC
Then new MC spec does not speak about proxies, so MC implementations shouldn't set proxy settings.
Comment 4 Paul Ezvan 2008-05-01 12:15:03 UTC
I have the same problem. I have set a proxy only for http and ftp protocols, so I think telepathy should not use these settings because they don't concern xmpp or others im protocols.
Comment 5 Xavier Claessens 2008-05-21 10:10:05 UTC
*** Bug 533168 has been marked as a duplicate of this bug. ***
Comment 6 Maxime Chéramy 2008-05-21 11:47:49 UTC
+1 Paul, telepathy must not use http or ftp setting. For example :
You're in a network which provides you an access to the http(s) and ftp through a proxy and a direct connexion to jabber using the gateway.
You can't ask to telepathy to use the HTTP proxy for a XMPP connection, it's nonsens!
Comment 7 Felipe Contreras (banned) 2008-07-18 13:23:11 UTC
I don't care in which layer, how do I connect to an XMPP connection through https(443) by an http proxy?

I have set the proxy in the GNOME preference to be used for all the protocols and Empathy still doesn't connect.
Comment 8 Felipe Contreras (banned) 2008-08-25 12:21:34 UTC
The severity and priority should be raised, as this makes Empathy not useful at all in proxied environments.
Comment 9 Maxime Chéramy 2008-11-19 22:30:12 UTC
I've make other tests :

I have a gtalk account and an internal account.

- No proxy :
My internal account works fine.
GTalk obviously can't connect.

- Proxy correctly configured (hosts to ignore specified) :
Gtalk is connecting after a long delay (1mn?)
My internal account is connecting after the same delay ! (timeout delay?)

So, I think there is 2 problems :
- When using a proxy, there is a long delay before the connection.
- When using a proxy, the ignored hosts are not...
Comment 10 Felipe Contreras (banned) 2009-03-03 13:17:47 UTC
Actually now it seems to work better.

I also have an internal and GTalk account, the internal works fine when there's no proxy configured and the external works when the proxy is configured.

So in order to connect to both accounts I need to login to GTalk, disable the proxy, connect to the internal one, and re-enable the proxy.

I tried to add the host in the 'ignored' list, but that didn't help.
Comment 11 Maxime Chéramy 2009-05-16 11:43:23 UTC
Any news ?

I'm using Empathy 2.26.1 and I have exactly the same problem as Felipe.

I disable my proxy settings to connect to my internal Jabber account and then I reable them to connect to my external accounts...
Comment 12 Felipe Contreras (banned) 2009-06-15 22:31:43 UTC
Strike my previous comment.

I am using Fedora 11 now and it doesn't work any more. I doesn't matter which sequence of steps I try.
Comment 13 Dave Hayes 2009-06-16 18:00:47 UTC
I ran into this bug today too. I use an SSH tunnel as a SOCKS proxy to connect to all my IM services, and it seems that only some protocols respect the Gnome proxy settings. 

In my experience today, AIM, ICQ and Yahoo! connect without issue whereas MSN, GTalk and IRC do not.

I have *only* set the SOCKS proxy in the Gnome Network Proxy Preferences and left the HTTP(s) and FTP proxies blank. 
Comment 14 Nathaniel McCallum 2009-06-19 15:32:05 UTC
I just want to point out that libproxy can help with the implementation details and it is already an approved GNOME external dep.

See for more details.  Also, we are rapidly approaching a 0.3.0 release, so make sure you look at trunk.
Comment 15 André Klapper 2009-06-20 13:09:09 UTC
Adding the blocker milestone as this seems to bite quite a few people.
Comment 16 Roland Dreier 2009-06-24 04:31:38 UTC
Just want to amplify the use case mentioned in case #10: it should be possible to set proxies by account.  In my case I would like to use empathy both to access a jabber server that I can reach directly, and also a corporate IM server (in my case a lotus sametime server via the telepathy-haze/libpurple support) that I can only reach via a SOCKS proxy.  So ideally I should be able to set my jabber account to use no proxy (which is what my GNOME preferences would say, since I can reach nearly everything with no proxy) and my sametime account to use a SOCKS proxy (since I need that for the one specific sametime server).
Comment 17 Xavier Claessens 2009-08-25 17:31:02 UTC
We discussed this at guadec, and we agreed that libproxy must be used at the ConnectionManager level.
Comment 18 Xavier Claessens 2009-08-25 17:32:07 UTC
Resolving as NOTGNOME since CM are fd.o projects.
Comment 19 Sam Illingworth 2009-11-11 15:38:56 UTC
Can someone tell me if the problem I'm seeing is caused by this same issue:

I don't have any proxy set up in Gnome, it all happens invisibly somewhere on the corporate network.  I cannot connect to my MSN account using Empathy over the corporate LAN. I can connect using Pidgin, and I can connect with Empathy over my home connection.

I'm using Ubuntu 9.10.