After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 406672 - installation in different prefix still opens old gnome-sudoku
installation in different prefix still opens old gnome-sudoku
Product: gnome-games-superseded
Classification: Deprecated
Component: gnome-sudoku
Other Linux
: Normal minor
: gnome-2-22
Assigned To: GNOME Games maintainers
GNOME Games maintainers
: 416700 (view as bug list)
Depends on:
Reported: 2007-02-11 12:38 UTC by Nickolay V. Shmyrev
Modified: 2008-01-12 13:54 UTC
See Also:
GNOME target: ---
GNOME version: ---

Reorder to load from prefix before system wide (2.47 KB, patch)
2008-01-12 04:49 UTC, Thomas Andersen
committed Details | Review

Description Nickolay V. Shmyrev 2007-02-11 12:38:27 UTC
If gnome-sudoku is installed into some prefix, say /home/user/local it will still load old gnome-sudoku first:

    from gnome_sudoku.gnome_sudoku import start_game                           
except ImportError:                                                            
    import sys                                                                      
    if "/home/shmyrev/t/lib/python2.5/site-packages" not in sys.path:               
        sys.path.insert(0, "/home/shmyrev/t/lib/python2.5/site-packages")             
    from gnome_sudoku.gnome_sudoku import start_game
Comment 1 Nickolay V. Shmyrev 2007-02-11 14:03:21 UTC
The same trouble for glchess
Comment 2 Andreas Røsdal 2007-02-15 17:00:44 UTC
If you uninstall the old gnome-sudoku, and reinstall the latest gnome-games, do you have any problems then?  I don't see how this could be solved in another way at the moment.
Comment 3 Nickolay V. Shmyrev 2007-02-15 17:30:54 UTC
No, it's not a question of my installation, it's just a problem of your load script. Do not load system wide packages first, reorder those two calls. First of all try to load packages from prefix and only then system-wide packages.
Comment 4 Nickolay V. Shmyrev 2007-02-16 00:17:37 UTC
Look into deskbar applet:

it does things correctly
Comment 5 Andreas Røsdal 2007-02-27 17:10:27 UTC
Setting target to gnome 2.20.
Comment 6 Andreas Røsdal 2007-03-10 06:26:31 UTC
*** Bug 416700 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Andersen 2008-01-12 04:49:44 UTC
Created attachment 102642 [details] [review]
Reorder to load from prefix before system wide

I committed the attached patch to make gnome-sudoku try to load from the prefix before looking system wide.
Comment 8 Andreas Røsdal 2008-01-12 09:03:25 UTC
Thomas, could you please commit the same patch to glChess?
The two Python games should always have identical startup-code.
Comment 9 Andreas Røsdal 2008-01-12 10:19:00 UTC
Fixed in glChess also now.
Comment 10 Thomas Andersen 2008-01-12 13:54:39 UTC
Yeah, I planned to, but it was really late and glchess wouldn't build for me so I decided to postpone that till today. But I see you fixed it already. Nice :)