After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 347887 - gnome-obex-server 0.70 problems
gnome-obex-server 0.70 problems
Product: gnome-bluetooth
Classification: Core
Component: general
Other All
: Normal critical
: ---
Assigned To: gnome-bluetooth-general-maint@gnome.bugs
Depends on:
Reported: 2006-07-18 09:28 UTC by James Allsopp
Modified: 2009-02-25 14:39 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description James Allsopp 2006-07-18 09:28:23 UTC
Steps to reproduce:
1. In Gentoo (up to date) using gnome 2.14 with gnome-bluetooth-0.7.0
2. run gnome-obex-server

Stack trace:
Hawaiian ja # gnome-obex-server -v

(gnome-obex-server:10360): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

** (gnome-obex-server:10360): WARNING **: OBEX server register error: -94

** (gnome-obex-server:10360): WARNING **: Unable to initialize OBEX source

** (gnome-obex-server:10360): WARNING **: Couldn't initialise OBEX listener 

Other information:
Comment 1 James Allsopp 2006-07-18 09:29:48 UTC
I've managed to pair the phone and I can ping it fine and get no errors starting the bluetooth stack. Sorry about that.
Comment 2 James Allsopp 2006-07-18 11:45:30 UTC
Whole system worked fine upon downgrade to 0.6.0. To be more specific, the version I was using before was 0.7.0-r1. 
Comment 3 Aredridel 2006-08-21 21:57:46 UTC
I'm having the same problem, minus the session manager authentication:

** (gnome-obex-server:23564): WARNING **: OBEX server register error: -94

** (gnome-obex-server:23564): WARNING **: Unable to initialize OBEX source

** (gnome-obex-server:23564): WARNING **: Couldn't initialise OBEX listener

Comment 4 Bastien Nocera 2006-08-22 22:20:29 UTC
Could you please attach the output of "sdptool browse local" on your systems?
Could you also list the exact versions of gnome-bluetooth, libbtctl and openobex used in both the running and non-running cases?
Comment 5 Bastien Nocera 2006-08-22 22:38:12 UTC
Never mind, -94 is -ESOCKTNOSUPPORT. In openobex/lib/obex.c's BtOBEX_ServerRegister:

        if(src == NULL)
                src = BDADDR_ANY;
        btobex_prepare_listen(self, src, channel);
        return obex_transport_listen(self);
        return -ESOCKTNOSUPPORT;
#endif /* HAVE_BLUETOOTH */

Your openobex was compiled without bluetooth support. Using gentoo?
Comment 6 Aredridel 2006-08-23 00:33:40 UTC
PLD. I'll get on that. (I'm one of the maintainers.)
Comment 7 James Allsopp 2006-08-23 10:35:38 UTC
Yeah, sounds like you need to include the bluetooth option to get it to work, I presume in /etc/make.conf. Still it seems strange that the earlier versions work fine.
Comment 8 James Allsopp 2006-11-08 13:54:29 UTC
I've tried this now (adding bluetooth) and it doesn't work, I'm using the 0.6 version of libbtctl and gnome-bluetooth-0.7-r1 on a2.16 gnome system.

Best regards
Comment 9 Bastien Nocera 2006-11-08 14:45:42 UTC
If it's still the same error you have, then it's still not compiled with Bluetooth enabled. If it's a different one, then it's a different bug. Please attach the output of gnome-obex-server to a new bug.