After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 341078 - RB does not play beyond initially downloaded podcast file
RB does not play beyond initially downloaded podcast file
Product: GStreamer
Classification: Platform
Component: gst-plugins-base
Other All
: Normal minor
: 0.10.13
Assigned To: Wim Taymans
RhythmBox Maintainers
: 370871 (view as bug list)
Depends on:
Reported: 2006-05-08 20:38 UTC by Dejan Čabrilo
Modified: 2007-03-22 09:27 UTC
See Also:
GNOME target: ---
GNOME version: ---

possible patch (4.33 KB, patch)
2007-03-05 17:11 UTC, Wim Taymans
committed Details | Review

Description Dejan Čabrilo 2006-05-08 20:38:10 UTC
Please describe the problem:
When I start downloading a podcast file, I can start playing it while it has
still not been downloaded in entirety. However, rhythmbox stops playing the file
at the last downloaded point at the time when playing started.

Steps to reproduce:
1. Double click a podcast episode, so it start's downloading.
2. Wait for it to be completed, say, 20%.
3. Double click again, let it play.

Actual results:
It will play up to 20%, even though the entire file might have been downloaded
by the time 20% was reached.

Expected results:
I expect it to continue playing the entire file, even though it was not
downloaded right away.

Does this happen every time?

Other information:
This might be a feature/bug confusion, but for people with slower internet
connection really eager to start listening to podcast episode, it's rather
important to work :)
Comment 1 Hidde Brugmans 2006-05-09 15:10:56 UTC

even worse, it ups the playcount even though play was aborted halfway through actually playing the file.
Comment 2 Stanislaw Pitucha 2006-10-27 22:05:39 UTC
+1 from me and I wanna be in CC.
I'd say it's a bug.
Comment 3 Jonathan Matthew 2006-11-05 05:16:13 UTC
This works correctly for local mp3 files (so, virtually all podcasts) with gstreamer 0.10.10 and later, as the rank for filesrc changed to be higher than that of gnomevfssrc.  gnomevfssrc doesn't deal with changing file sizes (bug 370871), but filesrc does.  It doesn't work for ogg files because oggdemux doesn't seem to be clairvoyant enough.  I haven't tried any other file types.
Comment 4 Wim Taymans 2007-03-05 17:11:55 UTC
Created attachment 83979 [details] [review]
possible patch
Comment 5 Wim Taymans 2007-03-06 09:01:03 UTC
*** Bug 370871 has been marked as a duplicate of this bug. ***
Comment 6 Wim Taymans 2007-03-22 09:27:06 UTC
        * ext/gnomevfs/gstgnomevfssrc.c: (gst_gnome_vfs_src_get_size),
        (gst_gnome_vfs_src_start), (gst_gnome_vfs_src_stop):
        * ext/gnomevfs/gstgnomevfssrc.h:
        Don't cache file sizes. Fixes #341078.