After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 330560 - Crash on startup: no code for module (g-wrap gw standard)
Crash on startup: no code for module (g-wrap gw standard)
Product: GnuCash
Classification: Other
Component: General
Other All
: Normal critical
: ---
Assigned To: Neil Williams
Chris Lyttle
: 333660 340359 344890 (view as bug list)
Depends on:
Reported: 2006-02-09 19:40 UTC by Adam Buchbinder
Modified: 2018-07-02 07:19 UTC
See Also:
GNOME target: ---
GNOME version: ---

Results of 'make check'. (20.61 KB, text/plain)
2006-02-09 19:44 UTC, Adam Buchbinder

Description Adam Buchbinder 2006-02-09 19:40:20 UTC
Steps to reproduce:
1. Build GnuCash locally.
2. Install to /usr/local.
3. Run /usr/local/bin/gnucash.

Stack trace:
$ /usr/local/bin/gnucash --debug
<unnamed port>: In procedure scm-error in expression (scm-error (quote
misc-error) #f ...):
<unnamed port>: no code for module (g-wrap gw standard)

Other information:
The application crashes with no other information, no stack trace or anything.
The splash screen pops up, then another dialog box which doesn't finish drawing
before the application quits.

I also have gnucash 1.8.10-18 installed on this machine, from the package. I
don't know what precisely the new version depends on, but here's a system
information report detailing versions of packages relevant to the 1.8 install.

-- System Information:
Debian Release: testing/unstable
  APT prefers breezy-updates
  APT policy: (500, 'breezy-updates'), (500, 'breezy-security'), (500,
'breezy-backports'), (500, 'breezy')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-10-386
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages gnucash depends on:
ii  bonobo            1.0.22-2.3build1       The GNOME Bonobo System.
ii  gdk-imlib1        1.9.14-16.2ubuntu4     imaging library for use with gtk (
ii  gnucash-common    1.8.10-18              A personal finance tracking progra
ii  guile-1.6-libs    1.6.7-1ubuntu3         Main Guile libraries
ii  guile-1.6-slib    1.6.7-1ubuntu3         Guile SLIB support
ii  libart2           1.4.2-20               The GNOME canvas widget - runtime
ii  libaudiofile0     0.2.6-6                Open-source version of SGI's audio
ii  libbonobo2        1.0.22-2.3build1       The GNOME Bonobo library.
ii  libc6             2.3.5-1ubuntu12        GNU C Library: Shared libraries an
ii  libdate-manip-per 5.44-1build1           a perl library for manipulating da
ii  libdb3            3.2.9-22ubuntu1        Berkeley v3 Database Libraries [ru
ii  libesd-alsa0 [lib 0.2.36-1ubuntu5        Enlightened Sound Daemon (ALSA) -
ii  libfinance-quote- 1.08-1                 Perl module for retrieving stock q
ii  libfreetype6      2.1.7-2.4ubuntu1       FreeType 2 font engine, shared lib
ii  libgal23          0.24-1.4ubuntu1        G App Libs (run time library)
ii  libgconf11        1.0.9-7ubuntu1         GNOME configuration database syste
ii  libgdk-pixbuf-gno 0.22.0-8ubuntu0.1      The GNOME1 Canvas pixbuf library
ii  libgdk-pixbuf2    0.22.0-8ubuntu0.1      The GdkPixBuf image library, gtk+
ii  libghttp1         1.0.9-15               original GNOME HTTP client library
ii  libglade-gnome0   1:0.17-3               Library to load .glade files at ru
ii  libglade0         1:0.17-3               Library to load .glade files at ru
ii  libglib1.2        1.2.10-10ubuntu1       The GLib library of C routines
ii  libgnome32        1.4.2-20               The GNOME libraries
ii  libgnomeprint15   0.37-5                 The GNOME Print architecture - run
ii  libgnomesupport0  1.4.2-20               The GNOME libraries (Support libra
ii  libgnomeui32      1.4.2-20               The GNOME libraries (User Interfac
ii  libgtk1.2         1.2.10-17build1        The GIMP Toolkit set of widgets fo
ii  libgtkhtml1.1-3   1.1.10-4ubuntu1        HTML rendering/editing library - r
ii  libguile-ltdl-1   1.6.7-1ubuntu3         Guile's patched version of libtool
ii  libguppi16        0.40.3-10ubuntu2       GNOME graph and plot component
ii  libgwrapguile1    1.3.4-14               g-wrap: Tool for exporting C libra
ii  libice6           1:6.3.5-4              X11 Inter-Client Exchange library
ii  libltdl3          1.5.6-6                A system independent dlopen wrappe
ii  liboaf0           0.6.10-3               The GNOME Object Activation Framew
ii  libofx2           1:0.8.0-3ubuntu8       library to support Open Financial
ii  liborbit0         0.5.17-11.1            Libraries for ORBit - a CORBA ORB
ii  libpopt0          1.7-5                  lib for parsing cmdline parameters
ii  libqthreads-12    1.6.7-1ubuntu3         QuickThreads library for Guile
ii  libsm6            1:6.0.4-4              X11 Session Management library
ii  libstdc++6        4.0.1-4ubuntu9         The GNU Standard C++ Library v3
ii  libx11-6          1:6.2.1+cvs.20050722-8 X11 client-side library
ii  libxext6          1:6.4.3-3              X11 miscellaneous extension librar
ii  libxi6            1:1.3.0-2              X11 Input extension library
ii  libxml1           1:1.8.17-10            GNOME XML library
ii  libzvt2           1.4.2-20               The GNOME zvt (zterm) widget
ii  oaf               0.6.10-3               The GNOME Object Activation Framew
ii  psfontmgr         0.11.8ubuntu2          PostScript font manager -- part of
ii  slib              3a1-4.2                Portable Scheme library
ii  x-ttcidfont-conf  17ubuntu3              Configure TrueType and CID fonts f
ii  zlib1g            1:1.2.3-3ubuntu4       compression library - runtime

I also have g-wrap 1.9.6-2ubuntu2 installed; I know that gnucash 1.9 depends on
Comment 1 Adam Buchbinder 2006-02-09 19:44:49 UTC
Created attachment 59017 [details]
Results of 'make check'.

Upon further investigation, 'make check' fails 7 of 12 tests. Here is the result of:

abuchbinder@abuchbinder:~/software/gnucash-1.9.0$ make check > makecheck.log 2>&1
Comment 2 rstutsma 2006-02-10 03:32:51 UTC
I can confirm this on Debian Unstable.  Identical behavior for both the debug output and the make check.
Comment 3 Christian Stimming 2006-02-10 09:22:13 UTC
You said you have "g-wrap 1.9.6-2ubuntu2", but also "libgwrapguile1    1.3.4-14"? That sounds like conflicting packages. Can you remove the older libgwrapguile1, so that there is only a 1.9.x g-wrap available? The "make check" failures are obviously the same error message as the gnucash startup error. Please report back what happened after you removed the older gwrap package.

Also, on the gnucash-devel list in December/January there have been reported some issues with slib on Debian, but I don't know if these apply here. 
Comment 4 Adam Buchbinder 2006-02-10 11:28:52 UTC
Okay, libgwrapguile1 was required for my gnucash-1.8. I uninstalled both, and ran the gnucash-1.9 I had built earlier. I see a "Cannot find default values" dialog. If I hit 'Skip', I get the same crash message. If I hit 'Setup', I get a wizard to update my gconf settings, which I do. (I think it's a result of removing the old gnucash from my system.) After that, I get the same crash I had before, with the same briefly-appearing splash window. 'make check' still gets 7 of 12 failures.

I did 'make uninstall' from the source directory. I'm going to 'make clean', re-'./configure', rebuild and reinstall. I'll let you know if that makes any difference, but removing libgwrapguile1 doesn't seem to have done anything.
Comment 5 Adam Buchbinder 2006-02-10 11:44:57 UTC
I don't think it's the slib problem from before; I could run gnucash-1.8 (1.8.10-18 was the version I was using) without any trouble. And in any case, the slib problem would have shown up as "unbound variable", according to the Debian bug report (#348018).
Comment 6 Christian Stimming 2006-02-10 12:56:20 UTC
I'm sorry to hear that gwrapguile1 didn't change anything.

There is a similar error report on gnucash-user:
and that whole thread. Maybe the g-wrap 1.9.6-2 vs. 1.9.6-3 is the important difference?

BTW "make uninstall" might not be sufficient, as this won't remove some old library versions that might still exist from previous unstable gnucash versions.
Comment 7 Derek Atkins 2006-02-10 13:50:21 UTC
For the record, g-wrap 1.9.6 was designed to co-exist with g-wrap 1.3.4, so you CAN have the runtimes at the same time (although you can only have one of the development-sets installed).

Is this the slib 3a2 problem?
Comment 8 Derek Atkins 2006-02-10 14:13:53 UTC
I notice there's also a dependency on guppi -- that seems VERY weird as guppi is a gtk1 package.  It's almost as if you have two builds on top of each other or something, because your dependency package list is VERY weird.
Comment 9 Adam Buchbinder 2006-02-11 00:10:14 UTC
Removing libgwrapguile1 had no effect on the results of 'make check' or the crash of the resultant executable. I've changed from {g-wrap,libgwrap-runtime0{,-dev}}-1.9.6-2ubuntu2 to 1.9.6-3 from the Debian distribution. I'm currently doing a 'make distclean && ./configure && make && make install'; I will relay to you the results of the changes.

Derek: the above dependency list was for the gnucash-1.8.10-18 package that came with my copy of Ubuntu. I figured that it would tell you the versions of some important packages, as gnucash-1.9 is not being managed through my package manager at this point, and I couldn't do the same for it. Hence the presence of 'guppi' on the list.
Comment 10 Derek Atkins 2006-02-11 00:15:48 UTC
Unfortunately 1.9.0 is a gtk2 app, so the whole set of dependencies has changed.

I'm not surprised that removing libgwrapguile1 had no effect -- the 1.9.6 runtime was designed to happily coexist with 1.3.4.  Only the development packages conflict with each other.
Comment 11 Adam Buchbinder 2006-02-11 01:08:02 UTC
Upgrading to g-wrap (and associated packages) 1.9.6-3 made no difference; I still fail 7 of 12 tests in 'make check', and the installed copy crashes with the same terse error.
Comment 12 Derek Atkins 2006-02-11 01:22:39 UTC
By any chance do you have another copy of g-wrap installed in /usr/local?  Or do you a copy of GnuCash installed in /usr/local?  (or ANYTHING in /usr/local)?

One of the devs uses Debian, so it certainly works.  It's just a question of what's going on in your environment.
Comment 13 Neil Williams 2006-02-11 10:38:16 UTC
1. Whenever any of the g-wrap/guile libraries change, it is important to clean the gnucash tree using make distclean - make clean is insufficient. make uninstall may also fail at times with svn, it's best to completely remove the installation directory with rm -rf /<your prefix>/. Simply re-running make or make check after changing a g-wrap/guile dependency does NOT update the generated g-wrap code and therefore carries the problem into the next test - giving you the false impression that the change achieved nothing.

Do 'make distclean' and rebuild before you change any other libraries.

2. slib may need to be upgraded. I'm now running 3a2-5 - avoid 3a2-4.

Debian unstable users should upgrade slib, run make distclean in the gnucash tree, remove the installation directory (rm -rf /usr/local/gnucash/), rebuild the gnucash tree from scratch, re-run make check.

make check completes fully on Debian unstable when the correct dependencies are sorted out.

slib 3a2-5 is available in Ubuntu Universe for Dapper, not breezy.
This is similar to Debian where testing only has 3a1-4.2.

AFAICT, this isn't a bug in gnucash, except that ./configure might need to halt if it finds g-wrap 1.3 with gcc4 and a README should contain notes about make distclean.

Please run 'make distclean', rebuild and run 'make check' before trying to run the installed program. 
Comment 14 Derek Atkins 2006-02-11 13:55:14 UTC
I must admit that I've never seen "make uninstall" fail, Neil.  Except from SVN where files move around, change names, or get removed from the source tree, under what circumstances does make uninstall fail?

Also, the g-wrap generation /should/ happen any time configure is re-run, but I admit that that code probably doesn't work right in all cases.  I forgot about that.
Comment 15 Neil Williams 2006-02-11 15:32:26 UTC
Yes, regarding 'make uninstall' failures I was referring to svn, I did mention that above but didn't qualify the statement in the summary.
Comment 16 Derek Atkins 2006-02-11 20:16:10 UTC
Here's a question:  Do you have the "guile-g-wrap" package installed?  If not, does installing that make gnucash work?
Comment 17 Adam Buchbinder 2006-02-12 13:18:11 UTC
I had the following installed:

guile-1.6-libs   1.6.7-1ubuntu3
slib             3a1-4.2
libreadline5     5.0-10
libreadline4     4.3-15

To see if this was the slib-3a2-5 issue, I upgraded to:

guile-1.6-libs   1.6.7-2
slib             3a2-5
libreadline5     5.1-5
libreadline4     4.3-18
readline-common  5.1-5

Then I ran 'make distclean && ./configure && make && make check'. No change. This is not the slib-3a2-5 issue.

I next installed guile-g-wrap 1.9.6-2ubuntu2, which was not previously installed. I ran 'make distclean && ./configure && make && make check', and hurrah! make check successfully completed. I ran 'sudo make install', and gnucash now runs.

Thanks for helping me out!
Comment 18 Christian Stimming 2006-03-07 09:29:16 UTC
*** Bug 333660 has been marked as a duplicate of this bug. ***
Comment 19 Derek Atkins 2006-05-11 03:41:24 UTC
*** Bug 340359 has been marked as a duplicate of this bug. ***
Comment 20 Christian Stimming 2006-06-15 12:11:42 UTC
*** Bug 344890 has been marked as a duplicate of this bug. ***
Comment 21 John Ralls 2018-06-29 20:57:01 UTC
GnuCash bug tracking has moved to a new Bugzilla host. This bug has been copied to Please update any external references or bookmarks.