After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 322033 - ATK tarball has no list of deprecated functions.
ATK tarball has no list of deprecated functions.
Status: RESOLVED DUPLICATE of bug 313183
Product: atk
Classification: Platform
Component: docs
git master
Other All
: Low minor
: ---
Assigned To: bill.haneman
Depends on:
Reported: 2005-11-21 14:15 UTC by Murray Cumming
Modified: 2006-06-28 14:44 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Murray Cumming 2005-11-21 14:15:25 UTC
GTK+ uses gtk-doc to mark deprecated functions, like so:

ATK+ doesn't seem to do this:

It would be nice if it did.

See also about the "since" tag.
Comment 1 bill.haneman 2005-11-23 17:34:49 UTC
SO far there aren't any deprecated functions in ATK.
Comment 3 bill.haneman 2005-11-25 11:57:36 UTC
Yes, very wrong.  Where did that list come from?
Comment 4 bill.haneman 2005-11-25 12:19:43 UTC
Murray - I have edited that Wiki page.  I'll have a root around to see if I've
forgotten any deprecations.
Comment 5 Murray Cumming 2005-11-25 12:45:48 UTC
> Where did that list come from?

Brian Cameron, I think.
Comment 6 bill.haneman 2005-11-25 19:39:52 UTC
Brian's right, I just mis-read the wiki doc.  I didn't even know those symbols
had ever existed!  However, they are marked as deprecated (already) in gtk-doc.

I guess this RFE is for a "list of deprecated symbols", I am cluing in now.  I
have, however, no idea how to do this, since we're already using the
'deprecated' tag.
Comment 7 bill.haneman 2005-11-25 19:41:13 UTC
reopening as RFE, since there doesn't appear to be a list autogenerated from the
'deprecated' gtk-doc tags.   Can anyone point me to a doc on how to do that?
Comment 8 Murray Cumming 2006-02-09 19:16:14 UTC
Overheard in irc:

<tko> I'm trying to build API docs for maemo modified gtk+ and on the surface the docs get built, but on closer look I can see at least deprecated symbols and lists of new symbols being missing from the table of contents
<tko> can't help but I just have this feeling no one really knows how to use gtk-doc, everyone just copypastes something that seems to work
<mclasen> tko: you need to add suitable <index/> elemnts to your main document
<tko> mclasen, I have whatever was in 2.6.10 but even those disappear
<mclasen> tko: see gtk-docs.sgml for an example
<tko> any specific gtk-doc version that's required?
<mclasen> tko: could be that your docbook style sheets are old
<mclasen> tko: the multi-index support that was added as some point was a patch by me to get gtk-doc support for multiple indices
<tko> hmm.. I have gtk-doc-tools 1.3 and docbook-xml 2.0.3 from debian.. ring a bell? :-]
Comment 9 Tommi Komulainen 2006-02-16 20:32:14 UTC
Ok, with the following it worked for me:
gtk-doc-tools 1.4
docbook-xml 4.3
docbook-xsl 1.68.1       <-- this was important, 1.64 was too old

And then the <index role="deprecated"> ... </index> works

If you use both @deprecated and Since: tags, such as:
 * Since: egg 2.2
 * @Deprecated: use foo instead

only index like <index role="deprecated egg 2.2">...</index> will collect the symbol (role="deprecated" and role="egg 2.2" both will fail to include it)
Comment 10 bill.haneman 2006-03-20 15:08:43 UTC
OK, so this is some kind of tools issue with creating tarballs, not a problem with the cvs ATK sources.
Comment 11 bill.haneman 2006-03-20 15:48:20 UTC
I've got docbook-xml 4.4, docbook-xsl 1.69.1, gtk-doc from HEAD... and it still doesn't work.
Comment 12 bill.haneman 2006-06-28 14:44:24 UTC
See bug 313183, this was the same issue, only a different tag.  Fixed in CVS, will be fixed in the next ATK tarball.

*** This bug has been marked as a duplicate of 313183 ***