After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 317310 - Cant play swedish radio station "P3"
Cant play swedish radio station "P3"
Product: GStreamer
Classification: Platform
Component: gst-plugins-ugly
git master
Other All
: Normal normal
: 0.10.3
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Blocks: 138435
Reported: 2005-09-27 07:00 UTC by Mattias Eriksson
Modified: 2006-03-27 10:42 UTC
See Also:
GNOME target: ---
GNOME version: 2.11/2.12

Description Mattias Eriksson 2005-09-27 07:00:39 UTC
Please describe the problem:
I have tried to open the stream in both rhythmbox and in totem with no luck. I
have tried to feed them with different stages of the flow below, but still no
success. This have made me believe that the problem lies in the gstreamer framework.

The swedish radio channel P3 is available at:

This gives you a asx file containing the folowing streams:
<ASX version="3.0">
        <ref HREF= "rtsp://"/>
        <ref HREF= "mms://"/>
        <ref HREF= ""/>

And the http and mms url gives you:

Steps to reproduce:

Actual results:

Expected results:

Does this happen every time?

Other information:
Comment 1 Edward Hervey 2005-11-21 17:54:09 UTC
Updating bug to 0.9. Blocks playback tracker.
Since asfdemux isn't ported yet, this is a real problem.
Comment 2 Bastien Nocera 2006-03-24 17:01:12 UTC
$ ./test-parser ""

###################### parsing ################

added URI 'mmsh://' with title 'empty' genre '(null)'

And launching that URL in Totem with the xine backend:
libmmsh: http status not 2xx: >503 Service Unavailable<
xine: input plugin cannot open MRL [mmsh://]

No wonder it doesn't work.
Comment 3 Christian Fredrik Kalager Schaller 2006-03-24 17:04:46 UTC
ok, thanks Bastien. Taking a look at the SR website it seems they are using Real media now. So closing this bug as invalid.
Comment 4 Christian Fredrik Kalager Schaller 2006-03-24 17:08:42 UTC
Ok, I was a little quick in closing this:

The following URL have direct links to their streams:

This plays well with the Fluendo windows Media plugins and the opensource MMS plugin. But with the opensource asfdemux/ffmpeg it doesn't play. Tim do you want to take a look?
Comment 5 Tim-Philipp Müller 2006-03-27 10:42:22 UTC
This is fixed in CVS now:

 2006-03-27  Tim-Philipp Müller  <tim at centricular dot net>

        Patch by: Fabrizio Gennari  <fabrizio dot ge at tiscali dot it>

        * gst/asfdemux/gstasfdemux.c: (gst_asf_demux_setup_pad),
        * gst/asfdemux/gstasfdemux.h:
          Subtract first timestamp from timestamps, so that
          stream starts from 0; makes live streams that don't
          start at 0 work again (fixes #317310, #336097).