After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 169772 - [PATCH] GOption command-line parsing
[PATCH] GOption command-line parsing
Product: GStreamer
Classification: Platform
Component: gstreamer (core)
Other Linux
: High enhancement
: 0.9.4
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Blocks: 160807
Reported: 2005-03-09 21:12 UTC by Bastien Nocera
Modified: 2005-10-10 15:58 UTC
See Also:
GNOME target: ---
GNOME version: ---

patch implementing that (10.13 KB, patch)
2005-03-10 16:54 UTC, Ronald Bultje
none Details | Review
0.9 version, also removes popt alltogether (38.03 KB, patch)
2005-06-24 10:05 UTC, Ronald Bultje
committed Details | Review

Description Bastien Nocera 2005-03-09 21:12:09 UTC
The API seems to only allow for popt to be used right now. GOption support would
help i18n, and portability.
Comment 1 Ronald Bultje 2005-03-10 16:54:03 UTC
Created attachment 38515 [details] [review]
patch implementing that

This patch implements gst_init_get_option_group, which is in name similar to
_get_popt_table(). It can be used in combination with gtk_get_option_group()
and all the like. With this, we could even obsolete all popt functions already.

That said, some people have proposed to remove all commandlineoptions in 0.9
alltogether. I don't have a strong preference of what will happen in 0.9 w.r.t.
commandline parsing, but it has to be said that Gtk+ does use GOption, so it
would make sense to follow their trend.
Comment 2 Ronald Bultje 2005-03-10 17:33:40 UTC
Oh, obviously, the above patch doesn't make gst_init() use GOption yet (it still
picks the popt one). It'd be nice to do that, too.
Comment 3 Benjamin Otte (Company) 2005-03-10 19:06:43 UTC
GStreamer depends on glib 2.2.
So I guess it's kinda impossible to add that.
Comment 4 Ronald Bultje 2005-06-24 10:05:17 UTC
Created attachment 48270 [details] [review]
0.9 version, also removes popt alltogether
Comment 5 Andy Wingo 2005-10-06 15:11:43 UTC
For great justice, we should look at this patch.
Comment 6 Tim-Philipp Müller 2005-10-06 16:15:28 UTC
This is only really an option (no pun intended) if we decide to bump the GLib
requirement to 2.6. Not sure what the result of the discussion on the mailing
list was, but it looked to me like we're gonna stick to 2.4 for now.
Comment 7 David Schleef 2005-10-06 18:09:25 UTC
My rule, which seemed to have some traction, is "Packages we depend on should
exist in the latest stable release of both Fedora and Ubuntu."  This includes
glib-2.6, but excludes 2.8 for a few more months.  Of course, we don't have to
gratuitously use the latest glib, but I think GOption warrants it.
Comment 8 Ronald Bultje 2005-10-06 20:07:39 UTC
I asked for votes, and we got three votes out of five maintainers:
1) require 2.8 now
2) require 2.4 forever
3) what dave said

I'll go with dave's vote (I'm (1) right now), which means (3) is decided. We'll
depend on 2.8 when Breezy/FC5 are released.
Comment 9 Andy Wingo 2005-10-10 15:58:02 UTC
Applied to HEAD. Good riddance popt!