After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 160665 - [ffdec_h264] VideoSoft h.264 videos (VSSH) make totem/ffdec_h264 segfault
[ffdec_h264] VideoSoft h.264 videos (VSSH) make totem/ffdec_h264 segfault
Product: GStreamer
Classification: Platform
Component: gst-libav
git master
Other All
: Normal normal
: 0.8.6
Assigned To: Stephane Loeuillet
GStreamer Maintainers
Depends on:
Blocks: 138435
Reported: 2004-12-07 07:31 UTC by Steve Baker
Modified: 2005-07-20 15:42 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Steve Baker 2004-12-07 07:31:28 UTC
Download sample files from

The first problem is that avidemux doesn't seem to like parsing these files:
gst-launch filesrc location=tempete-cif-best-350.avi ! avidemux ! fakesink 
RUNNING pipeline ...
Execution ended after 2 iterations (sum 25218000 ns, average 12609000 ns, min
170000 ns, max 25048000 ns).

The next challange is that the ffdec_h264 element expects mime-type video/x-h264
for which there seems to be no typefind function.

Here is some background on H.264:
Comment 1 Stephane Loeuillet 2004-12-13 11:38:08 UTC
this h264 avi file has the following 4CC : VSSH

mplayer gave me a black screen trying to play vssh-ccir39_d1_3000.avi (using a
dll). same thing with news-qcif-best-10.avi

i can try to add VSSH => video/x-h264 to riff/avidemux, but as mplayer can't
play it, i have little hope with gst-ffmpeg (ffdec_h264)
Comment 2 Stephane Loeuillet 2004-12-13 18:28:59 UTC
i added VSSH => video/x-h324 to riff-lib/avidemux

vssh-ccir39_d1_3000.avi : totem segfaults instantly
news-qcif-best-10.avi : totem display the first image then breaks on failed assert :

totem: h264.c:2507: fill_default_ref_list:  l'assertion « best_i != -1 » a échoué.
(in ffmpeg code)
Comment 3 Stephane Loeuillet 2004-12-13 18:29:28 UTC
h324 => h264
Comment 4 Ronald Bultje 2004-12-13 19:08:29 UTC
In that case, please revert. Also, don't just add fourccs for everything, I'm
usually only adding after confirmed to work. I'm doing this exactly *because* I
want to be sure that it works - GStreamer has a bad name for stability and I'd
like to improve a bit on that.
Comment 5 Steve Baker 2004-12-13 20:22:34 UTC
In my local copy I had added VSSH to avidemux. ffdec_h264 could not decode the
VSSH files. Looking around it appears that VSSH is sufficiently different to
standard h.264 that ffmpeg cannot currently decode it. Apparently mplayer can
play them with the vss dll.

We might have more luck with other h.264 files and HEAD of ffmpeg.
Comment 6 Ronald Bultje 2004-12-16 20:34:01 UTC
With CVS, I get this assertion for VSSH:

lt-totem: h264.c:1946: mc_dir_part: Assertion `pic->data[0]' failed.

Other "plain" h264 files work fine.
Comment 7 Ronald Bultje 2005-04-21 19:05:30 UTC
No longer crashes, but still doesn't work.
Comment 8 Ronald Bultje 2005-07-20 15:42:33 UTC
Works now.