GNOME Bugzilla – Bug 61757
StockItems needed for most icons
Last modified: 2011-02-04 16:09:25 UTC
stock icons such as GTK_STOCK_ADD and GTK_STOCK_DELETE need to have full GtkStockItems created for them, so that they can be used in toolbars and such....
The idea here is that any stock icon where there is something reasonable at all for the text should have a stock icon, since it can't hurt and might help.
For the record, here is a list of all stock icons without text: GTK_STOCK_ADD GTK_STOCK_CDROM GTK_STOCK_CONVERT GTK_STOCK_DND GTK_STOCK_DND_MULTIPLE GTK_STOCK_EXECUTE GTK_STOCK_FLOPPY GTK_STOCK_GOTO_BOTTOM GTK_STOCK_GOTO_FIRST GTK_STOCK_GOTO_LAST GTK_STOCK_GOTO_TOP GTK_STOCK_GO_DOWN GTK_STOCK_GO_UP GTK_STOCK_INDEX GTK_STOCK_ITALIC GTK_STOCK_JUMP_TO GTK_STOCK_MISSING_IMAGE GTK_STOCK_REFRESH GTK_STOCK_REMOVE GTK_STOCK_SELECT_COLOR GTK_STOCK_SELECT_FONT GTK_STOCK_SORT_ASCENDING GTK_STOCK_SORT_DESCENDING GTK_STOCK_UNDELETE
I think stock items should be added for: GTK_STOCK_ADD GTK_STOCK_CDROM GTK_STOCK_CONVERT GTK_STOCK_EXECUTE GTK_STOCK_FLOPPY GTK_STOCK_GOTO_BOTTOM GTK_STOCK_GOTO_FIRST GTK_STOCK_GOTO_LAST GTK_STOCK_GOTO_TOP GTK_STOCK_GO_DOWN GTK_STOCK_GO_UP GTK_STOCK_INDEX GTK_STOCK_ITALIC GTK_STOCK_JUMP_TO GTK_STOCK_REFRESH GTK_STOCK_REMOVE GTK_STOCK_SELECT_COLOR GTK_STOCK_SELECT_FONT GTK_STOCK_SORT_ASCENDING GTK_STOCK_SORT_DESCENDING GTK_STOCK_UNDELETE (So, not for DND, DND_MULTIPLE, MISSING_IMAGE) CDROM, FLOPPY are questionable, but it doesn't hurt to have stock items for them. JUMP_TO is also questionable, but since it is an action, if we are adding items for all the other actions, we should add it is well. The GOTO_* ones should probably "First, Last" etc as the text, or at least "Go to First, Go to Last", since GOTO isn't a word. GO_UP/GO_DOWN should probably get "Up" "Down" as the text for consistency.
I think any icons that have active connotations should have stock items. That might help to decide whether GTK_STOCK_ADD (yes) and GTK_STOCK_CDROM (no) should get stock items. It occurred to me as I was working my way through the list, that the GTK_STOCK_DELETE icon is a bit misleading. It has an active name but an inactive icon. GTK_STOCK_UNDELETE shows an open trashcan with an arrow pointing out of it. I think GTK_STOCK_DELETE should be the similar but with an arrow pointing into the trashcan. Perhaps the icon associated with GTK_STOCK_DELETE could be renamed to be GTK_STOCK_TRASH or GTK_STOCK_TRASHCAN (and not get a stock item). While I have your attention ;-) I just noticed that the stock items demo doesn't always display the correct icon. For example, if I select any of the five items that appear after GTK_STOCK-DIALOG-ERROR, the error icon is displayed in the right-hand panel instead of the icon displayed with the icon name.
The error icons in the demo are because those items don't exist at the size the side image displays them at.
Created attachment 5911 [details] [review] Here's a patch for the missing stock items
The following patch implements Skips idea to separate trashcan and delete. It has to be completed by adding a stock_delete.png icon to gtk/stock-icons. An inital approximation could be achieved by cp stock_trash.png stock_delete.png
Created attachment 5912 [details] [review] trash-adding patch
Please go ahead and commit the addition of the missing icons. I don't think separation of trash-can and delete makes sense because I don't think a trash can icon as distinct from a delete icon is useful enough to add. If the delete icon isn't good enough, then we should fix it.