GNOME Bugzilla – Bug 610179
GDM patch for accounts dialogue
Last modified: 2010-06-15 21:22:22 UTC
Created attachment 153947 [details] [review] patch from mclasen GDM patch to enable the user accounts dialogue to work.
Created attachment 153950 [details] [review] Use accounts service in the simple greeter Rebased from 2.28.2 to master by Bastien Nocera <hadess@hadess.net>
Created attachment 154473 [details] [review] Another iteration of the patch I moved around functions and dropped some spurious changes. This is just to make it a little easier to review and update.
Created attachment 154475 [details] [review] Churn, churn This iteration makes the user switch applet compile and makes user switching work again. Next up is to hook back up include/exclude lists (arguably they should be done on the accounts service side, and they can, but we might as well keep the gdm config options working) and add some fallback behavior for when org.freedesktop.Accounts isn't available. We can drop the fallbacks once accountsservice has gained more adoption.
Created attachment 154986 [details] [review] chugachugachuga This adds back include/exclude lists and starts to add back the bits needed to handle if the service isn't available, and does more small changes to make the patch more readable. Next up will be fixing icons in the no accountsservice case, and also breaking this patch up into logically separate incremental chunks.
Created attachment 155170 [details] [review] Use accounts service in the simple greeter Rebased from 2.28.2 to master by Bastien Nocera <hadess@hadess.net>
(In reply to comment #5) > Created an attachment (id=155170) [details] [review] > Use accounts service in the simple greeter > > Rebased from 2.28.2 to master by Bastien Nocera <hadess@hadess.net> This fixes icons in the no service case and few other miscellaneous issues. Next up will be breaking the patch up into logical sequential commits.
Created attachment 156248 [details] [review] change split up This patch cleans things up further, and also splits the changes up into 21 commits. I need to do some testing to make sure it still works. Also, each commit needs a more thoughtful commit message.
Created attachment 160908 [details] [review] slightly updated version This is a slightly updated version. It fixes some bugs that were found in fedora shortly after landing attachment 156248 [details] [review] there.
I'm rebasing these patches on top of the ones in bug #620908.
Created attachment 163009 [details] [review] Add new gdm_user_is_logged_in method Before we were doing if (gdm_user_get_num_sessions > 0) all over the place. This is slightly more clear.
Created attachment 163010 [details] [review] Move get_primary_session_id to gdm-user.h It makes more sense there, and this will allow us to drop get_sessions eventually.
Created attachment 163011 [details] [review] Don't track manager from user object We don't need it, and it's a bit backward anyway.
Created attachment 163012 [details] [review] Drop user properties in favor of a "changed" signal This is less specific, but good enough, and will make changing out the backend easier.
Created attachment 163013 [details] [review] drop sessions_changed class member We're never going to have a default handler, we aren't going to have subclasses that need to chain up, so we don't need the vfunc.
Created attachment 163014 [details] [review] Drop get_sessions We don't need it now.
Created attachment 163015 [details] [review] Drop get_shell and get_home_directory They aren't used, so let's cull them.
Created attachment 163016 [details] [review] drop loading-users signal No one listens for it, so there's no point in having it.
Created attachment 163017 [details] [review] Drop "user-login-frequency-changed" signal in favor of "changed" It's less specific and will let us handle the other properties changes at the same time.
Created attachment 163018 [details] [review] Rename users hashtable to user_by_name This will lend us the flexibility to index users by other criteria later.
Created attachment 163019 [details] [review] move local user monitoring code to its own function It was open coded in _init before.
Created attachment 163020 [details] [review] rearrange gdm_user_collate This way we don't make unnecessary assignments
Created attachment 163021 [details] [review] Get dbus connection outside of get_seat_proxy While having a connection is a prerequisite for get_seat_proxy, it could potentially be useful for other purposes, so move it out.
Created attachment 163022 [details] [review] Rename on_proxy_destroy to on_seat_proxy_destroy
Created attachment 163023 [details] [review] Drop unused defines
Created attachment 163024 [details] [review] rename update to update_from_pwent it's less ambiguous
Created attachment 163025 [details] [review] Get users from account service, fallback to old way
Created attachment 163026 [details] [review] Don't crash when adding multiple user switchers Before we were blowing an assertion because settings client was getting initialized twice.
Created attachment 163131 [details] [review] Add new gdm_user_is_logged_in method Before we were doing if (gdm_user_get_num_sessions > 0) all over the place. This is slightly more clear.
Created attachment 163132 [details] [review] Move get_primary_session_id to gdm-user.h It makes more sense there, and this will allow us to drop get_sessions eventually.
Created attachment 163133 [details] [review] Don't track manager from user object We don't need it, and it's a bit backward anyway.
Created attachment 163134 [details] [review] Drop user properties in favor of a "changed" signal This is less specific, but good enough, and will make changing out the backend easier.
Created attachment 163135 [details] [review] drop sessions_changed class member We're never going to have a default handler, we aren't going to have subclasses that need to chain up, so we don't need the vfunc.
Created attachment 163136 [details] [review] Drop get_sessions We don't need it now.
Created attachment 163137 [details] [review] Drop get_shell and get_home_directory They aren't used, so let's cull them.
Created attachment 163138 [details] [review] drop loading-users signal No one listens for it, so there's no point in having it.
Created attachment 163139 [details] [review] Drop "user-login-frequency-changed" signal in favor of "changed" It's less specific and will let us handle the other properties changes at the same time.
Created attachment 163140 [details] [review] Rename users hashtable to user_by_name This will lend us the flexibility to index users by other criteria later.
Created attachment 163141 [details] [review] move local user monitoring code to its own function It was open coded in _init before.
Created attachment 163142 [details] [review] rearrange gdm_user_collate This way we don't make unnecessary assignments
Created attachment 163143 [details] [review] Get dbus connection outside of get_seat_proxy While having a connection is a prerequisite for get_seat_proxy, it could potentially be useful for other purposes, so move it out.
Created attachment 163144 [details] [review] Rename on_proxy_destroy to on_seat_proxy_destroy
Created attachment 163145 [details] [review] Drop unused defines
Created attachment 163146 [details] [review] rename update to update_from_pwent it's less ambiguous
Created attachment 163147 [details] [review] Get users from account service, fallback to old way
Created attachment 163148 [details] [review] Don't crash when adding multiple user switchers Before we were blowing an assertion because settings client was getting initialized twice.
Created attachment 163354 [details] [review] Get users from account service, fallback to old way
Committed the rest and rebased this on master.